summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/nautilus
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-11-14 20:49:26 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-14 20:02:48 -0800
commit08c0f579f251bc3d12d4d770df604423105c2a82 (patch)
tree3d3047a7892a960e8a5497580cc7e1466c67f3b4 /meta-gnome/recipes-gnome/nautilus
parent5c2988207d6a29dc22f3d1f5d3c6955046c95e34 (diff)
downloadmeta-openembedded-08c0f579f251bc3d12d4d770df604423105c2a82.tar.gz
nautilus: upgrade 3.18.5 -> 3.34.1
bumping high requires rewrite from scratch almost: * meson-build * remove backported patch Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/nautilus')
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch40
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb33
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb32
3 files changed, 32 insertions, 73 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch b/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch
deleted file mode 100644
index f19eb49798..0000000000
--- a/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From a4ed38e95cbe07f02028249b8b315565a5ac1e43 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 5 May 2018 22:32:45 -0700
4Subject: [PATCH] nautilus: drop gnome-desktop thumbnail API with new
5 gdk-pixbuf
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10If gdk-pixbuf >= 2.36.5 is available, its scaling API can do what we
11want, so we don’t need to use the deprecated gnome-desktop one.
12
13Also fixes compile errors seen on master
14nautilus-properties-window.c:5101: undefined reference to `gnome_desktop_thumbnail_scale_down_pixbuf'
15
16Upstream-Status: Backport
17
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
19---
20 src/nautilus-properties-window.c | 5 +++--
21 1 file changed, 3 insertions(+), 2 deletions(-)
22
23diff --git a/src/nautilus-properties-window.c b/src/nautilus-properties-window.c
24index dea8b0f..fad9bd1 100644
25--- a/src/nautilus-properties-window.c
26+++ b/src/nautilus-properties-window.c
27@@ -5098,10 +5098,11 @@ update_preview_callback (GtkFileChooser *icon_chooser,
28 scale = (double)gdk_pixbuf_get_height (pixbuf) /
29 gdk_pixbuf_get_width (pixbuf);
30
31- scaled_pixbuf = gnome_desktop_thumbnail_scale_down_pixbuf
32+ scaled_pixbuf = gdk_pixbuf_scale_simple
33 (pixbuf,
34 PREVIEW_IMAGE_WIDTH,
35- scale * PREVIEW_IMAGE_WIDTH);
36+ scale * PREVIEW_IMAGE_WIDTH,
37+ GDK_INTERP_HYPER);
38 g_object_unref (pixbuf);
39 pixbuf = scaled_pixbuf;
40 }
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb
deleted file mode 100644
index bdb2f3c884..0000000000
--- a/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SUMMARY = "File manager for GNOME"
2SECTION = "x11/gnome"
3
4LICENSE="GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=36cf660aea2b8beffba7945f44a7e748 \
6 file://COPYING.EXTENSIONS;md5=7579d6678402a1868631bf82c93ff0d4 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9inherit distro_features_check autotools pkgconfig gobject-introspection
10
11MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
12SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/nautilus/${MAJ_VER}/nautilus-${PV}.tar.xz \
13 file://0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch \
14 "
15
16SRC_URI[md5sum] = "0f578bda5655c0ce204befafca5803d7"
17SRC_URI[sha256sum] = "60a927c0522b4cced9d8f62baed2ee5e2fd4305be4523eb5bc44805971a6cc15"
18
19DEPENDS = "gtk+3 gnome-desktop3 gsettings-desktop-schemas glib-2.0-native intltool-native pango"
20
21REQUIRED_DISTRO_FEATURES = "x11"
22
23EXTRA_OECONF = " \
24 --disable-gtk-doc \
25 --disable-update-mimedb \
26 --disable-nst-extension \
27 --enable-tracker=no \
28 --disable-schemas-compile \
29 --enable-xmp=no \
30 --enable-libexif=no \
31"
32
33FILES_${PN} += "${datadir}/*"
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb
new file mode 100644
index 0000000000..342c59d6d9
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "File manager for GNOME"
2SECTION = "x11/gnome"
3
4LICENSE="GPLv3"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
6
7GNOMEBASEBUILDCLASS = "meson"
8
9DEPENDS = " \
10 fontconfig \
11 gtk+3 \
12 gnome-desktop3 \
13 gsettings-desktop-schemas \
14 gnome-autoar \
15 tracker \
16"
17
18inherit gnomebase gobject-introspection gtk-doc gettext distro_features_check
19
20SRC_URI[archive.md5sum] = "19e4f1d89fb9d0ff135d5b1974ce43b5"
21SRC_URI[archive.sha256sum] = "37ce2c16a610c589dcc7660f9092446465568e38e29bce6ed8c24f2e8e0077f3"
22
23REQUIRED_DISTRO_FEATURES = "x11"
24
25PACKAGECONFIG = "extensions"
26PACKAGECONFIG[extensions] = "-Dextensions=true,-Dextensions=false, gexiv2 gstreamer1.0-plugins-base"
27
28FILES_${PN} += " \
29 ${datadir}/dbus-1 \
30 ${datadir}/metainfo \
31 ${datadir}/gnome-shell \
32"