diff options
3 files changed, 32 insertions, 73 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch b/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch deleted file mode 100644 index f19eb49798..0000000000 --- a/meta-gnome/recipes-gnome/nautilus/nautilus/0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From a4ed38e95cbe07f02028249b8b315565a5ac1e43 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 5 May 2018 22:32:45 -0700 | ||
4 | Subject: [PATCH] nautilus: drop gnome-desktop thumbnail API with new | ||
5 | gdk-pixbuf | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | If gdk-pixbuf >= 2.36.5 is available, its scaling API can do what we | ||
11 | want, so we don’t need to use the deprecated gnome-desktop one. | ||
12 | |||
13 | Also fixes compile errors seen on master | ||
14 | nautilus-properties-window.c:5101: undefined reference to `gnome_desktop_thumbnail_scale_down_pixbuf' | ||
15 | |||
16 | Upstream-Status: Backport | ||
17 | |||
18 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
19 | --- | ||
20 | src/nautilus-properties-window.c | 5 +++-- | ||
21 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
22 | |||
23 | diff --git a/src/nautilus-properties-window.c b/src/nautilus-properties-window.c | ||
24 | index dea8b0f..fad9bd1 100644 | ||
25 | --- a/src/nautilus-properties-window.c | ||
26 | +++ b/src/nautilus-properties-window.c | ||
27 | @@ -5098,10 +5098,11 @@ update_preview_callback (GtkFileChooser *icon_chooser, | ||
28 | scale = (double)gdk_pixbuf_get_height (pixbuf) / | ||
29 | gdk_pixbuf_get_width (pixbuf); | ||
30 | |||
31 | - scaled_pixbuf = gnome_desktop_thumbnail_scale_down_pixbuf | ||
32 | + scaled_pixbuf = gdk_pixbuf_scale_simple | ||
33 | (pixbuf, | ||
34 | PREVIEW_IMAGE_WIDTH, | ||
35 | - scale * PREVIEW_IMAGE_WIDTH); | ||
36 | + scale * PREVIEW_IMAGE_WIDTH, | ||
37 | + GDK_INTERP_HYPER); | ||
38 | g_object_unref (pixbuf); | ||
39 | pixbuf = scaled_pixbuf; | ||
40 | } | ||
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb deleted file mode 100644 index bdb2f3c884..0000000000 --- a/meta-gnome/recipes-gnome/nautilus/nautilus_3.18.5.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | SUMMARY = "File manager for GNOME" | ||
2 | SECTION = "x11/gnome" | ||
3 | |||
4 | LICENSE="GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=36cf660aea2b8beffba7945f44a7e748 \ | ||
6 | file://COPYING.EXTENSIONS;md5=7579d6678402a1868631bf82c93ff0d4 \ | ||
7 | file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" | ||
8 | |||
9 | inherit distro_features_check autotools pkgconfig gobject-introspection | ||
10 | |||
11 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" | ||
12 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/nautilus/${MAJ_VER}/nautilus-${PV}.tar.xz \ | ||
13 | file://0001-nautilus-drop-gnome-desktop-thumbnail-API-with-new-g.patch \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[md5sum] = "0f578bda5655c0ce204befafca5803d7" | ||
17 | SRC_URI[sha256sum] = "60a927c0522b4cced9d8f62baed2ee5e2fd4305be4523eb5bc44805971a6cc15" | ||
18 | |||
19 | DEPENDS = "gtk+3 gnome-desktop3 gsettings-desktop-schemas glib-2.0-native intltool-native pango" | ||
20 | |||
21 | REQUIRED_DISTRO_FEATURES = "x11" | ||
22 | |||
23 | EXTRA_OECONF = " \ | ||
24 | --disable-gtk-doc \ | ||
25 | --disable-update-mimedb \ | ||
26 | --disable-nst-extension \ | ||
27 | --enable-tracker=no \ | ||
28 | --disable-schemas-compile \ | ||
29 | --enable-xmp=no \ | ||
30 | --enable-libexif=no \ | ||
31 | " | ||
32 | |||
33 | FILES_${PN} += "${datadir}/*" | ||
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb new file mode 100644 index 0000000000..342c59d6d9 --- /dev/null +++ b/meta-gnome/recipes-gnome/nautilus/nautilus_3.34.1.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "File manager for GNOME" | ||
2 | SECTION = "x11/gnome" | ||
3 | |||
4 | LICENSE="GPLv3" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | |||
7 | GNOMEBASEBUILDCLASS = "meson" | ||
8 | |||
9 | DEPENDS = " \ | ||
10 | fontconfig \ | ||
11 | gtk+3 \ | ||
12 | gnome-desktop3 \ | ||
13 | gsettings-desktop-schemas \ | ||
14 | gnome-autoar \ | ||
15 | tracker \ | ||
16 | " | ||
17 | |||
18 | inherit gnomebase gobject-introspection gtk-doc gettext distro_features_check | ||
19 | |||
20 | SRC_URI[archive.md5sum] = "19e4f1d89fb9d0ff135d5b1974ce43b5" | ||
21 | SRC_URI[archive.sha256sum] = "37ce2c16a610c589dcc7660f9092446465568e38e29bce6ed8c24f2e8e0077f3" | ||
22 | |||
23 | REQUIRED_DISTRO_FEATURES = "x11" | ||
24 | |||
25 | PACKAGECONFIG = "extensions" | ||
26 | PACKAGECONFIG[extensions] = "-Dextensions=true,-Dextensions=false, gexiv2 gstreamer1.0-plugins-base" | ||
27 | |||
28 | FILES_${PN} += " \ | ||
29 | ${datadir}/dbus-1 \ | ||
30 | ${datadir}/metainfo \ | ||
31 | ${datadir}/gnome-shell \ | ||
32 | " | ||