summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2023-09-30 00:26:59 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-30 01:03:17 -0700
commitc63a101cf99ebf2af265c073509fa45d8d71c525 (patch)
tree313a5b64e6fddbe19734cbc650c0e73d144ecf85 /meta-filesystems
parentae8faf852988cfed875e8bc73c911b89f3d052ad (diff)
downloadmeta-openembedded-c63a101cf99ebf2af265c073509fa45d8d71c525.tar.gz
overlayfs-tools: Install fsck binary
Two projects, overlayfs-tools and overlayfs-progs, were combined upstream. Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch32
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb32
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb5
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb2
4 files changed, 2 insertions, 69 deletions
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch
deleted file mode 100644
index 2c001834b..000000000
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs/0001-Makefile-proper-location-of-LDFLAGS.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 8eeaee82dcfdf47f16ad880e416b722827f41bdb Mon Sep 17 00:00:00 2001
2From: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
3Date: Mon, 23 May 2022 19:37:32 +0200
4Subject: [PATCH] Makefile: proper location of LDFLAGS
5
6Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
7---
8Upstream-Status: Pending
9
10 Makefile | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/Makefile b/Makefile
14index e3c5207..14b155e 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -1,5 +1,5 @@
18 CFLAGS = -Wall -g
19-LFLAGS = -lm
20+LDFLAGS = -lm
21 CC = gcc
22
23 all: overlay
24@@ -7,7 +7,7 @@ all: overlay
25 objects = fsck.o common.o lib.o check.o mount.o path.o overlayfs.o
26
27 overlay: $(objects)
28- $(CC) $(LFLAGS) $(objects) -o fsck.overlay
29+ $(CC) $(objects) -o fsck.overlay $(LDFLAGS)
30
31 .c.o:
32 $(CC) $(CFLAGS) -c $<
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb
deleted file mode 100644
index 9d58b9a63..000000000
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-progs_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "File system check utility for OverlayFS"
2HOMEPAGE = "https://github.com/hisilicon/overlayfs-progs"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
5
6SRC_URI = "\
7 git://github.com/hisilicon/overlayfs-progs.git;protocol=https;branch=master \
8 file://0001-Makefile-proper-location-of-LDFLAGS.patch \
9"
10
11PV = "1.0+git${SRCPV}"
12SRCREV = "e10ef686570d9c7eff42f52461593a5c15da56bd"
13
14S = "${WORKDIR}/git"
15B = "${S}"
16
17# Required to have the fts.h header for musl
18DEPENDS:append:libc-musl = " fts"
19# Fix the missing fts libs when using musl
20EXTRA_OEMAKE:append:libc-musl = " LDFLAGS='-lfts'"
21
22EXTRA_OEMAKE += "'CC=${CC} -O2' "
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25do_compile () {
26 oe_runmake
27}
28
29do_install () {
30 install -d ${D}${bindir}
31 install -m 0755 ${B}/fsck.overlay ${D}${bindir}
32}
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
index de5155133..ca2ec9cc4 100644
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
+++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
@@ -21,11 +21,8 @@ EXTRA_OEMAKE += "'CC=${CC} -O2'"
21EXTRA_OEMAKE:append:libc-musl = " LDLIBS=-lfts" 21EXTRA_OEMAKE:append:libc-musl = " LDLIBS=-lfts"
22TARGET_CC_ARCH += "${LDFLAGS}" 22TARGET_CC_ARCH += "${LDFLAGS}"
23 23
24do_compile () {
25 oe_runmake
26}
27
28do_install () { 24do_install () {
29 install -d ${D}${bindir} 25 install -d ${D}${bindir}
30 install -m 0755 ${B}/overlay ${D}${bindir} 26 install -m 0755 ${B}/overlay ${D}${bindir}
27 install -m 0755 ${B}/fsck.overlay ${D}${bindir}
31} 28}
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
index fdfe04574..cfb6e4fd8 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb
@@ -28,7 +28,7 @@ RDEPENDS:${PN} += "\
28 e2fsprogs-resize2fs \ 28 e2fsprogs-resize2fs \
29 libaio \ 29 libaio \
30 libcap-bin \ 30 libcap-bin \
31 overlayfs-progs \ 31 overlayfs-tools \
32 perl \ 32 perl \
33 python3 \ 33 python3 \
34 python3-core \ 34 python3-core \