summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2023-09-30 00:26:58 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-30 01:03:17 -0700
commitae8faf852988cfed875e8bc73c911b89f3d052ad (patch)
treeeaa5e4b96c22c56da9f3f8db15d4617051a3a777 /meta-filesystems
parentba46d91d3958a41e321c649a967e2d1ccd605ed8 (diff)
downloadmeta-openembedded-ae8faf852988cfed875e8bc73c911b89f3d052ad.tar.gz
overlayfs-tools: Bump up the version
Drop the patches, they have been merged upstream. Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch43
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0002-makefile-fix-linking-flags.patch33
-rw-r--r--meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb4
3 files changed, 1 insertions, 79 deletions
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
deleted file mode 100644
index ed84d92c7..000000000
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 81b4fbb5f52044cb348534c23f10b3884972b09b Mon Sep 17 00:00:00 2001
2From: Beat Schaer <beat.schaer@wabtec.com>
3Date: Fri, 19 Mar 2021 08:18:58 +0100
4Subject: [PATCH] Fixed includes so that it compiles on Ubuntu 20.04
5
6---
7Upstream-Status: Pending
8
9 logic.c | 3 +--
10 main.c | 3 ++-
11 2 files changed, 3 insertions(+), 3 deletions(-)
12
13diff --git a/logic.c b/logic.c
14index 97767f5..47ebfaa 100644
15--- a/logic.c
16+++ b/logic.c
17@@ -7,8 +7,7 @@
18 #include <string.h>
19 #include <errno.h>
20 #include <unistd.h>
21-#include <attr/xattr.h>
22-#include <attr/attributes.h>
23+#include <sys/xattr.h>
24 #include <fts.h>
25 #include <libgen.h>
26 #include "logic.h"
27diff --git a/main.c b/main.c
28index aa11239..f462b98 100644
29--- a/main.c
30+++ b/main.c
31@@ -12,7 +12,8 @@
32 #include <linux/limits.h>
33 #include <stdbool.h>
34 #include <sys/stat.h>
35-#include <attr/xattr.h>
36+#include <sys/xattr.h>
37+#include <errno.h>
38 #ifndef _SYS_STAT_H
39 #include <linux/stat.h>
40 #endif
41--
422.25.1
43
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0002-makefile-fix-linking-flags.patch b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0002-makefile-fix-linking-flags.patch
deleted file mode 100644
index 8fbb250f0..000000000
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools/0002-makefile-fix-linking-flags.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From b4ff5886797e72d1c21da43261ca7648412f3186 Mon Sep 17 00:00:00 2001
2From: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
3Date: Mon, 23 May 2022 19:53:21 +0200
4Subject: [PATCH] makefile: fix linking flags
5
6LDLIBS should be placed at the end according to
7https://www.gnu.org/software/make/manual/html_node/Catalogue-of-Rules.html
8
9Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
10---
11Upstream-Status: Pending
12
13 makefile | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/makefile b/makefile
17index fb1bed4..038c7ce 100644
18--- a/makefile
19+++ b/makefile
20@@ -1,11 +1,11 @@
21 CFLAGS = -Wall -std=c99
22-LFLAGS = -lm
23+LDLIBS = -lm
24 CC = gcc
25
26 all: overlay
27
28 overlay: main.o logic.o sh.o
29- $(CC) $(LFLAGS) main.o logic.o sh.o -o overlay
30+ $(CC) main.o logic.o sh.o -o overlay $(LDLIBS)
31
32 main.o: main.c logic.h
33 $(CC) $(CFLAGS) -c main.c
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
index c638be9af..de5155133 100644
--- a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
+++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
@@ -5,12 +5,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69"
5 5
6SRC_URI = "\ 6SRC_URI = "\
7 git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \ 7 git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \
8 file://0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch \
9 file://0002-makefile-fix-linking-flags.patch \
10" 8"
11 9
12PV = "1.0+git${SRCPV}" 10PV = "1.0+git${SRCPV}"
13SRCREV = "291c7f4a3fb548d06c572700650c2e3bccb0cd27" 11SRCREV = "b5e5a829895ac98ccfe4629fbfbd8b819262bd00"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16B = "${S}" 14B = "${S}"