summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-03-27 10:03:27 +0200
committerKhem Raj <raj.khem@gmail.com>2024-03-27 07:57:30 -0700
commitd46d2caa25a0de13bec29f7393a98f6c557469d4 (patch)
treefff9488fab4e99e5ff2b9f59239fb81495c78caf
parent063cde60409b15f4262f6633f5fc9291ccc6e9f6 (diff)
downloadmeta-openembedded-d46d2caa25a0de13bec29f7393a98f6c557469d4.tar.gz
python3-typeguard: Upgrade 4.1.5 -> 4.2.1
Upgrade to version 4.2.1: - Fixed missing typing_extensions dependency for Python 3.12 - Fixed deprecation warning in the test suite on Python 3.13 - Added support for specifying options for the pytest plugin via pytest config files - Avoid creating reference cycles when type checking unions - Fixed Optional[...] being removed from the AST if it was located within a subscript - Fixed TypedDict from typing_extensions not being recognized as one - Fixed typing types (dict[str, int], List[str], etc.) not passing checks against type or Type - Fixed detection of optional fields (NotRequired[...]) in TypedDict when using forward references - Fixed mapping checks against Django's MultiValueDict Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb (renamed from meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb)4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb
index 1e9f6685d..e0e84df28 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_4.1.5.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5 5
6SRC_URI[sha256sum] = "ea0a113bbc111bcffc90789ebb215625c963411f7096a7e9062d4e4630c155fd" 6SRC_URI[sha256sum] = "c556a1b95948230510070ca53fa0341fb0964611bd05d598d87fb52115d65fee"
7 7
8inherit pypi python_setuptools_build_meta ptest 8inherit pypi python_setuptools_build_meta ptest
9 9
@@ -12,8 +12,10 @@ SRC_URI += " \
12" 12"
13 13
14RDEPENDS:${PN} += " \ 14RDEPENDS:${PN} += " \
15 python3-core \
15 python3-compression \ 16 python3-compression \
16 python3-unittest \ 17 python3-unittest \
18 python3-typing-extensions \
17" 19"
18 20
19RDEPENDS:${PN}-ptest += " \ 21RDEPENDS:${PN}-ptest += " \