summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb
new file mode 100644
index 000000000..e0e84df28
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.2.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
6SRC_URI[sha256sum] = "c556a1b95948230510070ca53fa0341fb0964611bd05d598d87fb52115d65fee"
7
8inherit pypi python_setuptools_build_meta ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN} += " \
15 python3-core \
16 python3-compression \
17 python3-unittest \
18 python3-typing-extensions \
19"
20
21RDEPENDS:${PN}-ptest += " \
22 python3-pytest \
23 python3-typing-extensions \
24 python3-unittest-automake-output \
25 python3-unixadmin \
26 python3-mypy \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32}
33
34DEPENDS += "\
35 python3-distutils-extra-native \
36 python3-setuptools-scm-native \
37"
38
39BBCLASSEXTEND = "native nativesdk"