summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-09-13 13:37:36 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:01:41 -0700
commitcff2f38874166085fe2b6cf8a75c53fe9a3a231c (patch)
treef65f65e90e7c999c7c37ab725f84184c7df3e1d1
parente5c84d8365f4d56c01aafe2ceee11d198adf4d30 (diff)
downloadmeta-openembedded-cff2f38874166085fe2b6cf8a75c53fe9a3a231c.tar.gz
spice: fix compile error on 32bit system
Fix below compile error on 32bit system, since input argument is uLong, but use format %d: format '%d' expects argument of type 'int', but argument 6 has type 'long unsigned int' [-Werror=format=] Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch36
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch b/meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch
new file mode 100644
index 000000000..1f9d5fdd7
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice/0001-spice-fix-compile-fail-problem.patch
@@ -0,0 +1,36 @@
1From 7023732c65b4dc509c46a54fb7715da275b5597f Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Thu, 13 Sep 2018 12:39:44 +0800
4Subject: [PATCH] spice: fix compile fail problem
5
6compile error:
7format '%d' expects argument of type 'int', but argument 6 has
8type 'long unsigned int' [-Werror=format=]
9
10spice compile failed on 32bit system, since upstream commit
119541cd2fe(in V0.14.1) change %ld to %PRIdPTR, %PRIdPTR is %d, but argument
12strm.total_out is uLong.
13
14Upstream-Status: Submitted[https://github.com/freedesktop/spice/pull/1]
15
16Signed-off-by: Changqing Li <changqing.li@windriver.com>
17---
18 server/red-replay-qxl.c | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/server/red-replay-qxl.c b/server/red-replay-qxl.c
22index 1fce76c..bd33b58 100644
23--- a/server/red-replay-qxl.c
24+++ b/server/red-replay-qxl.c
25@@ -266,7 +266,7 @@ static replay_t read_binary(SpiceReplay *replay, const char *prefix, size_t *siz
26 exit(1);
27 }
28 if ((ret = inflate(&strm, Z_NO_FLUSH)) != Z_STREAM_END) {
29- spice_error("inflate error %d (disc: %" PRIdPTR ")", ret, *size - strm.total_out);
30+ spice_error("inflate error %d (disc: %ld)", ret, *size - strm.total_out);
31 if (ret == Z_DATA_ERROR) {
32 /* last operation may be wrong. since we do the recording
33 * in red_worker, when there is a shutdown from the vcpu/io thread
34--
352.7.4
36
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 871bb0fe9..c7e4b0329 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -24,6 +24,7 @@ SRC_URI = " \
24 git://anongit.freedesktop.org/spice/spice;name=spice \ 24 git://anongit.freedesktop.org/spice/spice;name=spice \
25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \ 25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \
26 file://0001-Convert-pthread_t-to-be-numeric.patch \ 26 file://0001-Convert-pthread_t-to-be-numeric.patch \
27 file://0001-spice-fix-compile-fail-problem.patch \
27" 28"
28 29
29FOO = "\ 30FOO = "\