summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-12 21:50:59 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:01:41 -0700
commite5c84d8365f4d56c01aafe2ceee11d198adf4d30 (patch)
treec665c5b3c01d4231f9cd9d1f87b95af1c92720c2
parent5028479bffdf81c265a108409d9fbbdf12454bb9 (diff)
downloadmeta-openembedded-e5c84d8365f4d56c01aafe2ceee11d198adf4d30.tar.gz
kexec-tools-klibc: Deliberately add -O2
This helps the compiler to be more aggressive and do the expected optimizations to remove unused code which otherwise gets flagged on some architectures e.g. armv7l errors like undefined reference to `bad_unaligned_access_length' Also see http://lists.infradead.org/pipermail/kexec/2009-August/003488.html Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
index fe3467198..25f5da48d 100644
--- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb
@@ -60,7 +60,7 @@ EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
60 60
61# fix purgatory/printf.c:2:10: fatal error: limits.h: No such file or directory 61# fix purgatory/printf.c:2:10: fatal error: limits.h: No such file or directory
62# fix include/limits.h:42:10: fatal error: bitsize/limits.h: No such file or directory 62# fix include/limits.h:42:10: fatal error: bitsize/limits.h: No such file or directory
63COMMON_CFLAGS += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${S}/purgatory/include" 63COMMON_CFLAGS += "-O2 -I${STAGING_DIR_HOST}${libdir}/klibc/include -I${S}/purgatory/include"
64CFLAGS_x86_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" 64CFLAGS_x86_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32"
65CFLAGS_x86-64_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64" 65CFLAGS_x86-64_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64"
66CFLAGS_arm_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" 66CFLAGS_arm_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32"