summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-12 12:33:43 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-12 08:57:34 -0700
commitcf4bf3f13aeec49072d6e6c24e1ff005236e94c2 (patch)
tree7c83e8b7c27c94f94605de8eacc4a9ca3651a0d0
parentb4980bfc97916f4896ac4a723f9a35a675c4228c (diff)
downloadmeta-openembedded-cf4bf3f13aeec49072d6e6c24e1ff005236e94c2.tar.gz
python3-ecdsa: enable ptest and add missing runtime dependency
* Ptest and library example tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_SLOW_META_PYTHON Ptest result: ============= qemux86-64: Testsuite summary TOTAL: 1976 PASS: 1972 SKIP: 4 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 292 END: /usr/lib/python3-ecdsa/ptest 2024-04-12T09:18 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 1976 PASS: 1972 SKIP: 4 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 236 END: /usr/lib/python3-ecdsa/ptest 2024-04-12T09:05 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb27
3 files changed, 27 insertions, 4 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 6bd48156d..c54df5090 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -87,6 +87,7 @@ PTESTS_FAST_META_PYTHON = "\
87 87
88PTESTS_SLOW_META_PYTHON = "\ 88PTESTS_SLOW_META_PYTHON = "\
89 python3-arrow \ 89 python3-arrow \
90 python3-ecdsa \
90 python3-google-auth \ 91 python3-google-auth \
91 python3-lz4 \ 92 python3-lz4 \
92 python3-marshmallow \ 93 python3-marshmallow \
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa/run-ptest b/meta-python/recipes-devtools/python/python3-ecdsa/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ecdsa/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
index 5b4f7eb93..8e967f925 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
@@ -6,12 +6,31 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
6PYPI_PACKAGE = "ecdsa" 6PYPI_PACKAGE = "ecdsa"
7SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8" 7SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8"
8 8
9inherit pypi setuptools3 python3native 9inherit pypi setuptools3 python3native ptest
10 10
11RDEPENDS:${PN} += "python3-six python3-gmpy2" 11SRC_URI += " \
12 file://run-ptest \
13"
12 14
13BBCLASSEXTEND = "native nativesdk" 15RDEPENDS:${PN}-ptest += " \
16 python3-hypothesis \
17 python3-pytest \
18 python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/src/ecdsa/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN} += " \
27 python3-gmpy2 \
28 python3-json \
29 python3-six \
30"
14 31
15do_install:append() { 32do_install:append() {
16 rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py 33 rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py
17} 34}
35
36BBCLASSEXTEND = "native nativesdk"