summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-12 16:16:33 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-12 08:57:34 -0700
commitb4980bfc97916f4896ac4a723f9a35a675c4228c (patch)
tree7372692cae965dfb5070f9ba5e42a4ce36d5ec9f
parent2f30540742cbcfdfdcc5beb6482b304d8643f230 (diff)
downloadmeta-openembedded-b4980bfc97916f4896ac4a723f9a35a675c4228c.tar.gz
libcoap: fix CVE-2024-0962
CVE-2024-0962: A vulnerability was found in obgm libcoap 4.3.4. It has been rated as critical. Affected by this issue is the function get_split_entry of the file src/coap_oscore.c of the component Configuration File Handler. The manipulation leads to stack-based buffer overflow. Upstream-Status: Backport [https://github.com/obgm/libcoap/pull/1311] WARNING: libcoap-4.3.4-r0 do_cve_check: Found unpatched CVE (CVE-2024-0962) This vulnerability is only exist in 4.3.4. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/libcoap/libcoap/CVE-2024-0962.patch45
-rw-r--r--meta-networking/recipes-devtools/libcoap/libcoap_4.3.4.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/libcoap/libcoap/CVE-2024-0962.patch b/meta-networking/recipes-devtools/libcoap/libcoap/CVE-2024-0962.patch
new file mode 100644
index 000000000..add52483b
--- /dev/null
+++ b/meta-networking/recipes-devtools/libcoap/libcoap/CVE-2024-0962.patch
@@ -0,0 +1,45 @@
1From bf6a303883bde40cf96b960c8574cddd89e71701 Mon Sep 17 00:00:00 2001
2From: Jon Shallow <supjps-libcoap@jpshallow.com>
3Date: Thu, 25 Jan 2024 18:03:17 +0000
4Subject: [PATCH] coap_oscore.c: Fix parsing OSCORE configuration information
5
6A vulnerability was found in obgm libcoap 4.3.4. It has been rated as critical.
7Affected by this issue is the function get_split_entry of the file src/coap_oscore.c of the component Configuration File Handler.
8The manipulation leads to stack-based buffer overflow.
9
10CVE: CVE-2024-0962
11
12Upstream-Status: Backport [https://github.com/obgm/libcoap/pull/1311]
13
14Signed-off-by: alperak <alperyasinak1@gmail.com>
15---
16 src/coap_oscore.c | 5 +++--
17 1 file changed, 3 insertions(+), 2 deletions(-)
18
19diff --git a/src/coap_oscore.c b/src/coap_oscore.c
20index 83f785c92..e0fb22947 100644
21--- a/src/coap_oscore.c
22+++ b/src/coap_oscore.c
23@@ -1678,11 +1678,12 @@ get_split_entry(const char **start,
24 oscore_value_t *value) {
25 const char *begin = *start;
26 const char *end;
27+ const char *kend;
28 const char *split;
29 size_t i;
30
31 retry:
32- end = memchr(begin, '\n', size);
33+ kend = end = memchr(begin, '\n', size);
34 if (end == NULL)
35 return 0;
36
37@@ -1693,7 +1694,7 @@ get_split_entry(const char **start,
38
39 if (begin[0] == '#' || (end - begin) == 0) {
40 /* Skip comment / blank line */
41- size -= end - begin + 1;
42+ size -= kend - begin + 1;
43 begin = *start;
44 goto retry;
45 }
diff --git a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.4.bb b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.4.bb
index 20bdbee25..98f0f02fb 100644
--- a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.4.bb
+++ b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.4.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1978dbc41673ab1c20e64b287c8317bc"
9 9
10SRC_URI = "git://github.com/obgm/libcoap.git;branch=main;protocol=https \ 10SRC_URI = "git://github.com/obgm/libcoap.git;branch=main;protocol=https \
11 file://run-ptest \ 11 file://run-ptest \
12 file://CVE-2024-0962.patch \
12 " 13 "
13SRCREV = "5fd2f89ef068214130e5d60b7087ef48711fa615" 14SRCREV = "5fd2f89ef068214130e5d60b7087ef48711fa615"
14 15