summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-24 22:49:49 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-24 22:52:26 -0700
commitc1d9e520e64e062f974772e31be3088fda117db3 (patch)
treebc626a1c6035d2e0679ad376d38c21f3dfde8169
parent860d1a117a6e9640406c26fd9115fc82e604a7ff (diff)
downloadmeta-openembedded-c1d9e520e64e062f974772e31be3088fda117db3.tar.gz
ot-br-posix: Update to latest
Drop backports Add a new patch to supply additional musl fixes Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix/0001-bn_mul.h-fix-x86-PIC-inline-ASM-compilation-with-GCC.patch79
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch23
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch26
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb6
4 files changed, 29 insertions, 105 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/0001-bn_mul.h-fix-x86-PIC-inline-ASM-compilation-with-GCC.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/0001-bn_mul.h-fix-x86-PIC-inline-ASM-compilation-with-GCC.patch
deleted file mode 100644
index 8b286dfd1..000000000
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix/0001-bn_mul.h-fix-x86-PIC-inline-ASM-compilation-with-GCC.patch
+++ /dev/null
@@ -1,79 +0,0 @@
1From c0546e351f6d7ab50eb1de8cef1d0d167760fccc Mon Sep 17 00:00:00 2001
2From: Peter Korsgaard <peter@korsgaard.com>
3Date: Mon, 27 Aug 2018 22:50:57 +0200
4Subject: [PATCH] bn_mul.h: fix x86 PIC inline ASM compilation with GCC < 5
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Fixes #1910
10
11With ebx added to the MULADDC_STOP clobber list to fix #1550, the inline
12assembly fails to build with GCC < 5 in PIC mode with the following error:
13
14include/mbedtls/bn_mul.h:46:13: error: PIC register clobbered by ‘ebx’ in ‘asm’
15
16This is because older GCC versions treated the x86 ebx register (which is
17used for the GOT) as a fixed reserved register when building as PIC.
18
19This is fixed by an improved register allocator in GCC 5+. From the release
20notes:
21
22Register allocation improvements: Reuse of the PIC hard register, instead of
23using a fixed register, was implemented on x86/x86-64 targets. This
24improves generated PIC code performance as more hard registers can be used.
25
26https://www.gnu.org/software/gcc/gcc-5/changes.html
27
28As a workaround, detect this situation and disable the inline assembly,
29similar to the MULADDC_CANNOT_USE_R7 logic.
30
31Upstream-Status: Backport [https://github.com/Mbed-TLS/mbedtls/commit/c0546e351f6d7ab50eb1de8cef1d0d167760fccc]
32Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
33---
34 library/bn_mul.h | 18 +++++++++++++++++-
35 1 file changed, 17 insertions(+), 1 deletion(-)
36
37--- a/third_party/openthread/repo/third_party/mbedtls/repo/include/mbedtls/bn_mul.h
38+++ b/third_party/openthread/repo/third_party/mbedtls/repo/include/mbedtls/bn_mul.h
39@@ -95,12 +95,28 @@
40 ( !defined(__ARMCC_VERSION) || __ARMCC_VERSION >= 6000000 )
41
42 /*
43+ * GCC < 5.0 treated the x86 ebx (which is used for the GOT) as a
44+ * fixed reserved register when building as PIC, leading to errors
45+ * like: bn_mul.h:46:13: error: PIC register clobbered by 'ebx' in 'asm'
46+ *
47+ * This is fixed by an improved register allocator in GCC 5+. From the
48+ * release notes:
49+ * Register allocation improvements: Reuse of the PIC hard register,
50+ * instead of using a fixed register, was implemented on x86/x86-64
51+ * targets. This improves generated PIC code performance as more hard
52+ * registers can be used.
53+ */
54+#if defined(__GNUC__) && __GNUC__ < 5 && defined(__PIC__)
55+#define MULADDC_CANNOT_USE_EBX
56+#endif
57+
58+/*
59 * Disable use of the i386 assembly code below if option -O0, to disable all
60 * compiler optimisations, is passed, detected with __OPTIMIZE__
61 * This is done as the number of registers used in the assembly code doesn't
62 * work with the -O0 option.
63 */
64-#if defined(__i386__) && defined(__OPTIMIZE__)
65+#if defined(__i386__) && defined(__OPTIMIZE__) && !defined(MULADDC_CANNOT_USE_EBX)
66
67 #define MULADDC_INIT \
68 asm( \
69--- a/third_party/openthread/repo/third_party/mbedtls/repo/CMakeLists.txt
70+++ b/third_party/openthread/repo/third_party/mbedtls/repo/CMakeLists.txt
71@@ -210,7 +210,7 @@ if(CMAKE_COMPILER_IS_GNU)
72 endif(CMAKE_COMPILER_IS_GNU)
73
74 if(CMAKE_COMPILER_IS_CLANG)
75- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wwrite-strings -Wpointer-arith -Wimplicit-fallthrough -Wshadow -Wvla -Wformat=2 -Wno-format-nonliteral")
76+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wwrite-strings -Wpointer-arith -Wimplicit-fallthrough -Wshadow -Wvla -Wformat=2 -Wno-format-nonliteral -Wno-error=documentation")
77 set(CMAKE_C_FLAGS_RELEASE "-O2")
78 set(CMAKE_C_FLAGS_DEBUG "-O0 -g3")
79 set(CMAKE_C_FLAGS_COVERAGE "-O0 -g3 --coverage")
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch
deleted file mode 100644
index 0824eb6b9..000000000
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1mbedtls: Disable documentation warning as error with clang
2
3There are shortcomings with doxygen info which clang-15+ flags, dont
4treat them as errors
5
6Remove unused variable
7
8Fixes
9library/bignum.c:1395:29: error: variable 't' set but not used [-Werror,-Wunused-but-set-variable]
10
11Upstream-Status: Pending
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13--- a/third_party/openthread/repo/third_party/mbedtls/repo/library/bignum.c
14+++ b/third_party/openthread/repo/third_party/mbedtls/repo/library/bignum.c
15@@ -1392,7 +1392,7 @@ void mpi_mul_hlp( size_t i,
16 mbedtls_mpi_uint *d,
17 mbedtls_mpi_uint b )
18 {
19- mbedtls_mpi_uint c = 0, t = 0;
20+ mbedtls_mpi_uint c = 0, t __attribute__ ((unused)) = 0;
21
22 #if defined(MULADDC_HUIT)
23 for( ; i >= 8; i -= 8 )
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch
new file mode 100644
index 000000000..279a60741
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch
@@ -0,0 +1,26 @@
1Musl fixes, which should be applied upstream too
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/src/dbus/common/types.hpp
6+++ b/src/dbus/common/types.hpp
7@@ -715,7 +715,7 @@ struct TrelInfo
8 };
9
10 bool mEnabled; ///< Whether TREL is enabled.
11- u_int16_t mNumTrelPeers; ///< The number of TREL peers.
12+ uint16_t mNumTrelPeers; ///< The number of TREL peers.
13 TrelPacketCounters mTrelCounters; ///< The TREL counters.
14 };
15
16--- a/third_party/openthread/repo/src/posix/platform/CMakeLists.txt
17+++ b/third_party/openthread/repo/src/posix/platform/CMakeLists.txt
18@@ -172,7 +172,7 @@ target_link_libraries(openthread-posix
19 )
20
21 option(OT_TARGET_OPENWRT "enable openthread posix for OpenWRT" OFF)
22-if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND NOT OT_TARGET_OPENWRT)
23+if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND NOT OT_TARGET_OPENWRT AND NOT OT_TARGET_MUSL)
24 target_compile_definitions(ot-posix-config
25 INTERFACE "OPENTHREAD_POSIX_CONFIG_NAT64_AIL_PREFIX_ENABLE=1"
26 )
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb b/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
index 271340a25..d7be1cd71 100644
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
+++ b/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
@@ -11,15 +11,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=87109e44b2fda96a8991f27684a7349c \
11 file://third_party/openthread/repo/LICENSE;md5=543b6fe90ec5901a683320a36390c65f \ 11 file://third_party/openthread/repo/LICENSE;md5=543b6fe90ec5901a683320a36390c65f \
12 " 12 "
13DEPENDS = "autoconf-archive dbus readline avahi jsoncpp boost libnetfilter-queue protobuf protobuf-native" 13DEPENDS = "autoconf-archive dbus readline avahi jsoncpp boost libnetfilter-queue protobuf protobuf-native"
14SRCREV = "4e937939ba6ce146fd98537cb63e0f4c41c8dbe1" 14SRCREV = "a35cc682305bb2201c314472adf06a4960536750"
15PV = "0.3.0+git" 15PV = "0.3.0+git"
16 16
17SRC_URI = "gitsm://github.com/openthread/ot-br-posix.git;protocol=https;branch=main \ 17SRC_URI = "gitsm://github.com/openthread/ot-br-posix.git;protocol=https;branch=main \
18 file://0001-otbr-agent.service.in-remove-pre-exec-hook-for-mdns-.patch \ 18 file://0001-otbr-agent.service.in-remove-pre-exec-hook-for-mdns-.patch \
19 file://0001-cmake-Disable-nonnull-compare-warning-on-gcc.patch \ 19 file://0001-cmake-Disable-nonnull-compare-warning-on-gcc.patch \
20 file://0001-bn_mul.h-fix-x86-PIC-inline-ASM-compilation-with-GCC.patch \
21 file://mbedtls.patch \
22 file://default-cxx-std.patch \ 20 file://default-cxx-std.patch \
21 file://musl-fixes.patch \
23 " 22 "
24 23
25S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
@@ -56,6 +55,7 @@ EXTRA_OECMAKE = "-DBUILD_TESTING=OFF \
56 -DOT_DHCP6_CLIENT=ON \ 55 -DOT_DHCP6_CLIENT=ON \
57 -DOT_DHCP6_SERVER=ON \ 56 -DOT_DHCP6_SERVER=ON \
58 " 57 "
58EXTRA_OECMAKE:append:libc-musl = " -DOT_TARGET_MUSL=ON"
59 59
60RDEPENDS:${PN} = "iproute2 ipset avahi-daemon" 60RDEPENDS:${PN} = "iproute2 ipset avahi-daemon"
61 61