summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch')
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch
new file mode 100644
index 000000000..279a60741
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch
@@ -0,0 +1,26 @@
1Musl fixes, which should be applied upstream too
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/src/dbus/common/types.hpp
6+++ b/src/dbus/common/types.hpp
7@@ -715,7 +715,7 @@ struct TrelInfo
8 };
9
10 bool mEnabled; ///< Whether TREL is enabled.
11- u_int16_t mNumTrelPeers; ///< The number of TREL peers.
12+ uint16_t mNumTrelPeers; ///< The number of TREL peers.
13 TrelPacketCounters mTrelCounters; ///< The TREL counters.
14 };
15
16--- a/third_party/openthread/repo/src/posix/platform/CMakeLists.txt
17+++ b/third_party/openthread/repo/src/posix/platform/CMakeLists.txt
18@@ -172,7 +172,7 @@ target_link_libraries(openthread-posix
19 )
20
21 option(OT_TARGET_OPENWRT "enable openthread posix for OpenWRT" OFF)
22-if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND NOT OT_TARGET_OPENWRT)
23+if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND NOT OT_TARGET_OPENWRT AND NOT OT_TARGET_MUSL)
24 target_compile_definitions(ot-posix-config
25 INTERFACE "OPENTHREAD_POSIX_CONFIG_NAT64_AIL_PREFIX_ENABLE=1"
26 )