summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-10 16:03:02 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-10 16:06:31 -0700
commit9d220eb5e91d7aa48effe02d59f2465821179f83 (patch)
tree3029610f172c734fb78b13a62bbdc35dcbda6661
parent382389f356bf819bf40f47cae0a980e8ebeeb03e (diff)
downloadmeta-openembedded-9d220eb5e91d7aa48effe02d59f2465821179f83.tar.gz
python3-pint: Switch to using github SRC_URI
It fixes some but not all ptest failures Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.23.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.23.bb b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
index ad3e13e5d..370cd7017 100644
--- a/meta-python/recipes-devtools/python/python3-pint_0.23.bb
+++ b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
@@ -8,9 +8,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8 8
9PYPI_PACKAGE := "Pint" 9PYPI_PACKAGE := "Pint"
10 10
11inherit pypi ptest python_setuptools_build_meta 11inherit ptest python_setuptools_build_meta
12 12
13SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4" 13SRCREV = "f2e4081aee38f850938048beac7fb69c4908bc5e"
14SRC_URI = "git://github.com/hgrecco/pint;protocol=https;branch=master"
15S = "${WORKDIR}/git"
16#SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
14 17
15DEPENDS += "python3-setuptools-scm-native" 18DEPENDS += "python3-setuptools-scm-native"
16 19
@@ -26,10 +29,13 @@ RDEPENDS:${PN} += " \
26" 29"
27 30
28RDEPENDS:${PN}-ptest += " \ 31RDEPENDS:${PN}-ptest += " \
32 python3-appdirs \
33 python3-flexcache \
34 python3-flexparser \
29 python3-pytest \ 35 python3-pytest \
30" 36"
31 37
32do_install_ptest() { 38do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/testsuite 39 install -d ${D}${PTEST_PATH}/testsuite
34 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/ 40 cp -rf ${S}/pint/* ${D}${PTEST_PATH}/
35} 41}