summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-10 16:01:36 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-10 16:06:30 -0700
commit382389f356bf819bf40f47cae0a980e8ebeeb03e (patch)
tree6178e93ff48f31060adc9c4f73b65396cfd82295
parent614956c5d7904ae55558a0294630323359d3197c (diff)
downloadmeta-openembedded-382389f356bf819bf40f47cae0a980e8ebeeb03e.tar.gz
python3-flexparser,python3-flexcache: Add recipes
These will be needed by python3-pint in upcoming release Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-flexcache_0.3.bb10
-rw-r--r--meta-python/recipes-devtools/python/python3-flexparser_0.3.bb11
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
new file mode 100644
index 000000000..509a6a42e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexcache_0.3.bb
@@ -0,0 +1,10 @@
1SUMMARY = "Saves and loads to the cache a transformed versions of a source object."
2HOMEPAGE = "https://github.com/hgrecco/flexcache"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
5DEPENDS += "python3-setuptools-scm-native"
6SRC_URI[sha256sum] = "18743bd5a0621bfe2cf8d519e4c3bfdf57a269c15d1ced3fb4b64e0ff4600656"
7
8inherit pypi python_setuptools_build_meta
9PYPI_PACKAGE = "flexcache"
10RDEPENDS:${PN} = "python3-typing-extensions"
diff --git a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
new file mode 100644
index 000000000..fb94235f0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
@@ -0,0 +1,11 @@
1SUMMARY = "Parsing made fun ... using typing."
2HOMEPAGE = "https://github.com/hgrecco/flexparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
5
6DEPENDS += "python3-setuptools-scm-native"
7SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
8
9inherit pypi python_setuptools_build_meta
10
11PYPI_PACKAGE = "flexparser"