summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-24 22:50:33 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-24 22:52:26 -0700
commit9c00bf177685e01053e5d384ddb2053ec9d05e1f (patch)
treec8e203aeb661499dbbc6cf6c6d7ba6d1469143a6
parentc1d9e520e64e062f974772e31be3088fda117db3 (diff)
downloadmeta-openembedded-9c00bf177685e01053e5d384ddb2053ec9d05e1f.tar.gz
wpantund: Update to latest
Add patch to support portable basename Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/openthread/wpantund/basename.patch19
-rw-r--r--meta-networking/recipes-connectivity/openthread/wpantund_git.bb3
2 files changed, 21 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/wpantund/basename.patch b/meta-networking/recipes-connectivity/openthread/wpantund/basename.patch
new file mode 100644
index 000000000..30bd9e59c
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openthread/wpantund/basename.patch
@@ -0,0 +1,19 @@
1include libgen.h for getting prototype for basename()
2Newer musl has remove prototype from string.h [1]
3which renders a compile error with newer compilers like
4clang 18+ about missing prototype.
5
6[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10--- a/third_party/openthread/tools/spi-hdlc-adapter/spi-hdlc-adapter.c
11+++ b/third_party/openthread/tools/spi-hdlc-adapter/spi-hdlc-adapter.c
12@@ -32,6 +32,7 @@
13 #endif
14
15 #include <assert.h>
16+#include <libgen.h>
17 #include <stdio.h>
18 #include <stdlib.h>
19 #include <stdint.h>
diff --git a/meta-networking/recipes-connectivity/openthread/wpantund_git.bb b/meta-networking/recipes-connectivity/openthread/wpantund_git.bb
index b75d686e5..6a8489742 100644
--- a/meta-networking/recipes-connectivity/openthread/wpantund_git.bb
+++ b/meta-networking/recipes-connectivity/openthread/wpantund_git.bb
@@ -12,10 +12,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e7820bc7f7d1638a6b54fc2e8d7fb103 \
12 file://third_party/pt/LICENSE;md5=dcd598b69cad786beea33da7b1ae14b7 \ 12 file://third_party/pt/LICENSE;md5=dcd598b69cad786beea33da7b1ae14b7 \
13 " 13 "
14DEPENDS = "autoconf-archive dbus readline boost" 14DEPENDS = "autoconf-archive dbus readline boost"
15SRCREV = "0fb1f57e4224e2df3e630e146702bfcf63fbf07a" 15SRCREV = "8b5ce64c2f5bbf106cabfd015bcb3bdb2e0248d3"
16PV = "0.07.01+git" 16PV = "0.07.01+git"
17 17
18SRC_URI = "gitsm://github.com/openthread/wpantund.git;protocol=https;branch=master \ 18SRC_URI = "gitsm://github.com/openthread/wpantund.git;protocol=https;branch=master \
19 file://basename.patch \
19 " 20 "
20 21
21S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"