diff options
author | Changqing Li <changqing.li@windriver.com> | 2024-02-04 11:36:04 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-03 22:03:04 -0800 |
commit | 8c327fadfa0d50debd56b6af3ff82d4cf677759b (patch) | |
tree | e6fb007cf994af16c6c1129337e095471bde2355 | |
parent | fb98797c96470048962da897b084833874b7f3e6 (diff) | |
download | meta-openembedded-8c327fadfa0d50debd56b6af3ff82d4cf677759b.tar.gz |
cpuid: fix do_install
Fix do_install to make cpuid-doc installed correctly
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/cpuid/cpuid_20230614.bb | 10 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cpuid/files/0001-Makefile-update-the-hardcode-path-to-bindir-mandir.patch | 36 |
2 files changed, 42 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/cpuid/cpuid_20230614.bb b/meta-oe/recipes-devtools/cpuid/cpuid_20230614.bb index a88042ba6..ed339e016 100644 --- a/meta-oe/recipes-devtools/cpuid/cpuid_20230614.bb +++ b/meta-oe/recipes-devtools/cpuid/cpuid_20230614.bb | |||
@@ -8,6 +8,7 @@ LICENSE = "GPL-2.0-only" | |||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
9 | 9 | ||
10 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \ | 10 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \ |
11 | file://0001-Makefile-update-the-hardcode-path-to-bindir-mandir.patch \ | ||
11 | " | 12 | " |
12 | SRC_URI[sha256sum] = "b1c83045efc26076307751e0662d580277f5f9bf89cf027231a7812003c3a4e8" | 13 | SRC_URI[sha256sum] = "b1c83045efc26076307751e0662d580277f5f9bf89cf027231a7812003c3a4e8" |
13 | 14 | ||
@@ -15,9 +16,10 @@ COMPATIBLE_HOST = "(i.86|x86_64).*-linux" | |||
15 | 16 | ||
16 | inherit perlnative | 17 | inherit perlnative |
17 | 18 | ||
18 | # The install rule from the Makefile has hardcoded paths, so we duplicate | ||
19 | # the actions to accommodate different paths. | ||
20 | do_install () { | 19 | do_install () { |
21 | install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid | 20 | oe_runmake DESTDIR=${D} bindir=${bindir} mandir=${mandir} install |
22 | install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir} | ||
23 | } | 21 | } |
22 | |||
23 | RDEPENDS:${PN} = "perl" | ||
24 | |||
25 | INSANE_SKIP:${PN} += "already-stripped" | ||
diff --git a/meta-oe/recipes-devtools/cpuid/files/0001-Makefile-update-the-hardcode-path-to-bindir-mandir.patch b/meta-oe/recipes-devtools/cpuid/files/0001-Makefile-update-the-hardcode-path-to-bindir-mandir.patch new file mode 100644 index 000000000..8654fb86c --- /dev/null +++ b/meta-oe/recipes-devtools/cpuid/files/0001-Makefile-update-the-hardcode-path-to-bindir-mandir.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 1339348c5b69b32378a638d65b16297d29c5fa22 Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Tue, 7 Nov 2023 16:06:49 +0800 | ||
4 | Subject: [PATCH] Makefile: update the hardcode path to bindir/mandir | ||
5 | |||
6 | Update the hardcode path to bindir/mandir | ||
7 | |||
8 | Upstream-Status: Pending [ Send to cpuid@etallen.com ] | ||
9 | |||
10 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
11 | --- | ||
12 | Makefile | 8 ++++---- | ||
13 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
14 | |||
15 | diff --git a/Makefile b/Makefile | ||
16 | index 828d2b1..365e26d 100644 | ||
17 | --- a/Makefile | ||
18 | +++ b/Makefile | ||
19 | @@ -55,10 +55,10 @@ cpuinfo2cpuid.man.gz: cpuinfo2cpuid.man | ||
20 | gzip < $< > $@ | ||
21 | |||
22 | install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz | ||
23 | - install -D $(INSTALL_STRIP) -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG) | ||
24 | - install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz | ||
25 | - install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid | ||
26 | - install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz | ||
27 | + install -D $(INSTALL_STRIP) -m 755 $(PROG) $(BUILDROOT)${bindir}/$(PROG) | ||
28 | + install -D -m 444 $(PROG).man.gz $(BUILDROOT)${mandir}/man1/$(PROG).1.gz | ||
29 | + install -D -m 755 cpuinfo2cpuid $(BUILDROOT)${bindir}/cpuinfo2cpuid | ||
30 | + install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)${mandir}/man1/cpuinfo2cpuid.1.gz | ||
31 | |||
32 | clean: | ||
33 | rm -f $(PROG) $(PROG).i386 $(PROG).x86_64 | ||
34 | -- | ||
35 | 2.25.1 | ||
36 | |||