summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 15:44:39 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 18:52:51 -0700
commit7bfcc56748aa867f9dbcd5d85f177d53d52a3118 (patch)
tree49d53276d4eabc25b50f1174af2eccbf1222c264
parentb175cf714b1e619b7b8a6a85891442deb0363fdb (diff)
downloadmeta-openembedded-7bfcc56748aa867f9dbcd5d85f177d53d52a3118.tar.gz
ndctl: Fix build issues seen with musl 1.2.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl/0001-include-libgen.h-for-basename.patch32
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_v78.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 000000000..9de0a715b
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,32 @@
1From d7f01c310b74e3579a6474362922f173ac656d7b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 15:41:29 -0700
4Subject: [PATCH] include libgen.h for basename
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Submitted [https://github.com/pmem/ndctl/pull/263]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 daxctl/device.c | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/daxctl/device.c b/daxctl/device.c
19index d2d206b..e607a19 100644
20--- a/daxctl/device.c
21+++ b/daxctl/device.c
22@@ -2,6 +2,7 @@
23 /* Copyright (C) 2019-2020 Intel Corporation. All rights reserved. */
24 #include <stdio.h>
25 #include <errno.h>
26+#include <libgen.h>
27 #include <stdlib.h>
28 #include <syslog.h>
29 #include <unistd.h>
30--
312.44.0
32
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v78.bb b/meta-oe/recipes-core/ndctl/ndctl_v78.bb
index 2974a7db7..907c02c7c 100644
--- a/meta-oe/recipes-core/ndctl/ndctl_v78.bb
+++ b/meta-oe/recipes-core/ndctl/ndctl_v78.bb
@@ -11,7 +11,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=74a614eac8b2657a4b8e6607421a0883"
11inherit meson pkgconfig bash-completion systemd 11inherit meson pkgconfig bash-completion systemd
12 12
13SRCREV = "a871e6153b11fe63780b37cdcb1eb347b296095c" 13SRCREV = "a871e6153b11fe63780b37cdcb1eb347b296095c"
14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https" 14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https \
15 file://0001-include-libgen.h-for-basename.patch"
15 16
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)" 17UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)"
17 18