summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 15:37:09 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 18:52:51 -0700
commitb175cf714b1e619b7b8a6a85891442deb0363fdb (patch)
tree50c2d338e136eb94d15875173a651bb31aa4ddbc
parentd0736e800df0f4af95dd87c9d15c1a6ae76d1a03 (diff)
downloadmeta-openembedded-b175cf714b1e619b7b8a6a85891442deb0363fdb.tar.gz
sanlock: Fix build with musl >= 1.2.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch32
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 000000000..439ffc647
--- /dev/null
+++ b/meta-oe/recipes-extended/sanlock/sanlock/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,32 @@
1From c955ac2a4d57f21351e53a5209346fdc2325a747 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 15:12:02 -0700
4Subject: [PATCH] include libgen.h for basename
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Pending
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 wdmd/main.c | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/wdmd/main.c b/wdmd/main.c
19index 38a99f3..7014462 100644
20--- a/wdmd/main.c
21+++ b/wdmd/main.c
22@@ -15,6 +15,7 @@
23 #include <stddef.h>
24 #include <grp.h>
25 #include <fcntl.h>
26+#include <libgen.h>
27 #include <string.h>
28 #include <errno.h>
29 #include <limits.h>
30--
312.44.0
32
diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb
index 91b1460ff..1d0f8b010 100644
--- a/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.9.1.bb
@@ -16,8 +16,9 @@ PV .= "+git"
16SRC_URI = "git://pagure.io/sanlock.git;protocol=http;branch=master \ 16SRC_URI = "git://pagure.io/sanlock.git;protocol=http;branch=master \
17 file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch \ 17 file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch \
18 file://0001-add-missing-system-header-string.h.patch \ 18 file://0001-add-missing-system-header-string.h.patch \
19 file://0001-include-libgen.h-for-basename.patch \
19 " 20 "
20SRCREV = "90156f382c2508cc7dc4dc32f8247d3e1291b318" 21SRCREV = "ecf30a1ccf756776dfea440e4cf9b0b54581075f"
21 22
22S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
23 24