summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-06 21:30:04 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-06 14:14:17 -0700
commit5a02b76b82d1f48986212c33dddf7986385c79ef (patch)
tree57ec597f9e76574ff7c6ee575bc1f898926356ae
parentdce392b58826d1aff643196f05e592c9f40e9636 (diff)
downloadmeta-openembedded-5a02b76b82d1f48986212c33dddf7986385c79ef.tar.gz
python3-pillow: Upgrade 10.1.0 -> 10.3.0 and fix ptest
License-Update: Updated copyright year and clean up authors, contributors * 0001-explicitly-set-compile-options.patch dropped because setup.cfg moved to pyproject.toml -> (https://github.com/python-pillow/Pillow/pull/7484) Also, we can give the build option parameters as described in the documentation -> https://pillow.readthedocs.io/en/stable/installation/building-from-source.html#build-options Added build options to pass to build with using the variable PEP517_BUILD_OPTS so no need to create patch again. * "python setup.py" and the use of "setup.py" as a command line tool are deprecated and upstream added a custom build backend to translate -C feature=disable style flags to the old --disable-feature style flags by prepending the build command (typically bdist_wheel) with a build_ext --disable-feature command which builds the extension modules before being added to a wheel. That backend uses the build_meta module of setuptools. The _CustomBuildMetaBackend class is a subclass of this module, adding custom behaviors and enabling settings specific to a particular project. https://github.com/python-pillow/Pillow/blob/10.3.0/_custom_build/backend.py * Ptest tested on qemux86-64 and qemuarm64 with x11. * Since no ptest error was encountered, python3-pillow has been moved from PTESTS_PROBLEMS_META_PYTHON to PTESTS_SLOW_META_PYTHON. Tests with SKIP are related to packages with explicitly disabled build options. qemux86-64: Testsuite summary TOTAL: 4502 PASS: 4152 SKIP: 347 XFAIL: 2 FAIL: 0 XPASS: 1 ERROR: 0 DURATION: 904 END: /usr/lib/python3-pillow/ptest 2024-04-06T15:56 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 4502 PASS: 4152 SKIP: 347 XFAIL: 2 FAIL: 0 XPASS: 1 ERROR: 0 DURATION: 674 END: /usr/lib/python3-pillow/ptest 2024-04-06T16:40 STOP: ptest-runner TOTAL: 1 FAIL: 0 Changelog: https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html https://pillow.readthedocs.io/en/stable/releasenotes/10.2.0.html Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch40
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_10.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb)24
3 files changed, 19 insertions, 47 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 63f312b45..19566e466 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -88,6 +88,7 @@ PTESTS_SLOW_META_PYTHON = "\
88 python3-google-auth \ 88 python3-google-auth \
89 python3-lz4 \ 89 python3-lz4 \
90 python3-marshmallow \ 90 python3-marshmallow \
91 python3-pillow \
91 python3-pytest-localserver \ 92 python3-pytest-localserver \
92 python3-traitlets \ 93 python3-traitlets \
93 python3-yappi \ 94 python3-yappi \
@@ -97,7 +98,6 @@ PTESTS_PROBLEMS_META_PYTHON ="\
97 python3-betamax \ 98 python3-betamax \
98 python3-dnspython \ 99 python3-dnspython \
99 python3-fastjsonschema \ 100 python3-fastjsonschema \
100 python3-pillow \
101 python3-pint \ 101 python3-pint \
102 python3-pyzmq \ 102 python3-pyzmq \
103 python3-scrypt \ 103 python3-scrypt \
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
deleted file mode 100644
index 005fea5c6..000000000
--- a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 27bfa4028453dc79a72569823e97da8fd1994ffc Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Tue, 1 Sep 2020 11:53:53 +0000
4Subject: [PATCH] explicitly set compile options
5
6OE does not support to install egg package, so
7explicitly set build_ext options for oe-core's
8`setup.py install'
9
10Upstream-Status: Inappropriate [oe specific]
11
12Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
13Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
14---
15 setup.cfg | 12 ++++++++++++
16 1 file changed, 12 insertions(+)
17
18diff --git a/setup.cfg b/setup.cfg
19index 19979cf7..ed27dfe1 100644
20--- a/setup.cfg
21+++ b/setup.cfg
22@@ -11,3 +11,15 @@ multi_line_output = 3
23 [tool:pytest]
24 addopts = -ra --color=yes
25 testpaths = Tests
26+
27+[build_ext]
28+disable-platform-guessing = 1
29+enable-zlib = 1
30+enable-jpeg = 1
31+enable-tiff = 1
32+enable-freetype = 1
33+enable-lcms = 1
34+enable-jpeg2000 = 1
35+disable-webp = 1
36+disable-webpmux = 1
37+disable-imagequant = 1
38--
392.17.1
40
diff --git a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb b/meta-python/recipes-devtools/python/python3-pillow_10.3.0.bb
index e795bd491..debf48815 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_10.3.0.bb
@@ -3,16 +3,28 @@ Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors." 3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io" 4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=c349a4b4b9ec2377a8fd6a7df87dbffe"
7 7
8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ 8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
9 file://0001-support-cross-compiling.patch \ 9 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
11 file://run-ptest \ 10 file://run-ptest \
12 " 11 "
13SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c" 12SRCREV = "5c89d88eee199ba53f64581ea39b6a1bc52feb1a"
14 13
15inherit setuptools3 ptest 14inherit python_setuptools_build_meta ptest
15
16PEP517_BUILD_OPTS += " \
17 -C platform-guessing=disable \
18 -C zlib=enable \
19 -C jpeg=enable \
20 -C tiff=enable \
21 -C freetype=enable \
22 -C lcms=enable \
23 -C jpeg2000=enable \
24 -C webp=disable \
25 -C webpmux=disable \
26 -C imagequant=disable \
27"
16 28
17DEPENDS += " \ 29DEPENDS += " \
18 zlib \ 30 zlib \
@@ -53,8 +65,8 @@ S = "${WORKDIR}/git"
53RPROVIDES:${PN} += "python3-imaging" 65RPROVIDES:${PN} += "python3-imaging"
54 66
55do_install_ptest() { 67do_install_ptest() {
56 install -d ${D}${PTEST_PATH}/Tests 68 install -d ${D}${PTEST_PATH}/Tests
57 cp -rf ${S}/Tests ${D}${PTEST_PATH}/ 69 cp -rf ${S}/Tests ${D}${PTEST_PATH}/
58} 70}
59 71
60BBCLASSEXTEND = "native" 72BBCLASSEXTEND = "native"