summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-06 00:52:54 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-06 14:14:17 -0700
commitdce392b58826d1aff643196f05e592c9f40e9636 (patch)
tree254442275fb686592f1ab22f0b1770e2e789a172
parent96c7e7d6834a62d215caaa9fa2ac531aca7649a3 (diff)
downloadmeta-openembedded-dce392b58826d1aff643196f05e592c9f40e9636.tar.gz
python3-bleak: enable ptest and add missing runtime dependency
* Ptest tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_FAST_META_PYTHON qemux86-64: Testsuite summary TOTAL: 14 PASS: 14 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 9 END: /usr/lib/python3-bleak/ptest 2024-04-05T18:44 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 14 PASS: 14 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 8 END: /usr/lib/python3-bleak/ptest 2024-04-05T21:15 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-bleak/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb29
3 files changed, 27 insertions, 6 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 2f7babe48..63f312b45 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -12,6 +12,7 @@ PTESTS_FAST_META_PYTHON = "\
12 python3-ansicolors \ 12 python3-ansicolors \
13 python3-asgiref \ 13 python3-asgiref \
14 python3-aspectlib \ 14 python3-aspectlib \
15 python3-bleak \
15 python3-blinker \ 16 python3-blinker \
16 python3-cachetools \ 17 python3-cachetools \
17 python3-cbor2 \ 18 python3-cbor2 \
diff --git a/meta-python/recipes-devtools/python/python3-bleak/run-ptest b/meta-python/recipes-devtools/python/python3-bleak/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bleak/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb b/meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb
index 4a1fafb5d..96f3fcbcf 100644
--- a/meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb
+++ b/meta-python/recipes-devtools/python/python3-bleak_0.21.1.bb
@@ -3,14 +3,31 @@ HOMEPAGE = "https://github.com/hbldh/bleak"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=bcbc2069a86cba1b5e47253679f66ed7" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=bcbc2069a86cba1b5e47253679f66ed7"
5 5
6SRC_URI[sha256sum] = "ec4a1a2772fb315b992cbaa1153070c7e26968a52b0e2727035f443a1af5c18f" 6SRCREV = "054b092e19c7a45d5ea07d8948022f54117fe5e8"
7PYPI_SRC_URI = "git://github.com/hbldh/bleak.git;protocol=https;branch=develop"
7 8
8PYPI_PACKAGE = "bleak" 9inherit pypi python_poetry_core ptest
9 10
10inherit pypi python_poetry_core 11S = "${WORKDIR}/git"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-pytest-asyncio \
20 python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
11 27
12RDEPENDS:${PN} += " \ 28RDEPENDS:${PN} += " \
13 python3-core (>3.7) \ 29 python3-core (>3.7) \
14 python3-async-timeout \ 30 python3-async-timeout \
15 python3-dbus-fast \ 31 python3-dbus-fast \
32 python3-xml \
16" 33"