summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Vasiu <alexandru.vasiu@ni.com>2018-03-16 15:21:41 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:57:03 -0700
commit0c4b6aa806aaba6670b671e4da65f70b336747e5 (patch)
tree6d72320d7fdf1c059e525f81ccac0dab06238588
parent5b141faa25fa94a687e555c0ba1d248598580524 (diff)
downloadmeta-openembedded-0c4b6aa806aaba6670b671e4da65f70b336747e5.tar.gz
Add support for pyiface
Pyiface is a package that exposes the network interfaces of the operating system in a easy to use and transparent way. Signed-off-by: Alexandru Vasiu <alexandru.vasiu@ni.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyiface.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyiface.inc b/meta-python/recipes-devtools/python/python-pyiface.inc
new file mode 100644
index 000000000..4d0c8dc9e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyiface.inc
@@ -0,0 +1,11 @@
1SUMMARY = "Pyiface is a package that exposes the network interfaces of the operating system in a easy to use and transparent way"
2SECTION = "devel/python"
3HOMEPAGE = "https://pypi.python.org/pypi/pyiface/"
4LICENSE = "GPLv3+"
5
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fe06497acaf4f45999925d348c2605f9"
7
8SRC_URI[md5sum] = "edcdd71109c4259af8348006a8049c9c"
9SRC_URI[sha256sum] = "dc984de0e1bcf6871ef88b1a92d1fb75717d4f602a60caeb66136093d4a8f62e"
10
11inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb b/meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb
new file mode 100644
index 000000000..854cb30ee
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyiface_0.0.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-pyiface.inc \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb b/meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb
new file mode 100644
index 000000000..721e7b1c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyiface_0.0.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pyiface.inc