summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariia Movchan -X \(mmovchan - GLOBALLOGIC INC at Cisco\) <mmovchan@cisco.com>2018-03-15 19:46:58 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:56:55 -0700
commit5b141faa25fa94a687e555c0ba1d248598580524 (patch)
treebda224c7ed9226529974479bb10c8290acbccac4
parent66d3964b3c6e5ad7ef4712ff08aea77aa1614c2c (diff)
downloadmeta-openembedded-5b141faa25fa94a687e555c0ba1d248598580524.tar.gz
ipcalc: add initial recipe for version 0.2.2
Signed-off-by: Mariia Movchan <mmovchan@cisco.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/ipcalc/ipcalc/0001-Makefile-pass-extra-linker-flags.patch31
-rw-r--r--meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb22
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipcalc/ipcalc/0001-Makefile-pass-extra-linker-flags.patch b/meta-networking/recipes-support/ipcalc/ipcalc/0001-Makefile-pass-extra-linker-flags.patch
new file mode 100644
index 000000000..38d306475
--- /dev/null
+++ b/meta-networking/recipes-support/ipcalc/ipcalc/0001-Makefile-pass-extra-linker-flags.patch
@@ -0,0 +1,31 @@
1From fd80c0599083013a1b583feba5d7473f52b35938 Mon Sep 17 00:00:00 2001
2From: Mariia Movchan <mmovchan@cisco.com>
3Date: Tue, 6 Mar 2018 16:03:39 +0200
4Subject: [PATCH] Makefile: pass extra linker flags
5
6Fixes
7ERROR: QA Issue: No GNU_HASH in the elf binary
8
9Upstream-Status: Pending
10
11Signed-off-by: Mariia Movchan <mmovchan@cisco.com>
12---
13 Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/Makefile b/Makefile
17index 8beff8f..047f02a 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -8,7 +8,7 @@ LIBS?=
21 VERSION=0.2.2
22 CC?=gcc
23 CFLAGS?=-O2 -g -Wall
24-LDFLAGS=$(LIBS)
25+LDFLAGS+=$(LIBS)
26
27 ifeq ($(USE_GEOIP),yes)
28 ifeq ($(USE_DYN_GEOIP),yes)
29--
302.15.1
31
diff --git a/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb b/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb
new file mode 100644
index 000000000..3e278db68
--- /dev/null
+++ b/meta-networking/recipes-support/ipcalc/ipcalc_0.2.2.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Tool to assist in network address calculations for IPv4 and IPv6."
2HOMEPAGE = "https://github.com/nmav/ipcalc"
3
4SECTION = "net"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "\
10 https://github.com/nmav/ipcalc/archive/${PV}.tar.gz;downloadfilename=ipcalc-${PV}.tar.gz \
11 file://0001-Makefile-pass-extra-linker-flags.patch \
12"
13
14SRC_URI[md5sum] = "343db932a3ad407328920b7430965faf"
15SRC_URI[sha256sum] = "bf1b95eca219e564c85fa4233fe65342963cf3e8a303a7e10b4dd7269c864794"
16
17export USE_GEOIP = "no"
18
19do_install() {
20 install -d ${D}/${bindir}
21 install -m 0755 ${S}/ipcalc ${D}/${bindir}
22}