summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeniamin Sandu <beniaminsandu@gmail.com>2024-04-10 23:30:25 +0100
committerKhem Raj <raj.khem@gmail.com>2024-04-11 23:32:35 -0700
commit00a28f09266dc4a35b89e67a1dddf20684fbb3e1 (patch)
tree9aabaab316e595fab7f0820a8a9f3882943e7b6e
parent9d220eb5e91d7aa48effe02d59f2465821179f83 (diff)
downloadmeta-openembedded-00a28f09266dc4a35b89e67a1dddf20684fbb3e1.tar.gz
libtorrent-rasterbar: add initial recipe for 2.0.10
Signed-off-by: Beniamin Sandu <beniaminsandu@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/libtorrent-rasterbar/libtorrent-rasterbar_2.0.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent-rasterbar/libtorrent-rasterbar_2.0.10.bb b/meta-oe/recipes-connectivity/libtorrent-rasterbar/libtorrent-rasterbar_2.0.10.bb
new file mode 100644
index 000000000..084e3c408
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libtorrent-rasterbar/libtorrent-rasterbar_2.0.10.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "libtorrent is a feature complete C++ bittorrent implementation \
2 focusing on efficiency and scalability."
3HOMEPAGE = "https://libtorrent.org/"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d8b6cb42d66e6b3c47a909c3ce678a7b"
6
7DEPENDS = "boost openssl"
8
9SRC_URI = "git://github.com/arvidn/libtorrent.git;branch=master;protocol=https \
10 git://github.com/arvidn/try_signal.git;branch=master;protocol=https;destsuffix=git/deps/try_signal;name=try_signal"
11
12SRCREV = "74bc93a37a5e31c78f0aa02037a68fb9ac5deb41"
13SRCREV_try_signal = "105cce59972f925a33aa6b1c3109e4cd3caf583d"
14SRCREV_FORMAT .= "_try_signal"
15
16S = "${WORKDIR}/git"
17
18inherit cmake pkgconfig python3targetconfig
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
21
22PACKAGECONFIG ??= "python3"
23PACKAGECONFIG[python3] = "-Dpython-bindings=ON,-Dpython-bindings=OFF,python3-distutils-extra-native"
24
25# Strip host paths from autogenerated files
26do_install:append() {
27 sed -i 's+${STAGING_LIBDIR}+${libdir}+g' ${D}${libdir}/pkgconfig/${BPN}.pc
28}
29
30PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-${BPN}', '', d)}"
31FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/*"