summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2021-03-24 12:06:58 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2021-03-24 12:06:58 +0100
commite5010e96500e3e608fa61b7ad939df5769248d74 (patch)
treeac39e02e10e8da71d508feb058bce214c514dd41 /recipes-extended
parent6e52e1c613b7cf4fd08e985514e508461df7f641 (diff)
downloadmeta-nfv-access-common-e5010e96500e3e608fa61b7ad939df5769248d74.tar.gz
Upgrade to gatesgarth
This is an initial commit, containing quick fixes and hacks to allow building the images. All these issues will be re-evaluated and fixed properly in their own commits. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/shadow/shadow/CVE-2016-6252.patch48
-rw-r--r--recipes-extended/shadow/shadow_%.bbappend5
2 files changed, 0 insertions, 53 deletions
diff --git a/recipes-extended/shadow/shadow/CVE-2016-6252.patch b/recipes-extended/shadow/shadow/CVE-2016-6252.patch
deleted file mode 100644
index 6e05584..0000000
--- a/recipes-extended/shadow/shadow/CVE-2016-6252.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 1d5a926cc2d6078d23a96222b1ef3e558724dad1 Mon Sep 17 00:00:00 2001
2From: Sebastian Krahmer <krahmer@suse.com>
3Date: Wed, 3 Aug 2016 11:51:07 -0500
4Subject: [PATCH] Simplify getulong
5
6Use strtoul to read an unsigned long, rather than reading
7a signed long long and casting it.
8
9https://bugzilla.suse.com/show_bug.cgi?id=979282
10
11CVE: CVE-2016-6252
12Upstream-Status: Backport [https://github.com/shadow-maint/shadow/commit/1d5a926cc2d6078d23a96222b1ef3e558724dad1]
13
14Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
15---
16 lib/getulong.c | 9 +++------
17 1 file changed, 3 insertions(+), 6 deletions(-)
18
19diff --git a/lib/getulong.c b/lib/getulong.c
20index 61579cae..08d2c1a8 100644
21--- a/lib/getulong.c
22+++ b/lib/getulong.c
23@@ -44,22 +44,19 @@
24 */
25 int getulong (const char *numstr, /*@out@*/unsigned long int *result)
26 {
27- long long int val;
28+ unsigned long int val;
29 char *endptr;
30
31 errno = 0;
32- val = strtoll (numstr, &endptr, 0);
33+ val = strtoul (numstr, &endptr, 0);
34 if ( ('\0' == *numstr)
35 || ('\0' != *endptr)
36 || (ERANGE == errno)
37- /*@+ignoresigns@*/
38- || (val != (unsigned long int)val)
39- /*@=ignoresigns@*/
40 ) {
41 return 0;
42 }
43
44- *result = (unsigned long int)val;
45+ *result = val;
46 return 1;
47 }
48
diff --git a/recipes-extended/shadow/shadow_%.bbappend b/recipes-extended/shadow/shadow_%.bbappend
deleted file mode 100644
index 4f04479..0000000
--- a/recipes-extended/shadow/shadow_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2016-6252.patch \
5 "