summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2021-03-24 12:06:58 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2021-03-24 12:06:58 +0100
commite5010e96500e3e608fa61b7ad939df5769248d74 (patch)
treeac39e02e10e8da71d508feb058bce214c514dd41
parent6e52e1c613b7cf4fd08e985514e508461df7f641 (diff)
downloadmeta-nfv-access-common-e5010e96500e3e608fa61b7ad939df5769248d74.tar.gz
Upgrade to gatesgarth
This is an initial commit, containing quick fixes and hacks to allow building the images. All these issues will be re-evaluated and fixed properly in their own commits. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-core/systemd/systemd/CVE-2017-15908.patch44
-rw-r--r--recipes-core/systemd/systemd_%.bbappend5
-rw-r--r--recipes-enea/partrt/partrt_1.1.bb2
-rw-r--r--recipes-extended/shadow/shadow/CVE-2016-6252.patch48
-rw-r--r--recipes-extended/shadow/shadow_%.bbappend5
5 files changed, 1 insertions, 103 deletions
diff --git a/recipes-core/systemd/systemd/CVE-2017-15908.patch b/recipes-core/systemd/systemd/CVE-2017-15908.patch
deleted file mode 100644
index 6851243..0000000
--- a/recipes-core/systemd/systemd/CVE-2017-15908.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 9f939335a07085aa9a9663efd1dca06ef6405d62 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
3Date: Wed, 25 Oct 2017 11:19:19 +0200
4Subject: [PATCH] resolved: fix loop on packets with pseudo dns types
5
6Reported by Karim Hossen & Thomas Imbert from Sogeti ESEC R&D.
7
8Upstream-Status: Backport
9CVE: CVE-2017-15908
10
11Upstream patch:
12https://github.com/systemd/systemd/commit/8aeadf3052a2130b88d5bccf5439890e1034f28d
13
14https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/172535
15
16Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
17---
18 src/resolve/resolved-dns-packet.c | 6 +-----
19 1 file changed, 1 insertion(+), 5 deletions(-)
20
21diff --git a/src/resolve/resolved-dns-packet.c b/src/resolve/resolved-dns-packet.c
22index e2f227bfc64..35f4d0689b2 100644
23--- a/src/resolve/resolved-dns-packet.c
24+++ b/src/resolve/resolved-dns-packet.c
25@@ -1514,7 +1514,7 @@ static int dns_packet_read_type_window(DnsPacket *p, Bitmap **types, size_t *sta
26
27 found = true;
28
29- while (bitmask) {
30+ for (; bitmask; bit++, bitmask >>= 1)
31 if (bitmap[i] & bitmask) {
32 uint16_t n;
33
34@@ -1528,10 +1528,6 @@ static int dns_packet_read_type_window(DnsPacket *p, Bitmap **types, size_t *sta
35 if (r < 0)
36 return r;
37 }
38-
39- bit++;
40- bitmask >>= 1;
41- }
42 }
43
44 if (!found)
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
deleted file mode 100644
index 4fe658a..0000000
--- a/recipes-core/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2017-15908.patch \
5 "
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb
index 5c22e4a..65995e1 100644
--- a/recipes-enea/partrt/partrt_1.1.bb
+++ b/recipes-enea/partrt/partrt_1.1.bb
@@ -5,7 +5,7 @@ LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
6 6
7RDEPENDS_${PN} = "bash" 7RDEPENDS_${PN} = "bash"
8RDEPENDS_${PN}-ptest += "python" 8RDEPENDS_${PN}-ptest += "python3"
9 9
10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ 10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
11 file://run-ptest \ 11 file://run-ptest \
diff --git a/recipes-extended/shadow/shadow/CVE-2016-6252.patch b/recipes-extended/shadow/shadow/CVE-2016-6252.patch
deleted file mode 100644
index 6e05584..0000000
--- a/recipes-extended/shadow/shadow/CVE-2016-6252.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 1d5a926cc2d6078d23a96222b1ef3e558724dad1 Mon Sep 17 00:00:00 2001
2From: Sebastian Krahmer <krahmer@suse.com>
3Date: Wed, 3 Aug 2016 11:51:07 -0500
4Subject: [PATCH] Simplify getulong
5
6Use strtoul to read an unsigned long, rather than reading
7a signed long long and casting it.
8
9https://bugzilla.suse.com/show_bug.cgi?id=979282
10
11CVE: CVE-2016-6252
12Upstream-Status: Backport [https://github.com/shadow-maint/shadow/commit/1d5a926cc2d6078d23a96222b1ef3e558724dad1]
13
14Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
15---
16 lib/getulong.c | 9 +++------
17 1 file changed, 3 insertions(+), 6 deletions(-)
18
19diff --git a/lib/getulong.c b/lib/getulong.c
20index 61579cae..08d2c1a8 100644
21--- a/lib/getulong.c
22+++ b/lib/getulong.c
23@@ -44,22 +44,19 @@
24 */
25 int getulong (const char *numstr, /*@out@*/unsigned long int *result)
26 {
27- long long int val;
28+ unsigned long int val;
29 char *endptr;
30
31 errno = 0;
32- val = strtoll (numstr, &endptr, 0);
33+ val = strtoul (numstr, &endptr, 0);
34 if ( ('\0' == *numstr)
35 || ('\0' != *endptr)
36 || (ERANGE == errno)
37- /*@+ignoresigns@*/
38- || (val != (unsigned long int)val)
39- /*@=ignoresigns@*/
40 ) {
41 return 0;
42 }
43
44- *result = (unsigned long int)val;
45+ *result = val;
46 return 1;
47 }
48
diff --git a/recipes-extended/shadow/shadow_%.bbappend b/recipes-extended/shadow/shadow_%.bbappend
deleted file mode 100644
index 4f04479..0000000
--- a/recipes-extended/shadow/shadow_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2016-6252.patch \
5 "