summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/mingw-w64
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/mingw-w64')
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb4
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb6
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb2
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb
index 292d22b..68e77fa 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb
@@ -18,9 +18,9 @@ do_compile() {
18 : 18 :
19} 19}
20 20
21do_install_append() { 21do_install:append() {
22 # install correct pthread headers 22 # install correct pthread headers
23 install -m 0644 -t ${D}${includedir} ${S}/../mingw-w64-libraries/winpthreads/include/*.h 23 install -m 0644 -t ${D}${includedir} ${S}/../mingw-w64-libraries/winpthreads/include/*.h
24} 24}
25 25
26FILES_${PN} += "${exec_prefix}/${TARGET_SYS}" 26FILES:${PN} += "${exec_prefix}/${TARGET_SYS}"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb
index 0368841..02132c1 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb
@@ -9,7 +9,7 @@ B = "${WORKDIR}/build-${TARGET_SYS}"
9 9
10inherit autotools nativesdk 10inherit autotools nativesdk
11 11
12BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}" 12BUILDSDK_CPPFLAGS:append = " -isystem${STAGING_INCDIR}"
13 13
14INHIBIT_DEFAULT_DEPS = "1" 14INHIBIT_DEFAULT_DEPS = "1"
15DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc " 15DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc "
@@ -21,11 +21,11 @@ PROVIDES += "virtual/nativesdk-libintl"
21 21
22TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 22TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
23 23
24EXTRA_OECONF_x86-64 = "--disable-lib32" 24EXTRA_OECONF:x86-64 = "--disable-lib32"
25 25
26do_configure() { 26do_configure() {
27 oe_runconf 27 oe_runconf
28} 28}
29 29
30FILES_${PN} += "${exec_prefix}/libsrc" 30FILES:${PN} += "${exec_prefix}/libsrc"
31 31
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb
index 814268d..38092dc 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb
@@ -18,7 +18,7 @@ do_configure() {
18 18
19TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 19TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
20 20
21do_install_append() { 21do_install:append() {
22 # headers are already installed by mingw-w64-headers 22 # headers are already installed by mingw-w64-headers
23 rm -rf ${D}${includedir} 23 rm -rf ${D}${includedir}
24} 24}