summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend8
-rw-r--r--recipes-devtools/cmake/cmake_%.bbappend4
-rw-r--r--recipes-devtools/gcc/gcc-cross-canadian_%.bbappend12
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk_%.bbappend4
-rw-r--r--recipes-devtools/gcc/gcc-runtime_%.bbappend16
-rw-r--r--recipes-devtools/gcc/gcc_%.bbappend4
-rw-r--r--recipes-devtools/gcc/libgcc_%.bbappend8
-rw-r--r--recipes-devtools/gdb/gdb-cross-canadian_%.bbappend14
-rw-r--r--recipes-devtools/go/go_%.bbappend4
-rw-r--r--recipes-devtools/libtool/nativesdk-libtool_2.4.6.bbappend2
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb4
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb6
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb2
-rw-r--r--recipes-devtools/ninja/ninja_%.bbappend4
-rw-r--r--recipes-devtools/swig/swig_%.bbappend4
15 files changed, 48 insertions, 48 deletions
diff --git a/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend b/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend
index 5845fe0..2890afc 100644
--- a/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend
+++ b/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend
@@ -1,5 +1,5 @@
1EXTRA_OECONF_append_sdkmingw32 = " --disable-nls" 1EXTRA_OECONF:append:sdkmingw32 = " --disable-nls"
2LDFLAGS_append_sdkmingw32 = " -Wl,-static" 2LDFLAGS:append:sdkmingw32 = " -Wl,-static"
3 3
4DEPENDS_remove_sdkmingw32 = "nativesdk-gettext" 4DEPENDS:remove:sdkmingw32 = "nativesdk-gettext"
5DEPENDS_remove_sdkmingw32 = "nativesdk-flex" 5DEPENDS:remove:sdkmingw32 = "nativesdk-flex"
diff --git a/recipes-devtools/cmake/cmake_%.bbappend b/recipes-devtools/cmake/cmake_%.bbappend
index b2e8a19..9fb4f99 100644
--- a/recipes-devtools/cmake/cmake_%.bbappend
+++ b/recipes-devtools/cmake/cmake_%.bbappend
@@ -1,2 +1,2 @@
1DEPENDS_remove_mingw32 = "ncurses" 1DEPENDS:remove:mingw32 = "ncurses"
2RDEPENDS_${PN}-bash-completion_remove_mingw32 = "bash-completion" 2RDEPENDS:${PN}-bash-completion:remove:mingw32 = "bash-completion"
diff --git a/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend b/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
index 9c0d828..13ea016 100644
--- a/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
+++ b/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
@@ -1,9 +1,9 @@
1INSANE_SKIP_${PN}_append_sdkmingw32 = " staticdev" 1INSANE_SKIP:${PN}:append:sdkmingw32 = " staticdev"
2EXTRA_OECONF_append_sdkmingw32 = " --disable-nls" 2EXTRA_OECONF:append:sdkmingw32 = " --disable-nls"
3LDFLAGS_append_sdkmingw32 = " -Wl,-static" 3LDFLAGS:append:sdkmingw32 = " -Wl,-static"
4EXEEXT_sdkmingw32 = ".exe" 4EXEEXT:sdkmingw32 = ".exe"
5ELFUTILS_sdkmingw32 = "" 5ELFUTILS:sdkmingw32 = ""
6DEPENDS_remove_sdkmingw32 = "nativesdk-gettext" 6DEPENDS:remove:sdkmingw32 = "nativesdk-gettext"
7 7
8# With plugins enabled, it will output 'dll.a' files that are mistaken 8# With plugins enabled, it will output 'dll.a' files that are mistaken
9# for ELF which can trigger a failure. Simply avoid processing these 9# for ELF which can trigger a failure. Simply avoid processing these
diff --git a/recipes-devtools/gcc/gcc-crosssdk_%.bbappend b/recipes-devtools/gcc/gcc-crosssdk_%.bbappend
index 3411946..1a4bf6c 100644
--- a/recipes-devtools/gcc/gcc-crosssdk_%.bbappend
+++ b/recipes-devtools/gcc/gcc-crosssdk_%.bbappend
@@ -1,3 +1,3 @@
1PACKAGECONFIG_CONFARGS ?= "" 1PACKAGECONFIG_CONFARGS ?= ""
2EXTRA_OECONF_remove_mingw32 = "--enable-initfini-array --with-linker-hash-style=${LINKER_HASH_STYLE}" 2EXTRA_OECONF:remove:mingw32 = "--enable-initfini-array --with-linker-hash-style=${LINKER_HASH_STYLE}"
3EXTRA_OECONF_append_mingw32 = " --disable-initfini-array" 3EXTRA_OECONF:append:mingw32 = " --disable-initfini-array"
diff --git a/recipes-devtools/gcc/gcc-runtime_%.bbappend b/recipes-devtools/gcc/gcc-runtime_%.bbappend
index f14edf1..0013e88 100644
--- a/recipes-devtools/gcc/gcc-runtime_%.bbappend
+++ b/recipes-devtools/gcc/gcc-runtime_%.bbappend
@@ -1,14 +1,14 @@
1FILES_libstdc++_append_mingw32 = " ${bindir}/libstdc++*.dll" 1FILES:libstdc++_append_mingw32 = " ${bindir}/libstdc++*.dll"
2FILES_libstdc++-staticdev_append_mingw32 = " ${libdir}/libstdc++.dll.a*" 2FILES:libstdc++-staticdev_append_mingw32 = " ${libdir}/libstdc++.dll.a*"
3FILES_libssp_append_mingw32 = " ${bindir}/libssp*.dll" 3FILES:libssp:append:mingw32 = " ${bindir}/libssp*.dll"
4# FILES_libgomp_append_mingw32 = " ${bindir}/libgomp*.dll" 4# FILES:libgomp:append:mingw32 = " ${bindir}/libgomp*.dll"
5 5
6RUNTIMETARGET_remove_mingw32 = "libatomic libgomp" 6RUNTIMETARGET:remove:mingw32 = "libatomic libgomp"
7RUNTIMETARGET_remove_mingw32 = "libitm" 7RUNTIMETARGET:remove:mingw32 = "libitm"
8 8
9# Intel Memory Protection Extension library for x86 builds are now enabled 9# Intel Memory Protection Extension library for x86 builds are now enabled
10# by default. However, it does not build for mingw32, so remove it from 10# by default. However, it does not build for mingw32, so remove it from
11# mingw builds 11# mingw builds
12RUNTIMETARGET_remove_mingw32 = "libmpx" 12RUNTIMETARGET:remove:mingw32 = "libmpx"
13 13
14DEPENDS_append_mingw32 = " nativesdk-mingw-w64-winpthreads" 14DEPENDS:append:mingw32 = " nativesdk-mingw-w64-winpthreads"
diff --git a/recipes-devtools/gcc/gcc_%.bbappend b/recipes-devtools/gcc/gcc_%.bbappend
index a779bb9..c72363e 100644
--- a/recipes-devtools/gcc/gcc_%.bbappend
+++ b/recipes-devtools/gcc/gcc_%.bbappend
@@ -1,6 +1,6 @@
1FILES_${PN}_append_mingw32 = "\ 1FILES:${PN}:append:mingw32 = "\
2 ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/liblto_plugin-0.dll \ 2 ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/liblto_plugin-0.dll \
3 ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/liblto_plugin.dll.a \ 3 ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/liblto_plugin.dll.a \
4" 4"
5 5
6INSANE_SKIP_append_mingw32 = " staticdev" 6INSANE_SKIP:append:mingw32 = " staticdev"
diff --git a/recipes-devtools/gcc/libgcc_%.bbappend b/recipes-devtools/gcc/libgcc_%.bbappend
index f542cfc..743b5b7 100644
--- a/recipes-devtools/gcc/libgcc_%.bbappend
+++ b/recipes-devtools/gcc/libgcc_%.bbappend
@@ -1,9 +1,9 @@
1DEPENDS_append_mingw32 = " nativesdk-mingw-w64-winpthreads" 1DEPENDS:append:mingw32 = " nativesdk-mingw-w64-winpthreads"
2 2
3FILES_${PN}_append_mingw32 = " ${bindir}/libgcc*.dll" 3FILES:${PN}:append:mingw32 = " ${bindir}/libgcc*.dll"
4FILES_${PN}-dev_append_mingw32 = " ${base_libdir}/libgcc*.a" 4FILES:${PN}-dev:append:mingw32 = " ${base_libdir}/libgcc*.a"
5 5
6do_install_append_mingw32 () { 6do_install:append:mingw32 () {
7 # move the .dll files into bindir 7 # move the .dll files into bindir
8 install -d ${D}${bindir} 8 install -d ${D}${bindir}
9 mv ${D}${base_libdir}/libgcc*.dll ${D}${bindir}/ 9 mv ${D}${base_libdir}/libgcc*.dll ${D}${bindir}/
diff --git a/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend b/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
index 096fc63..9d8324f 100644
--- a/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
+++ b/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
@@ -1,7 +1,7 @@
1EXEEXT_sdkmingw32 = ".exe" 1EXEEXT:sdkmingw32 = ".exe"
2DEPENDS_remove_sdkmingw32 = "nativesdk-ncurses nativesdk-readline nativesdk-python" 2DEPENDS:remove:sdkmingw32 = "nativesdk-ncurses nativesdk-readline nativesdk-python"
3RDEPENDS_${PN}_remove_sdkmingw32 = "nativesdk-python-core nativesdk-python-lang nativesdk-python-re nativesdk-python-codecs nativesdk-python-netclient" 3RDEPENDS:${PN}:remove:sdkmingw32 = "nativesdk-python-core nativesdk-python-lang nativesdk-python-re nativesdk-python-codecs nativesdk-python-netclient"
4EXTRA_OECONF_append_sdkmingw32 = " --without-curses --without-system-readline --with-python=no" 4EXTRA_OECONF:append:sdkmingw32 = " --without-curses --without-system-readline --with-python=no"
5PACKAGECONFIG_remove_sdkmingw32 = "readline" 5PACKAGECONFIG:remove:sdkmingw32 = "readline"
6PACKAGECONFIG_remove_sdkmingw32 = "python" 6PACKAGECONFIG:remove:sdkmingw32 = "python"
7PACKAGECONFIG_remove_sdkmingw32 = "debuginfod" 7PACKAGECONFIG:remove:sdkmingw32 = "debuginfod"
diff --git a/recipes-devtools/go/go_%.bbappend b/recipes-devtools/go/go_%.bbappend
index 9933108..846a4ff 100644
--- a/recipes-devtools/go/go_%.bbappend
+++ b/recipes-devtools/go/go_%.bbappend
@@ -1,4 +1,4 @@
1do_install_append_class-nativesdk_mingw32() { 1do_install:append:class-nativesdk:mingw32() {
2 install -d ${D}${SDKPATHNATIVE}/environment-setup.d 2 install -d ${D}${SDKPATHNATIVE}/environment-setup.d
3 3
4 cat <<EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/go.bat 4 cat <<EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/go.bat
@@ -6,4 +6,4 @@ set GOROOT=%OECORE_NATIVE_SYSROOT%\\usr\\lib\\${BPN}
6EOF 6EOF
7} 7}
8 8
9FILES_${PN}_append_class-nativesdk_mingw32 = " ${SDKPATHNATIVE}/environment-setup.d" 9FILES:${PN}:append:class-nativesdk:mingw32 = " ${SDKPATHNATIVE}/environment-setup.d"
diff --git a/recipes-devtools/libtool/nativesdk-libtool_2.4.6.bbappend b/recipes-devtools/libtool/nativesdk-libtool_2.4.6.bbappend
index 4252e8d..63eb066 100644
--- a/recipes-devtools/libtool/nativesdk-libtool_2.4.6.bbappend
+++ b/recipes-devtools/libtool/nativesdk-libtool_2.4.6.bbappend
@@ -1 +1 @@
EXTRA_OECONF_append_mingw32 = " --disable-shared" \ No newline at end of file EXTRA_OECONF:append:mingw32 = " --disable-shared" \ No newline at end of file
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb
index 292d22b..68e77fa 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_8.0.0.bb
@@ -18,9 +18,9 @@ do_compile() {
18 : 18 :
19} 19}
20 20
21do_install_append() { 21do_install:append() {
22 # install correct pthread headers 22 # install correct pthread headers
23 install -m 0644 -t ${D}${includedir} ${S}/../mingw-w64-libraries/winpthreads/include/*.h 23 install -m 0644 -t ${D}${includedir} ${S}/../mingw-w64-libraries/winpthreads/include/*.h
24} 24}
25 25
26FILES_${PN} += "${exec_prefix}/${TARGET_SYS}" 26FILES:${PN} += "${exec_prefix}/${TARGET_SYS}"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb
index 0368841..02132c1 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_8.0.0.bb
@@ -9,7 +9,7 @@ B = "${WORKDIR}/build-${TARGET_SYS}"
9 9
10inherit autotools nativesdk 10inherit autotools nativesdk
11 11
12BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}" 12BUILDSDK_CPPFLAGS:append = " -isystem${STAGING_INCDIR}"
13 13
14INHIBIT_DEFAULT_DEPS = "1" 14INHIBIT_DEFAULT_DEPS = "1"
15DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc " 15DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc "
@@ -21,11 +21,11 @@ PROVIDES += "virtual/nativesdk-libintl"
21 21
22TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 22TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
23 23
24EXTRA_OECONF_x86-64 = "--disable-lib32" 24EXTRA_OECONF:x86-64 = "--disable-lib32"
25 25
26do_configure() { 26do_configure() {
27 oe_runconf 27 oe_runconf
28} 28}
29 29
30FILES_${PN} += "${exec_prefix}/libsrc" 30FILES:${PN} += "${exec_prefix}/libsrc"
31 31
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb
index 814268d..38092dc 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_8.0.0.bb
@@ -18,7 +18,7 @@ do_configure() {
18 18
19TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 19TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
20 20
21do_install_append() { 21do_install:append() {
22 # headers are already installed by mingw-w64-headers 22 # headers are already installed by mingw-w64-headers
23 rm -rf ${D}${includedir} 23 rm -rf ${D}${includedir}
24} 24}
diff --git a/recipes-devtools/ninja/ninja_%.bbappend b/recipes-devtools/ninja/ninja_%.bbappend
index e7ddb4d..8860e32 100644
--- a/recipes-devtools/ninja/ninja_%.bbappend
+++ b/recipes-devtools/ninja/ninja_%.bbappend
@@ -1,8 +1,8 @@
1do_compile_mingw32() { 1do_compile:mingw32() {
2 python3 ./configure.py --platform mingw 2 python3 ./configure.py --platform mingw
3 ninja 3 ninja
4} 4}
5 5
6do_install_mingw32() { 6do_install:mingw32() {
7 install -D -m 0755 ${S}/ninja.exe ${D}${bindir}/ninja.exe 7 install -D -m 0755 ${S}/ninja.exe ${D}${bindir}/ninja.exe
8} 8}
diff --git a/recipes-devtools/swig/swig_%.bbappend b/recipes-devtools/swig/swig_%.bbappend
index de40609..e5ce7e7 100644
--- a/recipes-devtools/swig/swig_%.bbappend
+++ b/recipes-devtools/swig/swig_%.bbappend
@@ -1,6 +1,6 @@
1# A wrapper script won't work to set SWIG_LIB for a mingw SDK. Instead, add an 1# A wrapper script won't work to set SWIG_LIB for a mingw SDK. Instead, add an
2# environment setup batch file to set SWIG_LIB when the SDK is configured. 2# environment setup batch file to set SWIG_LIB when the SDK is configured.
3do_install_append_class-nativesdk_mingw32() { 3do_install:append:class-nativesdk:mingw32() {
4 install -d ${D}${SDKPATHNATIVE}/environment-setup.d 4 install -d ${D}${SDKPATHNATIVE}/environment-setup.d
5 5
6 cat <<HEREDOC > ${D}${SDKPATHNATIVE}/environment-setup.d/swig.bat 6 cat <<HEREDOC > ${D}${SDKPATHNATIVE}/environment-setup.d/swig.bat
@@ -8,5 +8,5 @@ set SWIG_LIB=%OECORE_NATIVE_SYSROOT%\\usr\\share\\${BPN}\\${PV}
8HEREDOC 8HEREDOC
9} 9}
10 10
11FILES_${PN}_append_class-nativesdk_mingw32 = " ${SDKPATHNATIVE}/environment-setup.d" 11FILES:${PN}:append:class-nativesdk:mingw32 = " ${SDKPATHNATIVE}/environment-setup.d"
12 12