summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dbus/dbus-java_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dbus/dbus-java_2.7.bb')
-rw-r--r--recipes-extended/dbus/dbus-java_2.7.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/recipes-extended/dbus/dbus-java_2.7.bb b/recipes-extended/dbus/dbus-java_2.7.bb
index dfd2ff1..0e5ae92 100644
--- a/recipes-extended/dbus/dbus-java_2.7.bb
+++ b/recipes-extended/dbus/dbus-java_2.7.bb
@@ -1,15 +1,15 @@
1SUMMARY = "A pure Java D-Bus Implementation" 1SUMMARY = "A pure Java D-Bus Implementation"
2SUMMARY_${PN}-viewer = "${SUMMARY} (DBusViewer Binary)" 2SUMMARY:${PN}-viewer = "${SUMMARY} (DBusViewer Binary)"
3SUMMARY_${PN}-bin = "${SUMMARY} (Binaries)" 3SUMMARY:${PN}-bin = "${SUMMARY} (Binaries)"
4AUTHOR = "Matthew Johnson <dbus@matthew.ath.cx>" 4AUTHOR = "Matthew Johnson <dbus@matthew.ath.cx>"
5HOMEPAGE = "http://dbus.freedesktop.org/doc/dbus-java" 5HOMEPAGE = "http://dbus.freedesktop.org/doc/dbus-java"
6SECTION = "libs" 6SECTION = "libs"
7LICENSE = "LGPL-2.1 & AFL-2.1" 7LICENSE = "LGPL-2.1 & AFL-2.1"
8 8
9DEPENDS = "libmatthew gettext-native fastjar-native" 9DEPENDS = "libmatthew gettext-native fastjar-native"
10RDEPENDS_${PN}-viewer = "java2-runtime libunixsocket-java ${PN}-bin libmatthew-debug-java ${JPN}" 10RDEPENDS:${PN}-viewer = "java2-runtime libunixsocket-java ${PN}-bin libmatthew-debug-java ${JPN}"
11RDEPENDS_${PN}-bin = "java2-runtime libunixsocket-java libmatthew-debug-java ${JPN}" 11RDEPENDS:${PN}-bin = "java2-runtime libunixsocket-java libmatthew-debug-java ${JPN}"
12RSUGGESTS_${JPN} = "libunixsocket-java" 12RSUGGESTS:${JPN} = "libunixsocket-java"
13 13
14PR = "r1" 14PR = "r1"
15 15
@@ -25,6 +25,8 @@ S = "${WORKDIR}/dbus-java-${PV}"
25 25
26inherit java-library 26inherit java-library
27 27
28include recipes-core/classpath/classpath-features-check.inc
29
28# jamvm-native unfortunately contains non-generificed java/lang/reflect classes 30# jamvm-native unfortunately contains non-generificed java/lang/reflect classes
29# which are accessed in this package. Work around this by setting the bootclasspath 31# which are accessed in this package. Work around this by setting the bootclasspath
30# explicitly. 32# explicitly.
@@ -73,5 +75,5 @@ do_install () {
73# and dbus-bin*.jar 75# and dbus-bin*.jar
74PACKAGES = "${PN}-viewer ${PN}-bin ${JPN}" 76PACKAGES = "${PN}-viewer ${PN}-bin ${JPN}"
75 77
76FILES_${PN}-viewer = "${datadir}/java/dbus-java-viewer*.jar ${bindir}/DBusViewer" 78FILES:${PN}-viewer = "${datadir}/java/dbus-java-viewer*.jar ${bindir}/DBusViewer"
77FILES_${PN}-bin = "${datadir}/java/dbus-java-bin*.jar ${bindir}" 79FILES:${PN}-bin = "${datadir}/java/dbus-java-bin*.jar ${bindir}"