summaryrefslogtreecommitdiffstats
path: root/recipes-core/javasqlite/javasqlite_20150419.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/javasqlite/javasqlite_20150419.bb')
-rw-r--r--recipes-core/javasqlite/javasqlite_20150419.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-core/javasqlite/javasqlite_20150419.bb b/recipes-core/javasqlite/javasqlite_20150419.bb
index 06fbac2..45262e2 100644
--- a/recipes-core/javasqlite/javasqlite_20150419.bb
+++ b/recipes-core/javasqlite/javasqlite_20150419.bb
@@ -5,7 +5,7 @@ This is a Java wrapper including a basic JDBC driver for the SQLite 2/3 \
5database engine. It is designed using JNI to interface to the SQLite API. \ 5database engine. It is designed using JNI to interface to the SQLite API. \
6That API is wrapped by methods in the SQLite.Database class." 6That API is wrapped by methods in the SQLite.Database class."
7 7
8LICENSE = "BSD" 8LICENSE = "MIT-Modern-Variant"
9SECTION = "application" 9SECTION = "application"
10PR = "r1" 10PR = "r1"
11SRC_URI = " \ 11SRC_URI = " \
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "file://license.terms;md5=3da0e50feac5f64f08184584a8cad58a"
18inherit autotools-brokensep 18inherit autotools-brokensep
19 19
20DEPENDS += "sqlite3 sqlite3-native icedtea7-native" 20DEPENDS += "sqlite3 sqlite3-native icedtea7-native"
21RDEPENDS_${PN} += "sqlite3" 21RDEPENDS:${PN} += "sqlite3"
22FILES_${PN} +="/usr/share" 22FILES:${PN} +="/usr/share"
23 23
24PARALLEL_MAKE = "-j 1" 24PARALLEL_MAKE = "-j 1"
25 25
@@ -35,13 +35,9 @@ EXTRA_OECONF = " \
35EXTRA_OEMAKE = "DESTDIR=${D}" 35EXTRA_OEMAKE = "DESTDIR=${D}"
36 36
37# This dev package contains an '.so' file used for JNI development 37# This dev package contains an '.so' file used for JNI development
38INSANE_SKIP_${PN}-dev = "dev-elf" 38INSANE_SKIP:${PN}-dev = "dev-elf"
39 39
40do_configure_append (){ 40do_compile:prepend (){
41 cp ${S}/*-libtool ${S}/libtool
42}
43
44do_compile_prepend (){
45 echo '#!/bin/sh' > ${STAGING_BINDIR_NATIVE}/cc 41 echo '#!/bin/sh' > ${STAGING_BINDIR_NATIVE}/cc
46 echo '${BUILD_CC} $@' >> ${STAGING_BINDIR_NATIVE}/cc 42 echo '${BUILD_CC} $@' >> ${STAGING_BINDIR_NATIVE}/cc
47 chmod a+x ${STAGING_BINDIR_NATIVE}/cc 43 chmod a+x ${STAGING_BINDIR_NATIVE}/cc