summaryrefslogtreecommitdiffstats
path: root/recipes-core/antlr/antlr_2.7.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/antlr/antlr_2.7.7.bb')
-rw-r--r--recipes-core/antlr/antlr_2.7.7.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-core/antlr/antlr_2.7.7.bb b/recipes-core/antlr/antlr_2.7.7.bb
index d2453a9..d744201 100644
--- a/recipes-core/antlr/antlr_2.7.7.bb
+++ b/recipes-core/antlr/antlr_2.7.7.bb
@@ -5,11 +5,11 @@ LICENSE = "PD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=361934e706423915b4d9f413ad37fb65" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=361934e706423915b4d9f413ad37fb65"
6 6
7SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz" 7SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz"
8SRC_URI_append_class-native = " file://runantlr" 8SRC_URI:append:class-native = " file://runantlr"
9 9
10inherit java-library 10inherit java-library
11 11
12do_configure_class-native() { 12do_configure:class-native() {
13 sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr 13 sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr
14} 14}
15 15
@@ -21,7 +21,7 @@ do_compile() {
21 fastjar cf ${JARFILENAME} -C build . 21 fastjar cf ${JARFILENAME} -C build .
22} 22}
23 23
24do_install_class-native() { 24do_install:class-native() {
25 install -d ${D}${bindir} 25 install -d ${D}${bindir}
26 install -m 0755 ${WORKDIR}/runantlr ${D}${bindir}/ 26 install -m 0755 ${WORKDIR}/runantlr ${D}${bindir}/
27} 27}