summaryrefslogtreecommitdiffstats
path: root/recipes-core/jikes
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/jikes
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/jikes')
-rw-r--r--recipes-core/jikes/files/javac.jikes2
-rw-r--r--recipes-core/jikes/jikes-initial.bb24
-rw-r--r--recipes-core/jikes/jikes_1.22.bb36
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes-core/jikes/files/javac.jikes b/recipes-core/jikes/files/javac.jikes
new file mode 100644
index 0000000..8650d17
--- /dev/null
+++ b/recipes-core/jikes/files/javac.jikes
@@ -0,0 +1,2 @@
1#!/bin/sh
2jikes -bootclasspath /usr/share/classpath/glibj.zip $@
diff --git a/recipes-core/jikes/jikes-initial.bb b/recipes-core/jikes/jikes-initial.bb
new file mode 100644
index 0000000..613cb51
--- /dev/null
+++ b/recipes-core/jikes/jikes-initial.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4DEPENDS = "jikes-native classpath-initial"
5
6S = "${WORKDIR}"
7
8inherit native
9
10do_configure() {
11 :
12}
13
14do_compile() {
15 echo "#!/bin/sh" > jikes-initial
16 echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
17}
18
19do_install() {
20 install -d ${D}${bindir}
21 install -m 0755 jikes-initial ${D}${bindir}
22}
23
24NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes-core/jikes/jikes_1.22.bb b/recipes-core/jikes/jikes_1.22.bb
new file mode 100644
index 0000000..a3b7db3
--- /dev/null
+++ b/recipes-core/jikes/jikes_1.22.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Java compiler adhering to language and VM specifications"
2HOMEPAGE = "http://jikes.sourceforge.net/"
3PRIORITY = "optional"
4SECTION = "devel"
5LICENSE = "IBM"
6LIC_FILES_CHKSUM = " \
7 file://COPYING;md5=2d52359fd0d8f0c3e371e4cd19b213c0 \
8 file://doc/license.htm;md5=43506e48033a385dc0936f620ae2c745 \
9 "
10SRC_URI = "${SOURCEFORGE_MIRROR}/jikes/jikes-${PV}.tar.bz2"
11
12inherit autotools update-alternatives
13
14BBCLASSEXTEND = "native"
15
16RDEPENDS_${PN} = "classpath"
17PROVIDES_virtclass-native = ""
18RDEPENDS_${PN}_virtclass-native = ""
19
20EXTRA_OECONF = "--disable-fp-emulation --enable-source15"
21
22# configure script incorrectly defines these when cross compiling for ARM
23CXXFLAGS_append_arm += "-UHAVE_64BIT_TYPES -DWORDS_BIGENDIAN=1"
24
25do_install() {
26 oe_runmake 'DESTDIR=${D}' install
27 ln -s ${bindir}/jikes ${D}${bindir}/javac.jikes
28}
29
30PROVIDES = "virtual/javac"
31ALTERNATIVE_NAME = "javac"
32ALTERNATIVE_LINK = "/usr/bin/javac"
33ALTERNATIVE_PATH = "${bindir}/javac.jikes"
34
35SRC_URI[md5sum] = "cda958c7fef6b43b803e1d1ef9afcb85"
36SRC_URI[sha256sum] = "0cb02c763bc441349f6d38cacd52adf762302cce3a08e269f1f75f726e6e14e3"