summaryrefslogtreecommitdiffstats
path: root/recipes-core/jikes/jikes-initial.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jikes/jikes-initial.bb')
-rw-r--r--recipes-core/jikes/jikes-initial.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/jikes/jikes-initial.bb b/recipes-core/jikes/jikes-initial.bb
new file mode 100644
index 0000000..613cb51
--- /dev/null
+++ b/recipes-core/jikes/jikes-initial.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4DEPENDS = "jikes-native classpath-initial"
5
6S = "${WORKDIR}"
7
8inherit native
9
10do_configure() {
11 :
12}
13
14do_compile() {
15 echo "#!/bin/sh" > jikes-initial
16 echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
17}
18
19do_install() {
20 install -d ${D}${bindir}
21 install -m 0755 jikes-initial ${D}${bindir}
22}
23
24NATIVE_INSTALL_WORKS = "1"