summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/cacao-initial-native_0.98.bb
diff options
context:
space:
mode:
authorMagnus Olsson <magnus@minimum.se>2015-03-10 13:19:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-11 10:43:53 -0300
commitbd9c60238c4c62d9a0f2d60b89aef429a1b71e34 (patch)
tree0c1a1d5aeb46ad29e6dfadb45c54f4ec59b2b0bc /recipes-core/cacao/cacao-initial-native_0.98.bb
parentbd76e577a9f12b3036b0e7923b223dcd8b8ab7ed (diff)
downloadmeta-java-bd9c60238c4c62d9a0f2d60b89aef429a1b71e34.tar.gz
initials: silence "populate_sysroot manifest not found" warnings
A number of recipes in meta-java use autotools.bbclass for building; internally it uses the sstate-control populate_sysroot manifests to locate and copy aslocals for configure dependencies as part of the do_configure step. The manifest path differs depending on if it's a native package or not so autotools.bbclass looks at the package name to determine if its native or not (it's native if it ends with "-native"). The warnings are emitted because a few (native) recipes in meta-java (such as cacao-initial, classpath-initial and more) are incorrectly being classified as non-native by autotools.bbclass, which makes it look for the manifest in the wrong place and finally gives up with the warning: WARNING: /home/oe/tmp-glibc/sstate-control/manifest-mymachine-libecj-bootstrap.populate_sysroot not found This happens for cacao-initial, classpath-initial, ecj-initial, libecj-boostrap, jamvm-initial and jikes-initial since they are all native and rely on autotools. This patch renames the recipes so they end with -native, e.g ecj-initial-native. It also updates the recipes so they DEPEND on the corresponding new name. This helps autotools.bbclass to properly classify the recipes are native and silence the warnings. Signed-off-by: Magnus Olsson <magnus@minimum.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/cacao/cacao-initial-native_0.98.bb')
-rw-r--r--recipes-core/cacao/cacao-initial-native_0.98.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-core/cacao/cacao-initial-native_0.98.bb b/recipes-core/cacao/cacao-initial-native_0.98.bb
new file mode 100644
index 0000000..181faca
--- /dev/null
+++ b/recipes-core/cacao/cacao-initial-native_0.98.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "CacaoVM for use as OpenEmbedded's Java VM"
2HOMEPAGE = "http://www.cacaojvm.org/"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "interpreters"
6
7PROVIDES = "virtual/java-initial"
8
9inherit native autotools-brokensep
10
11DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial-native jikes-initial-native"
12
13SRC_URI = "\
14 http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \
15 file://cacao-0.98-initial.patch \
16 file://disable_hw_exceptions.patch \
17 "
18
19# libjvm disabled - it would conflict with cacao-native installations
20EXTRA_OECONF = "\
21 --enable-debug \
22 --with-classpath-libdir=${libdir} \
23 --with-classpath-includedir=${includedir}/classpath-initial \
24 --with-classpath-classes=${datadir}/classpath-initial/glibj.zip \
25 --with-vm-zip=${datadir}/cacao-initial/vm.zip \
26 --program-suffix=-initial \
27 --disable-libjvm \
28 "
29
30# enforces the usage of jikes-initial
31export JAVAC="jikes-initial"
32
33# enforces the usage of fastjar
34export JAR="fastjar"
35
36do_configure_append() {
37 # Fix the executable name in the wrapper script.
38 sed -i -e "s|exec cacao|exec cacao-initial|" src/scripts/java.in
39}
40
41SRC_URI[md5sum] = "8b8907c8b925761c9410bcadb9705346"
42SRC_URI[sha256sum] = "cb9363add825cedf77764fc49a223aaf43f0a9f485b711ba8c92f16b13fff188"