summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Olsson <magnus@minimum.se>2015-03-10 13:19:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-11 10:43:53 -0300
commitbd9c60238c4c62d9a0f2d60b89aef429a1b71e34 (patch)
tree0c1a1d5aeb46ad29e6dfadb45c54f4ec59b2b0bc
parentbd76e577a9f12b3036b0e7923b223dcd8b8ab7ed (diff)
downloadmeta-java-bd9c60238c4c62d9a0f2d60b89aef429a1b71e34.tar.gz
initials: silence "populate_sysroot manifest not found" warnings
A number of recipes in meta-java use autotools.bbclass for building; internally it uses the sstate-control populate_sysroot manifests to locate and copy aslocals for configure dependencies as part of the do_configure step. The manifest path differs depending on if it's a native package or not so autotools.bbclass looks at the package name to determine if its native or not (it's native if it ends with "-native"). The warnings are emitted because a few (native) recipes in meta-java (such as cacao-initial, classpath-initial and more) are incorrectly being classified as non-native by autotools.bbclass, which makes it look for the manifest in the wrong place and finally gives up with the warning: WARNING: /home/oe/tmp-glibc/sstate-control/manifest-mymachine-libecj-bootstrap.populate_sysroot not found This happens for cacao-initial, classpath-initial, ecj-initial, libecj-boostrap, jamvm-initial and jikes-initial since they are all native and rely on autotools. This patch renames the recipes so they end with -native, e.g ecj-initial-native. It also updates the recipes so they DEPEND on the corresponding new name. This helps autotools.bbclass to properly classify the recipes are native and silence the warnings. Signed-off-by: Magnus Olsson <magnus@minimum.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-core/cacao/cacao-initial-native_0.98.bb (renamed from recipes-core/cacao/cacao-initial_0.98.bb)2
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb2
-rw-r--r--recipes-core/classpath/classpath-initial-native_0.93.bb (renamed from recipes-core/classpath/classpath-initial_0.93.bb)0
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb2
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb2
-rw-r--r--recipes-core/ecj/ecj-initial-native.bb (renamed from recipes-core/ecj/ecj-initial.bb)2
-rw-r--r--recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb (renamed from recipes-core/ecj/libecj-bootstrap_3.6.2.bb)0
-rw-r--r--recipes-core/ecj/libecj-bootstrap.inc2
-rw-r--r--recipes-core/jamvm/jamvm-initial-native_1.4.5.bb (renamed from recipes-core/jamvm/jamvm-initial_1.4.5.bb)2
-rw-r--r--recipes-core/jamvm/jamvm.inc2
-rw-r--r--recipes-core/jikes/jikes-initial-native.bb (renamed from recipes-core/jikes/jikes-initial.bb)2
11 files changed, 9 insertions, 9 deletions
diff --git a/recipes-core/cacao/cacao-initial_0.98.bb b/recipes-core/cacao/cacao-initial-native_0.98.bb
index ad9436b..181faca 100644
--- a/recipes-core/cacao/cacao-initial_0.98.bb
+++ b/recipes-core/cacao/cacao-initial-native_0.98.bb
@@ -8,7 +8,7 @@ PROVIDES = "virtual/java-initial"
8 8
9inherit native autotools-brokensep 9inherit native autotools-brokensep
10 10
11DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial jikes-initial" 11DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial-native jikes-initial-native"
12 12
13SRC_URI = "\ 13SRC_URI = "\
14 http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \ 14 http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 2bd06c6..9f07946 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "interpreters" 5SECTION = "interpreters"
6 6
7DEPENDS_class-native = "zlib-native libtool-native ecj-initial fastjar-native classpath-native" 7DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native"
8PROVIDES_class-native = "virtual/java-native" 8PROVIDES_class-native = "virtual/java-native"
9 9
10DEPENDS = "zlib libtool classpath virtual/javac-native" 10DEPENDS = "zlib libtool classpath virtual/javac-native"
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb
index 0cfa693..0cfa693 100644
--- a/recipes-core/classpath/classpath-initial_0.93.bb
+++ b/recipes-core/classpath/classpath-initial-native_0.93.bb
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
index ece10c3..02951b9 100644
--- a/recipes-core/classpath/classpath-native_0.99.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,7 +1,7 @@
1require classpath-native.inc 1require classpath-native.inc
2 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" 3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4DEPENDS += "ecj-initial" 4DEPENDS += "ecj-initial-native"
5 5
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index c9be269..e159c9d 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
12 " 12 "
13PR = "r1" 13PR = "r1"
14 14
15DEPENDS = "libecj-bootstrap virtual/java-native" 15DEPENDS = "libecj-bootstrap-native virtual/java-native"
16 16
17PROVIDES = "virtual/javac-native" 17PROVIDES = "virtual/javac-native"
18 18
diff --git a/recipes-core/ecj/ecj-initial.bb b/recipes-core/ecj/ecj-initial-native.bb
index 45317a6..ed334ed 100644
--- a/recipes-core/ecj/ecj-initial.bb
+++ b/recipes-core/ecj/ecj-initial-native.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://www.eclipse.org/"
8LICENSE = "MIT" 8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" 9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
10 10
11DEPENDS = "libecj-bootstrap" 11DEPENDS = "libecj-bootstrap-native"
12 12
13SRC_URI = "file://ecj-initial.in" 13SRC_URI = "file://ecj-initial.in"
14 14
diff --git a/recipes-core/ecj/libecj-bootstrap_3.6.2.bb b/recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb
index 51dbca0..51dbca0 100644
--- a/recipes-core/ecj/libecj-bootstrap_3.6.2.bb
+++ b/recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc
index cd9d90f..9fb4156 100644
--- a/recipes-core/ecj/libecj-bootstrap.inc
+++ b/recipes-core/ecj/libecj-bootstrap.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.eclipse.org/"
5LICENSE = "EPL-1.0" 5LICENSE = "EPL-1.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6" 6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6"
7 7
8DEPENDS = "fastjar-native jikes-initial virtual/java-initial" 8DEPENDS = "fastjar-native jikes-initial-native virtual/java-initial"
9 9
10INC_PR = "r5" 10INC_PR = "r5"
11 11
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial-native_1.4.5.bb
index 4c64f6a..25b42b0 100644
--- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes-core/jamvm/jamvm-initial-native_1.4.5.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://jamvm.sourceforge.net/"
3LICENSE = "GPL" 3LICENSE = "GPL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native" 6DEPENDS = "zlib-native classpath-initial-native jikes-initial-native libffi-native"
7 7
8PROVIDES = "virtual/java-initial" 8PROVIDES = "virtual/java-initial"
9 9
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 094b22b..5893cbc 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS = "zlib classpath virtual/javac-native libffi" 6DEPENDS = "zlib classpath virtual/javac-native libffi"
7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial libffi-native" 7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native"
8 8
9RDEPENDS_${PN} = "classpath" 9RDEPENDS_${PN} = "classpath"
10RDEPENDS_${PN}_virtclass-native = "" 10RDEPENDS_${PN}_virtclass-native = ""
diff --git a/recipes-core/jikes/jikes-initial.bb b/recipes-core/jikes/jikes-initial-native.bb
index 4e6e870..239dea3 100644
--- a/recipes-core/jikes/jikes-initial.bb
+++ b/recipes-core/jikes/jikes-initial-native.bb
@@ -1,7 +1,7 @@
1SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler" 1SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690" 3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4DEPENDS = "jikes-native classpath-initial" 4DEPENDS = "jikes-native classpath-initial-native"
5 5
6S = "${WORKDIR}" 6S = "${WORKDIR}"
7 7