summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-02-17 10:57:14 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-02-17 10:53:34 -0200
commitc7f2b7dd60bff9092eeae6b7df7f8cae16994a21 (patch)
tree38bef7f119edcdbab5d4459008f3645b83ed0215 /classes
parent91e4ed3f74bbd4368f2fbbd5399dbaedf195bcf9 (diff)
downloadmeta-java-c7f2b7dd60bff9092eeae6b7df7f8cae16994a21.tar.gz
java-library: inherit allarch
Use the allarch class to make every packages in the 'all' ARCH. Recipes inheriting java-library which build additional packages which don't belong in to all ARCH must manually setting PACKAGE_ARCH after inheritting java-library. This fixes the following error when building e.g. rhino for a second machine of different architecture in the same build directory: ERROR: The recipe rhino is trying to install files into a shared area when those files already exist. Those files and their manifest location are: /.../ipk/all/librhino-java_1.7r4-r0_all.ipk Matched in manifest-armv7at2hf-vfp-rhino-package_write_ipk Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'classes')
-rw-r--r--classes/java-library.bbclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index a74c8d3..144cd2f 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -7,8 +7,12 @@
7# starts with "lib" and/or ends with "-java". In case the "lib" prefix is part of 7# starts with "lib" and/or ends with "-java". In case the "lib" prefix is part of
8# your package's normal name (e.g. liberator) the guessing is wrong and you have 8# your package's normal name (e.g. liberator) the guessing is wrong and you have
9# to set JPN manually! 9# to set JPN manually!
10#
11# package archs are set to all, if the recipe builds also packages which
12# can not be used for all archs, then set the PACKAGE_ARCH of that package
13# manually, see rxtx_xx.bb for an example.
10 14
11inherit java 15inherit java allarch
12 16
13# use java_stage for native packages 17# use java_stage for native packages
14JAVA_NATIVE_STAGE_INSTALL = "1" 18JAVA_NATIVE_STAGE_INSTALL = "1"
@@ -35,8 +39,6 @@ DEPENDS_prepend = "virtual/javac-native fastjar-native "
35 39
36PACKAGES += "${JPN}" 40PACKAGES += "${JPN}"
37 41
38PACKAGE_ARCH_${JPN} = "all"
39
40FILES_${JPN} = "${datadir_java}" 42FILES_${JPN} = "${datadir_java}"
41 43
42# File name of the libraries' main Jar file 44# File name of the libraries' main Jar file