summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/java-library.bbclass8
-rw-r--r--recipes-core/libmatthew/libmatthew.inc1
-rw-r--r--recipes-extended/rxtx/rxtx_2.2.0.bb1
3 files changed, 7 insertions, 3 deletions
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index a74c8d3..144cd2f 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -7,8 +7,12 @@
7# starts with "lib" and/or ends with "-java". In case the "lib" prefix is part of 7# starts with "lib" and/or ends with "-java". In case the "lib" prefix is part of
8# your package's normal name (e.g. liberator) the guessing is wrong and you have 8# your package's normal name (e.g. liberator) the guessing is wrong and you have
9# to set JPN manually! 9# to set JPN manually!
10#
11# package archs are set to all, if the recipe builds also packages which
12# can not be used for all archs, then set the PACKAGE_ARCH of that package
13# manually, see rxtx_xx.bb for an example.
10 14
11inherit java 15inherit java allarch
12 16
13# use java_stage for native packages 17# use java_stage for native packages
14JAVA_NATIVE_STAGE_INSTALL = "1" 18JAVA_NATIVE_STAGE_INSTALL = "1"
@@ -35,8 +39,6 @@ DEPENDS_prepend = "virtual/javac-native fastjar-native "
35 39
36PACKAGES += "${JPN}" 40PACKAGES += "${JPN}"
37 41
38PACKAGE_ARCH_${JPN} = "all"
39
40FILES_${JPN} = "${datadir_java}" 42FILES_${JPN} = "${datadir_java}"
41 43
42# File name of the libraries' main Jar file 44# File name of the libraries' main Jar file
diff --git a/recipes-core/libmatthew/libmatthew.inc b/recipes-core/libmatthew/libmatthew.inc
index b7e50bd..36622a8 100644
--- a/recipes-core/libmatthew/libmatthew.inc
+++ b/recipes-core/libmatthew/libmatthew.inc
@@ -8,6 +8,7 @@ DEPENDS = "virtual/java-native classpath-native classpath"
8S = "${WORKDIR}/libmatthew-java-${PV}" 8S = "${WORKDIR}/libmatthew-java-${PV}"
9 9
10inherit java-library 10inherit java-library
11PACKAGE_ARCH = "${TUNE_PKGARCH}"
11 12
12# Some internal version numbers which change from time to time. 13# Some internal version numbers which change from time to time.
13# Allowing to override them makes this include file more 14# Allowing to override them makes this include file more
diff --git a/recipes-extended/rxtx/rxtx_2.2.0.bb b/recipes-extended/rxtx/rxtx_2.2.0.bb
index 85f55c0..0d5aa21 100644
--- a/recipes-extended/rxtx/rxtx_2.2.0.bb
+++ b/recipes-extended/rxtx/rxtx_2.2.0.bb
@@ -23,6 +23,7 @@ S = "${WORKDIR}/rxtx-2.2pre2"
23INSANE_SKIP_${PN} += "dev-so" 23INSANE_SKIP_${PN} += "dev-so"
24 24
25inherit autotools-brokensep java-library 25inherit autotools-brokensep java-library
26PACKAGE_ARCH = "${TUNE_PKGARCH}"
26 27
27JARFILENAME = "RXTXcomm.jar" 28JARFILENAME = "RXTXcomm.jar"
28EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \ 29EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \