summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-04-09 15:06:59 +0300
committerMaxin B. John <maxin.john@intel.com>2018-04-09 17:18:03 +0300
commit9239be7e6a64560bba1e136367108012350f9ca0 (patch)
tree339ecfa749197cf3fca049c48d4c7ccafb683723
parentaf897090975d102d6136b2b64164b78da3b381c9 (diff)
downloadmeta-java-9239be7e6a64560bba1e136367108012350f9ca0.tar.gz
jamvm: refresh patches
Fixes this: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: patching file src/Makefile.am Hunk #1 succeeded at 23 with fuzz 1. Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch20
-rw-r--r--recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch10
-rw-r--r--recipes-core/jamvm/jamvm/libffi.patch38
3 files changed, 47 insertions, 21 deletions
diff --git a/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch b/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch
index f0884fd..f76da3c 100644
--- a/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch
+++ b/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch
@@ -1,9 +1,17 @@
1Index: jamvm-1.5.3/src/Makefile.am 1From a0169a5569a0373558bd99143a02ba3ebe80b81b Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Henning Heinold <heinold@inf.fu-berlin.de>
3--- jamvm-1.5.3.orig/src/Makefile.am 2009-09-29 09:29:13.386565473 +0200 3Date: Sat, 12 Nov 2011 20:58:34 +0100
4+++ jamvm-1.5.3/src/Makefile.am 2009-09-29 09:33:47.702565852 +0200 4
5@@ -23,7 +23,7 @@ 5---
6 DIST_SUBDIRS = os arch interp 6 src/Makefile.am | 2 +-
7 1 file changed, 1 insertion(+), 1 deletion(-)
8
9diff --git a/src/Makefile.am b/src/Makefile.am
10index 1cf2e87..1f06fed 100644
11--- a/src/Makefile.am
12+++ b/src/Makefile.am
13@@ -23,7 +23,7 @@ SUBDIRS = os interp classlib
14 DIST_SUBDIRS = os arch interp classlib
7 15
8 bin_PROGRAMS = jamvm 16 bin_PROGRAMS = jamvm
9-include_HEADERS = jni.h 17-include_HEADERS = jni.h
diff --git a/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
index bf0fda5..44fa606 100644
--- a/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
+++ b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
@@ -1,5 +1,13 @@
1From 2409bdf5de64f1a6f2d8d3c738b06d394b47c198 Mon Sep 17 00:00:00 2001
2From: Jan Luebbe <jlu@pengutronix.de>
3Date: Tue, 15 May 2012 09:56:31 +0000
4
5---
6 src/jam.c | 4 +---
7 1 file changed, 1 insertion(+), 3 deletions(-)
8
1diff --git a/src/jam.c b/src/jam.c 9diff --git a/src/jam.c b/src/jam.c
2index b76ce8b..dc5eac3 100644 10index 052f84a..460e4d3 100644
3--- a/src/jam.c 11--- a/src/jam.c
4+++ b/src/jam.c 12+++ b/src/jam.c
5@@ -133,9 +133,7 @@ int parseCommandLine(int argc, char *argv[], InitArgs *args) { 13@@ -133,9 +133,7 @@ int parseCommandLine(int argc, char *argv[], InitArgs *args) {
diff --git a/recipes-core/jamvm/jamvm/libffi.patch b/recipes-core/jamvm/jamvm/libffi.patch
index 1f68c5e..36143d7 100644
--- a/recipes-core/jamvm/jamvm/libffi.patch
+++ b/recipes-core/jamvm/jamvm/libffi.patch
@@ -1,8 +1,17 @@
1Index: git/configure.ac 1From fcd374ce67c0385ca94b09dfc1b1ddf13c3f631a Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Henning Heinold <heinold@inf.fu-berlin.de>
3--- git.orig/configure.ac 2011-11-18 15:47:15.339088111 +0100 3Date: Sat, 12 Nov 2011 20:58:34 +0100
4+++ git/configure.ac 2011-11-18 15:47:15.742392674 +0100 4
5@@ -273,9 +273,24 @@ 5---
6 configure.ac | 27 ++++++++++++++++++++-------
7 src/Makefile.am | 5 +++--
8 2 files changed, 23 insertions(+), 9 deletions(-)
9
10diff --git a/configure.ac b/configure.ac
11index 138b7e6..cc1990a 100644
12--- a/configure.ac
13+++ b/configure.ac
14@@ -272,9 +272,24 @@ if test "$enable_zip" != no; then
6 AC_CHECK_LIB(z,inflate,,AC_MSG_ERROR(zlib is missing)) 15 AC_CHECK_LIB(z,inflate,,AC_MSG_ERROR(zlib is missing))
7 fi 16 fi
8 17
@@ -29,7 +38,7 @@ Index: git/configure.ac
29 38
30 dnl Checks for header files. 39 dnl Checks for header files.
31 AC_HEADER_STDC 40 AC_HEADER_STDC
32@@ -285,10 +300,6 @@ 41@@ -284,10 +299,6 @@ if test "$enable_zip" != no; then
33 AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing)) 42 AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing))
34 fi 43 fi
35 44
@@ -40,7 +49,7 @@ Index: git/configure.ac
40 if test "$enable_zip" != no; then 49 if test "$enable_zip" != no; then
41 AC_DEFINE([USE_ZIP],1,[use zip]) 50 AC_DEFINE([USE_ZIP],1,[use zip])
42 use_zip_yes= 51 use_zip_yes=
43@@ -302,7 +313,9 @@ 52@@ -301,7 +312,9 @@ AC_SUBST(use_zip_yes)
44 AC_SUBST(use_zip_no) 53 AC_SUBST(use_zip_no)
45 54
46 if test "$enable_ffi" != no; then 55 if test "$enable_ffi" != no; then
@@ -51,13 +60,13 @@ Index: git/configure.ac
51 fi 60 fi
52 61
53 if test "$enable_md_stubs" != no; then 62 if test "$enable_md_stubs" != no; then
54Index: git/src/Makefile.am 63diff --git a/src/Makefile.am b/src/Makefile.am
55=================================================================== 64index 1f06fed..9c39edb 100644
56--- git.orig/src/Makefile.am 2011-11-18 15:47:15.685730049 +0100 65--- a/src/Makefile.am
57+++ git/src/Makefile.am 2011-11-18 15:49:43.881825251 +0100 66+++ b/src/Makefile.am
58@@ -43,8 +43,9 @@ 67@@ -44,9 +44,10 @@ jamvm_LDADD = libcore.la
59 jamvm_LDADD = libcore.la
60 libjvm_la_LIBADD = libcore.la 68 libjvm_la_LIBADD = libcore.la
69 libjvm_la_LDFLAGS = -avoid-version
61 libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \ 70 libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \
62- os/@os@/libos.la classlib/@classlib@/libclasslib.la 71- os/@os@/libos.la classlib/@classlib@/libclasslib.la
63+ os/@os@/libos.la classlib/@classlib@/libclasslib.la \ 72+ os/@os@/libos.la classlib/@classlib@/libclasslib.la \
@@ -66,4 +75,5 @@ Index: git/src/Makefile.am
66-AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine 75-AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine
67+AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine $(LIBFFI_CFLAGS) 76+AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine $(LIBFFI_CFLAGS)
68 77
69 DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h 78 DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h \
79 classlib-excep.h