summaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm/jamvm/libffi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jamvm/jamvm/libffi.patch')
-rw-r--r--recipes-core/jamvm/jamvm/libffi.patch38
1 files changed, 24 insertions, 14 deletions
diff --git a/recipes-core/jamvm/jamvm/libffi.patch b/recipes-core/jamvm/jamvm/libffi.patch
index 1f68c5e..36143d7 100644
--- a/recipes-core/jamvm/jamvm/libffi.patch
+++ b/recipes-core/jamvm/jamvm/libffi.patch
@@ -1,8 +1,17 @@
1Index: git/configure.ac 1From fcd374ce67c0385ca94b09dfc1b1ddf13c3f631a Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Henning Heinold <heinold@inf.fu-berlin.de>
3--- git.orig/configure.ac 2011-11-18 15:47:15.339088111 +0100 3Date: Sat, 12 Nov 2011 20:58:34 +0100
4+++ git/configure.ac 2011-11-18 15:47:15.742392674 +0100 4
5@@ -273,9 +273,24 @@ 5---
6 configure.ac | 27 ++++++++++++++++++++-------
7 src/Makefile.am | 5 +++--
8 2 files changed, 23 insertions(+), 9 deletions(-)
9
10diff --git a/configure.ac b/configure.ac
11index 138b7e6..cc1990a 100644
12--- a/configure.ac
13+++ b/configure.ac
14@@ -272,9 +272,24 @@ if test "$enable_zip" != no; then
6 AC_CHECK_LIB(z,inflate,,AC_MSG_ERROR(zlib is missing)) 15 AC_CHECK_LIB(z,inflate,,AC_MSG_ERROR(zlib is missing))
7 fi 16 fi
8 17
@@ -29,7 +38,7 @@ Index: git/configure.ac
29 38
30 dnl Checks for header files. 39 dnl Checks for header files.
31 AC_HEADER_STDC 40 AC_HEADER_STDC
32@@ -285,10 +300,6 @@ 41@@ -284,10 +299,6 @@ if test "$enable_zip" != no; then
33 AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing)) 42 AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing))
34 fi 43 fi
35 44
@@ -40,7 +49,7 @@ Index: git/configure.ac
40 if test "$enable_zip" != no; then 49 if test "$enable_zip" != no; then
41 AC_DEFINE([USE_ZIP],1,[use zip]) 50 AC_DEFINE([USE_ZIP],1,[use zip])
42 use_zip_yes= 51 use_zip_yes=
43@@ -302,7 +313,9 @@ 52@@ -301,7 +312,9 @@ AC_SUBST(use_zip_yes)
44 AC_SUBST(use_zip_no) 53 AC_SUBST(use_zip_no)
45 54
46 if test "$enable_ffi" != no; then 55 if test "$enable_ffi" != no; then
@@ -51,13 +60,13 @@ Index: git/configure.ac
51 fi 60 fi
52 61
53 if test "$enable_md_stubs" != no; then 62 if test "$enable_md_stubs" != no; then
54Index: git/src/Makefile.am 63diff --git a/src/Makefile.am b/src/Makefile.am
55=================================================================== 64index 1f06fed..9c39edb 100644
56--- git.orig/src/Makefile.am 2011-11-18 15:47:15.685730049 +0100 65--- a/src/Makefile.am
57+++ git/src/Makefile.am 2011-11-18 15:49:43.881825251 +0100 66+++ b/src/Makefile.am
58@@ -43,8 +43,9 @@ 67@@ -44,9 +44,10 @@ jamvm_LDADD = libcore.la
59 jamvm_LDADD = libcore.la
60 libjvm_la_LIBADD = libcore.la 68 libjvm_la_LIBADD = libcore.la
69 libjvm_la_LDFLAGS = -avoid-version
61 libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \ 70 libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \
62- os/@os@/libos.la classlib/@classlib@/libclasslib.la 71- os/@os@/libos.la classlib/@classlib@/libclasslib.la
63+ os/@os@/libos.la classlib/@classlib@/libclasslib.la \ 72+ os/@os@/libos.la classlib/@classlib@/libclasslib.la \
@@ -66,4 +75,5 @@ Index: git/src/Makefile.am
66-AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine 75-AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine
67+AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine $(LIBFFI_CFLAGS) 76+AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine $(LIBFFI_CFLAGS)
68 77
69 DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h 78 DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h \
79 classlib-excep.h