summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2017-08-31 17:48:35 +0300
committerMaxin B. John <maxin.john@intel.com>2017-09-01 11:55:59 +0300
commit8e26ce73cccdd7cd839426ced3f91b54102ad5b1 (patch)
treea7c3b05fe9ba09c29f9683acdd62dc38e025dbd5
parentc4b9b97c7c60ad5c0c3392ccf143b2e4e6c7df24 (diff)
downloadmeta-java-wip.tar.gz
meta-java: remove dependency on meta-oewip
remove dependency on meta-oe Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc3
-rw-r--r--recipes-core/openjdk/openjdk-7-common.inc6
-rw-r--r--recipes-core/openjdk/openjdk-8-cross.inc3
-rw-r--r--recipes-core/openjdk/openjdk-8-native.inc3
-rw-r--r--recipes-extended/bdwgc/bdwgc/0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch29
-rw-r--r--recipes-extended/bdwgc/bdwgc/musl_header_fix.patch27
-rw-r--r--recipes-extended/bdwgc/bdwgc_7.6.0.bb42
7 files changed, 108 insertions, 5 deletions
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index 55cb7e7..1a7b9b6 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -5,7 +5,7 @@ INC_PR = "r1"
5 5
6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ 6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \
7 rhino-native ant-native libxslt-native attr-native \ 7 rhino-native ant-native libxslt-native attr-native \
8 giflib-native jpeg-native libpng-native \ 8 jpeg-native libpng-native \
9 glib-2.0-native freetype-native zlib-native \ 9 glib-2.0-native freetype-native zlib-native \
10 fontconfig-native zip-native \ 10 fontconfig-native zip-native \
11 unzip-native make-native util-linux-native\ 11 unzip-native make-native util-linux-native\
@@ -13,6 +13,7 @@ DEPENDS = "virtual/javac-native virtual/java-native classpath-native \
13 13
14PACKAGECONFIG ??= "" 14PACKAGECONFIG ??= ""
15PACKAGECONFIG[x11] = ",--disable-headful,libx11-native xproto-native libxt-native libxext-native libxrender-native" 15PACKAGECONFIG[x11] = ",--disable-headful,libx11-native xproto-native libxt-native libxext-native libxrender-native"
16PACKAGECONFIG[gif] = ",--disable-system-gif, giflib"
16 17
17OEMAKE_BUILD_HEADLESS_ONLY = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', 'BUILD_HEADLESS_ONLY=1', d)}" 18OEMAKE_BUILD_HEADLESS_ONLY = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', 'BUILD_HEADLESS_ONLY=1', d)}"
18CFLAGS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', ' -DHEADLESS=true', d)}" 19CFLAGS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', ' -DHEADLESS=true', d)}"
diff --git a/recipes-core/openjdk/openjdk-7-common.inc b/recipes-core/openjdk/openjdk-7-common.inc
index 1ac3154..3d0cdc4 100644
--- a/recipes-core/openjdk/openjdk-7-common.inc
+++ b/recipes-core/openjdk/openjdk-7-common.inc
@@ -26,10 +26,10 @@ PROVIDES += "${JDKPN}"
26DEPENDS = " \ 26DEPENDS = " \
27 icedtea7-native zip-native ant-native \ 27 icedtea7-native zip-native ant-native \
28 zlib libxslt-native \ 28 zlib libxslt-native \
29 jpeg libpng giflib \ 29 jpeg libpng \
30 gtk+ glib-2.0 \ 30 gtk+ glib-2.0 \
31 cups fontconfig \ 31 cups fontconfig \
32 rhino krb5 \ 32 rhino \
33 libxt libxinerama libxrender libxtst libxi \ 33 libxt libxinerama libxrender libxtst libxi \
34 freetype alsa-lib libffi \ 34 freetype alsa-lib libffi \
35 attr \ 35 attr \
@@ -66,6 +66,8 @@ EXTRA_OECONF = " \
66 --disable-hotspot-tests \ 66 --disable-hotspot-tests \
67 --disable-langtools-tests \ 67 --disable-langtools-tests \
68 --disable-jdk-tests \ 68 --disable-jdk-tests \
69 --disable-system-kerberos \
70 --disable-system-gif \
69 --disable-docs \ 71 --disable-docs \
70 --disable-nss \ 72 --disable-nss \
71 --disable-system-lcms \ 73 --disable-system-lcms \
diff --git a/recipes-core/openjdk/openjdk-8-cross.inc b/recipes-core/openjdk/openjdk-8-cross.inc
index ad3a44d..55af747 100644
--- a/recipes-core/openjdk/openjdk-8-cross.inc
+++ b/recipes-core/openjdk/openjdk-8-cross.inc
@@ -18,7 +18,7 @@ PATCHES_URI_append = "\
18 18
19DEPENDS = "\ 19DEPENDS = "\
20 openjdk-8-native zip-native ant-native libxslt \ 20 openjdk-8-native zip-native ant-native libxslt \
21 jpeg libpng krb5 libffi fontconfig freetype \ 21 jpeg libpng libffi fontconfig freetype \
22" 22"
23 23
24PRIVATE_LIBS = "\ 24PRIVATE_LIBS = "\
@@ -43,6 +43,7 @@ PACKAGECONFIG[jce] = "--enable-unlimited-crypto,,"
43 43
44PACKAGECONFIG[zip] = "--with-zlib=system,--with-zlib=bundled,zlib," 44PACKAGECONFIG[zip] = "--with-zlib=system,--with-zlib=bundled,zlib,"
45PACKAGECONFIG[gif] = "--with-giflib=system,--with-giflib=bundled,giflib," 45PACKAGECONFIG[gif] = "--with-giflib=system,--with-giflib=bundled,giflib,"
46PACKAGECONFIG[krb5] = ",,,"
46 47
47export WANT_LLVM_RELEASE = "3.5.2" 48export WANT_LLVM_RELEASE = "3.5.2"
48PACKAGECONFIG[zero] = "--with-jvm-variants=zero,,," 49PACKAGECONFIG[zero] = "--with-jvm-variants=zero,,,"
diff --git a/recipes-core/openjdk/openjdk-8-native.inc b/recipes-core/openjdk/openjdk-8-native.inc
index fd97eff..d5079de 100644
--- a/recipes-core/openjdk/openjdk-8-native.inc
+++ b/recipes-core/openjdk/openjdk-8-native.inc
@@ -2,7 +2,7 @@ JDK_DIR = "openjdk-8-native"
2DEPENDS = "\ 2DEPENDS = "\
3 icedtea7-native ant-native \ 3 icedtea7-native ant-native \
4 libxslt-native attr-native \ 4 libxslt-native attr-native \
5 giflib-native jpeg-native libpng-native \ 5 jpeg-native libpng-native \
6 glib-2.0-native freetype-native fontconfig-native \ 6 glib-2.0-native freetype-native fontconfig-native \
7 zlib-native zip-native \ 7 zlib-native zip-native \
8 unzip-native make-native \ 8 unzip-native make-native \
@@ -13,6 +13,7 @@ PACKAGECONFIG ??= ""
13PACKAGECONFIG[x11] = "--with-x,,libx11-native xproto-native libxt-native libxext-native libxrender-native" 13PACKAGECONFIG[x11] = "--with-x,,libx11-native xproto-native libxt-native libxext-native libxrender-native"
14PACKAGECONFIG[cups] = "--with-cups,,cups" 14PACKAGECONFIG[cups] = "--with-cups,,cups"
15PACKAGECONFIG[alsa] = "--with-alsa,,alsa-lib-native" 15PACKAGECONFIG[alsa] = "--with-alsa,,alsa-lib-native"
16PACKAGECONFIG[alsa] = "--with-giflib,,giflib-native"
16PACKAGECONFIG[jce] = "--enable-unlimited-crypto,," 17PACKAGECONFIG[jce] = "--enable-unlimited-crypto,,"
17 18
18EXTRA_OECONF_append = "\ 19EXTRA_OECONF_append = "\
diff --git a/recipes-extended/bdwgc/bdwgc/0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch b/recipes-extended/bdwgc/bdwgc/0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch
new file mode 100644
index 0000000..8ef774f
--- /dev/null
+++ b/recipes-extended/bdwgc/bdwgc/0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch
@@ -0,0 +1,29 @@
1configure.ac: add check for NO_GETCONTEXT definition
2
3Signed-off-by: Samuel Martin <s.martin49@gmail.com>
4[yann.morin.1998@free.fr: add a comment, change variable name, use
5 AS_IF, remove debug traces, use AC_CHECK_FUNCS (as suggested by
6 Thomas)]
7Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
8Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
9
10---
11Upstream-Status: Pending
12 configure.ac | 6 ++++++
13 1 file changed, 6 insertions(+)
14
15--- bdwgc-7.2f.orig/configure.ac 2014-06-01 19:00:47.000000000 +0200
16+++ bdwgc-7.2f/configure.ac 2014-12-23 14:13:11.585716713 +0100
17@@ -365,6 +365,12 @@
18 AC_MSG_RESULT($ac_cv_fno_strict_aliasing)
19 fi
20
21+# Check for getcontext (uClibc can be configured without it, for example)
22+AC_CHECK_FUNCS([getcontext])
23+AS_IF([test "$ac_cv_func_getcontext" = "no"],
24+ [CFLAGS="$CFLAGS -DNO_GETCONTEXT"
25+ CPPFLAGS="$CPPFLAGS -DNO_GETCONTEXT"])
26+
27 case "$host" in
28 # While IRIX 6 has libdl for the O32 and N32 ABIs, it's missing for N64
29 # and unnecessary everywhere.
diff --git a/recipes-extended/bdwgc/bdwgc/musl_header_fix.patch b/recipes-extended/bdwgc/bdwgc/musl_header_fix.patch
new file mode 100644
index 0000000..4a18496
--- /dev/null
+++ b/recipes-extended/bdwgc/bdwgc/musl_header_fix.patch
@@ -0,0 +1,27 @@
1Add missing header to avoid:
2
3| 1472659610.016355: ../git/pthread_stop_world.c: In function 'GC_brief_async_signal_safe_sleep':
4| 1472659610.0540252: ../git/pthread_stop_world.c:397:22: error: storage size of 'tv' isn't known
5| 1472659610.0540252: struct timeval tv;
6| 1472659610.0540252: ^~
7| 1472659610.054099: ../git/pthread_stop_world.c:397:22: warning: unused variable 'tv' [-Wunused-variable]
8| 1472659610.054099: struct timeval tv;
9| 1472659610.054099: ^~
10| 1472659610.054099: Makefile:1530: recipe for target 'pthread_stop_world.lo' failed
11
12in musl builds.
13
14Upstream-Status: Pending
15
16Index: git/pthread_stop_world.c
17===================================================================
18--- git.orig/pthread_stop_world.c
19+++ git/pthread_stop_world.c
20@@ -45,6 +45,7 @@
21 #include <semaphore.h>
22 #include <errno.h>
23 #include <unistd.h>
24+#include <sys/time.h>
25 #include "atomic_ops.h"
26
27 /* It's safe to call original pthread_sigmask() here. */
diff --git a/recipes-extended/bdwgc/bdwgc_7.6.0.bb b/recipes-extended/bdwgc/bdwgc_7.6.0.bb
new file mode 100644
index 0000000..dcb68f0
--- /dev/null
+++ b/recipes-extended/bdwgc/bdwgc_7.6.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=4f81f24ec69726c312487c2ac740e9e3"
23
24SRCREV = "8ac1d84a40eb7a431fec1b8097e3f24b48fb23fa"
25SRC_URI = "git://github.com/ivmai/bdwgc.git \
26 file://0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch \
27 file://musl_header_fix.patch \
28 "
29
30FILES_${PN}-doc = "${datadir}"
31
32S = "${WORKDIR}/git"
33
34ARM_INSTRUCTION_SET = "arm"
35
36inherit autotools pkgconfig
37
38# by default use external libatomic-ops
39PACKAGECONFIG ??= "libatomic-ops"
40PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
41
42BBCLASSEXTEND = "native nativesdk"