summaryrefslogtreecommitdiffstats
path: root/recipes-extended/bdwgc/bdwgc_7.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/bdwgc/bdwgc_7.6.0.bb')
-rw-r--r--recipes-extended/bdwgc/bdwgc_7.6.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-extended/bdwgc/bdwgc_7.6.0.bb b/recipes-extended/bdwgc/bdwgc_7.6.0.bb
new file mode 100644
index 0000000..dcb68f0
--- /dev/null
+++ b/recipes-extended/bdwgc/bdwgc_7.6.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=4f81f24ec69726c312487c2ac740e9e3"
23
24SRCREV = "8ac1d84a40eb7a431fec1b8097e3f24b48fb23fa"
25SRC_URI = "git://github.com/ivmai/bdwgc.git \
26 file://0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch \
27 file://musl_header_fix.patch \
28 "
29
30FILES_${PN}-doc = "${datadir}"
31
32S = "${WORKDIR}/git"
33
34ARM_INSTRUCTION_SET = "arm"
35
36inherit autotools pkgconfig
37
38# by default use external libatomic-ops
39PACKAGECONFIG ??= "libatomic-ops"
40PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
41
42BBCLASSEXTEND = "native nativesdk"