summaryrefslogtreecommitdiffstats
path: root/recipes-support/jhi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/jhi')
-rw-r--r--recipes-support/jhi/jhi_1.41.bb72
1 files changed, 0 insertions, 72 deletions
diff --git a/recipes-support/jhi/jhi_1.41.bb b/recipes-support/jhi/jhi_1.41.bb
deleted file mode 100644
index badb928f..00000000
--- a/recipes-support/jhi/jhi_1.41.bb
+++ /dev/null
@@ -1,72 +0,0 @@
1SUMMARY = "Intel Dynamic Application Loader (DAL) Host Interface"
2DESCRIPTION = "A daemon and libraries which allow user space applications \
3to install Java applets on DAL FW and communicate with them"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=833126f14614a3276708a4d7c9734645"
6
7SRC_URI = "git://github.com/intel/dynamic-application-loader-host-interface.git;protocol=https"
8
9inherit cmake useradd systemd pkgconfig update-rc.d
10
11SRCREV = "4c9ef52bcd55fa03b30ac323e553a05be858d41e"
12
13S = "${WORKDIR}/git"
14
15DEPENDS += "util-linux libxml2"
16DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
17RDEPENDS_${PN} += "bash"
18
19USERADD_PACKAGES = "${PN}"
20USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false -g mei jhi"
21
22GROUPADD_PARAM_${PN} = "-g 880 mei"
23
24COMPATIBLE_HOST_libc-musl = 'null'
25
26SYSTEMD_SERVICE_${PN} = "jhi.service"
27
28INITSCRIPT_PACKAGES = "${PN}"
29INITSCRIPT_NAME_${PN} = "${PN}"
30INITSCRIPT_PARAMS_${PN} = "defaults"
31
32# systemd is the default so they are installed when sysvinit is not selected as INIT_SYSTEM
33EXTRA_OECMAKE = "-DCMAKE_SKIP_RPATH=ON \
34 -DINIT_SYSTEM=${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'SysVinit', 'systemd', d)} \
35 -DAPPLETS_DIR=${libdir}/dal/applets \
36 -DAPP_REPO_DIR=${localstatedir}/cache/dal/applet_repository \
37 "
38
39do_install_append () {
40 install -d ${D}${localstatedir}/cache/dal/applet_repository
41
42 chown -R jhi ${D}${localstatedir}/cache/dal/applet_repository
43 chgrp -R mei ${D}${localstatedir}/cache/dal/applet_repository
44
45 install -d ${D}${bindir}
46 install -m 755 ${B}/bin_linux/smoketest ${D}${bindir}
47 install -m 755 ${B}/bin_linux/bist ${D}${bindir}
48
49 install -d ${D}${libdir}/dal/applets
50 cp -r ${S}/test/smoketest/applets/* ${D}${libdir}/dal/applets/
51}
52
53PACKAGES += "${PN}-test"
54
55FILES_${PN}-dev = ""
56
57FILES_${PN} = "\
58 ${sbindir} \
59 ${sysconfdir} \
60 ${libdir}/lib*${SOLIBSDEV} \
61 ${libdir}/dal/applets/SpoolerApplet.dalp \
62 ${nonarch_libdir}/tmpfiles.d \
63 ${systemd_system_unitdir} \
64 ${localstatedir}/cache/dal/applet_repository \
65 "
66
67FILES_${PN}-test = "\
68 ${bindir} \
69 ${libdir}/dal/applets \
70 "
71
72UPSTREAM_CHECK_COMMITS = "1"