summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/isa-l/isa-l_2.31.0.bb (renamed from recipes-support/isa-l/isa-l_2.30.0.bb)8
-rw-r--r--recipes-support/jhi/jhi_1.41.bb72
-rw-r--r--recipes-support/libipt/libipt_2.1.1.bb (renamed from recipes-support/libipt/libipt_2.0.4.bb)13
-rw-r--r--recipes-support/sbsigntool/sbsigntool-native_git.bb16
-rw-r--r--recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch2
5 files changed, 22 insertions, 89 deletions
diff --git a/recipes-support/isa-l/isa-l_2.30.0.bb b/recipes-support/isa-l/isa-l_2.31.0.bb
index f06fd0b7..d5d09002 100644
--- a/recipes-support/isa-l/isa-l_2.30.0.bb
+++ b/recipes-support/isa-l/isa-l_2.31.0.bb
@@ -2,16 +2,18 @@ SUMMARY = "Intelligent Storage Acceleration Library"
2DESCRIPTION = "ISA-L is a collection of optimized low-level functions \ 2DESCRIPTION = "ISA-L is a collection of optimized low-level functions \
3targeting storage applications." 3targeting storage applications."
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e6c7d82ad7dd512687b0991a159a1ca9" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=2476688d0948d4a3f7c69473a603540d"
6SECTION = "lib" 6SECTION = "lib"
7 7
8inherit autotools pkgconfig 8inherit autotools pkgconfig
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11SRCREV = "2df39cf5f1b9ccaa2973f6ef273857e4dc46f0cf" 11SRCREV = "bd226375027899087bd48f3e59b910430615cc0a"
12SRC_URI = "git://github.com/intel/isa-l.git" 12SRC_URI = "git://github.com/intel/isa-l.git;branch=master;protocol=https"
13 13
14DEPENDS = "nasm-native" 14DEPENDS = "nasm-native"
15AS[unexport] = "1" 15AS[unexport] = "1"
16 16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
17COMPATIBLE_HOST = '(x86_64).*-linux' 19COMPATIBLE_HOST = '(x86_64).*-linux'
diff --git a/recipes-support/jhi/jhi_1.41.bb b/recipes-support/jhi/jhi_1.41.bb
deleted file mode 100644
index badb928f..00000000
--- a/recipes-support/jhi/jhi_1.41.bb
+++ /dev/null
@@ -1,72 +0,0 @@
1SUMMARY = "Intel Dynamic Application Loader (DAL) Host Interface"
2DESCRIPTION = "A daemon and libraries which allow user space applications \
3to install Java applets on DAL FW and communicate with them"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=833126f14614a3276708a4d7c9734645"
6
7SRC_URI = "git://github.com/intel/dynamic-application-loader-host-interface.git;protocol=https"
8
9inherit cmake useradd systemd pkgconfig update-rc.d
10
11SRCREV = "4c9ef52bcd55fa03b30ac323e553a05be858d41e"
12
13S = "${WORKDIR}/git"
14
15DEPENDS += "util-linux libxml2"
16DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
17RDEPENDS_${PN} += "bash"
18
19USERADD_PACKAGES = "${PN}"
20USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false -g mei jhi"
21
22GROUPADD_PARAM_${PN} = "-g 880 mei"
23
24COMPATIBLE_HOST_libc-musl = 'null'
25
26SYSTEMD_SERVICE_${PN} = "jhi.service"
27
28INITSCRIPT_PACKAGES = "${PN}"
29INITSCRIPT_NAME_${PN} = "${PN}"
30INITSCRIPT_PARAMS_${PN} = "defaults"
31
32# systemd is the default so they are installed when sysvinit is not selected as INIT_SYSTEM
33EXTRA_OECMAKE = "-DCMAKE_SKIP_RPATH=ON \
34 -DINIT_SYSTEM=${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'SysVinit', 'systemd', d)} \
35 -DAPPLETS_DIR=${libdir}/dal/applets \
36 -DAPP_REPO_DIR=${localstatedir}/cache/dal/applet_repository \
37 "
38
39do_install_append () {
40 install -d ${D}${localstatedir}/cache/dal/applet_repository
41
42 chown -R jhi ${D}${localstatedir}/cache/dal/applet_repository
43 chgrp -R mei ${D}${localstatedir}/cache/dal/applet_repository
44
45 install -d ${D}${bindir}
46 install -m 755 ${B}/bin_linux/smoketest ${D}${bindir}
47 install -m 755 ${B}/bin_linux/bist ${D}${bindir}
48
49 install -d ${D}${libdir}/dal/applets
50 cp -r ${S}/test/smoketest/applets/* ${D}${libdir}/dal/applets/
51}
52
53PACKAGES += "${PN}-test"
54
55FILES_${PN}-dev = ""
56
57FILES_${PN} = "\
58 ${sbindir} \
59 ${sysconfdir} \
60 ${libdir}/lib*${SOLIBSDEV} \
61 ${libdir}/dal/applets/SpoolerApplet.dalp \
62 ${nonarch_libdir}/tmpfiles.d \
63 ${systemd_system_unitdir} \
64 ${localstatedir}/cache/dal/applet_repository \
65 "
66
67FILES_${PN}-test = "\
68 ${bindir} \
69 ${libdir}/dal/applets \
70 "
71
72UPSTREAM_CHECK_COMMITS = "1"
diff --git a/recipes-support/libipt/libipt_2.0.4.bb b/recipes-support/libipt/libipt_2.1.1.bb
index a0554f44..c4b5ecaa 100644
--- a/recipes-support/libipt/libipt_2.0.4.bb
+++ b/recipes-support/libipt/libipt_2.1.1.bb
@@ -5,29 +5,30 @@ library or it can be partially or fully integrated into your tool."
5HOMEPAGE = "https://github.com/intel/libipt" 5HOMEPAGE = "https://github.com/intel/libipt"
6 6
7LICENSE = "BSD-3-Clause" 7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=aea4783603fc6bd8dff5157996ccb9d9" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=a429afa59f273b5d12778eda69d10313"
9 9
10inherit pkgconfig cmake 10inherit pkgconfig cmake
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14SRC_URI = "git://github.com/intel/libipt.git;protocol=https;branch=stable/v2.0" 14SRC_URI = "git://github.com/intel/libipt.git;protocol=https;branch=stable/v2.1"
15 15
16SRCREV = "63813186694487a2bc005f32be57eb526e16714b" 16SRCREV = "1c9bc700f4b9a71fd2d1cf1742de7e2351ddb281"
17 17
18EXTRA_OECMAKE += " \ 18EXTRA_OECMAKE += " \
19 -DPTDUMP=ON \ 19 -DPTDUMP=ON \
20 -DPTTC=ON \ 20 -DPTTC=ON \
21 -DPTSEG=ON \
21 -DCMAKE_SKIP_RPATH=ON \ 22 -DCMAKE_SKIP_RPATH=ON \
22 " 23 "
23 24
24do_install_append() { 25do_install:append() {
25 install -d ${D}${bindir}/libipt 26 install -d ${D}${bindir}/libipt
26 install -d ${D}${bindir}/libipt/tests 27 install -d ${D}${bindir}/libipt/tests
27 28
28 cp -r ${B}/bin/* ${D}${bindir}/libipt/ 29 cp -r ${B}/bin/* ${D}${bindir}/libipt/
29 cp -r ${WORKDIR}/git/test/src/* ${D}${bindir}/libipt/tests 30 cp -r ${S}/test/src/* ${D}${bindir}/libipt/tests
30} 31}
31 32
32FILES_${PN}-test = "${bindir}" 33FILES:${PN}-test = "${bindir}"
33PACKAGES =+ "${PN}-test" 34PACKAGES =+ "${PN}-test"
diff --git a/recipes-support/sbsigntool/sbsigntool-native_git.bb b/recipes-support/sbsigntool/sbsigntool-native_git.bb
index f6094a5c..5a9f5b4d 100644
--- a/recipes-support/sbsigntool/sbsigntool-native_git.bb
+++ b/recipes-support/sbsigntool/sbsigntool-native_git.bb
@@ -1,5 +1,5 @@
1DESCRIPTION = "Utility for signing and verifying files for UEFI Secure Boot" 1DESCRIPTION = "Utility for signing and verifying files for UEFI Secure Boot"
2LICENSE = "GPLv3 & LGPL-2.1 & LGPL-3.0 & MIT" 2LICENSE = "GPL-3.0-only & LGPL-2.1-only & LGPL-3.0-only & MIT"
3 3
4# sbsigntool statically links to libccan.a which is built with modules 4# sbsigntool statically links to libccan.a which is built with modules
5# passed to "create-ccan-tree" (and their dependencies). Therefore, 5# passed to "create-ccan-tree" (and their dependencies). Therefore,
@@ -19,25 +19,25 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=9eef91148a9b14ec7f9df333daebc746 \
19 19
20# The original upstream is git://kernel.ubuntu.com/jk/sbsigntool but it has 20# The original upstream is git://kernel.ubuntu.com/jk/sbsigntool but it has
21# not been maintained and many patches have been backported in this repo. 21# not been maintained and many patches have been backported in this repo.
22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools \ 22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools;branch=master \
23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan \ 23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan;branch=master \
24 file://0001-configure-Fixup-build-dependencies-for-cross-compili.patch \ 24 file://0001-configure-Fixup-build-dependencies-for-cross-compili.patch \
25 " 25 "
26 26
27SRCREV_sbsigntools ?= "f12484869c9590682ac3253d583bf59b890bb826" 27SRCREV_sbsigntools ?= "9cfca9fe7aa7a8e29b92fe33ce8433e212c9a8ba"
28SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5" 28SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5"
29SRCREV_FORMAT = "sbsigntools_ccan" 29SRCREV_FORMAT = "sbsigntools_ccan"
30 30
31DEPENDS = "binutils-native gnu-efi-native help2man-native openssl-native util-linux-native" 31DEPENDS = "binutils-native gnu-efi-native help2man-native openssl-native util-linux-native"
32 32
33PV = "0.9.4-git${SRCPV}" 33PV = "0.9.5"
34 34
35S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
36 36
37inherit autotools pkgconfig 37inherit autotools pkgconfig
38inherit native 38inherit native
39 39
40do_configure_prepend() { 40do_configure:prepend() {
41 cd ${S} 41 cd ${S}
42 42
43 sed -i s#RECIPE_SYSROOT#${RECIPE_SYSROOT_NATIVE}#g configure.ac 43 sed -i s#RECIPE_SYSROOT#${RECIPE_SYSROOT_NATIVE}#g configure.ac
@@ -79,3 +79,5 @@ EXTRA_OEMAKE = "\
79 -I${STAGING_INCDIR_NATIVE} \ 79 -I${STAGING_INCDIR_NATIVE} \
80 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \ 80 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \
81 " 81 "
82
83CFLAGS:append = " -Wno-error"
diff --git a/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch b/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch
index ef686511..ea7bee29 100644
--- a/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch
+++ b/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch
@@ -10,7 +10,7 @@ under /usr/include and /usr/lib.
10Prepend these paths with a placeholder that can be replaced with the 10Prepend these paths with a placeholder that can be replaced with the
11actual paths once they are resolved. 11actual paths once they are resolved.
12 12
13Upstream status: inappropriate [OE specific] 13Upstream-Status: Inappropriate [OE specific]
14 14
15Signed-off-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com> 15Signed-off-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
16 16