summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libva/libva-intel_2.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libva/libva-intel_2.20.0.bb')
-rw-r--r--recipes-graphics/libva/libva-intel_2.20.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes-graphics/libva/libva-intel_2.20.0.bb b/recipes-graphics/libva/libva-intel_2.20.0.bb
new file mode 100644
index 00000000..c81ed65c
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel_2.20.0.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2 \
21 "
22SRC_URI[sha256sum] = "f72bdb4f48dfe71ad01f1cbefe069672a2c949a6abd51cf3c4d4784210badc49"
23
24S = "${WORKDIR}/libva-${PV}"
25
26UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
27
28DEPENDS = "libdrm"
29
30inherit meson pkgconfig
31
32PACKAGECONFIG ??= " \
33 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
34 ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
35"
36
37PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
38PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
39
40PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
41
42PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
43
44RDEPENDS:${PN}-x11 =+ "${PN}"
45RDEPENDS:${PN}-glx =+ "${PN}-x11"
46
47FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
48FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
49FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
50
51PROVIDES += "libva"
52RPROVIDES:${PN} += "libva"
53RPROVIDES:${PN}-x11 += "libva-x11"
54RPROVIDES:${PN}-glx += "libva-glx"
55RPROVIDES:${PN}-wayland += "libva-wayland"