summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libva
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libva')
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.21.0.bb35
-rw-r--r--recipes-graphics/libva/libva-intel_2.21.0.bb56
2 files changed, 91 insertions, 0 deletions
diff --git a/recipes-graphics/libva/libva-intel-utils_2.21.0.bb b/recipes-graphics/libva/libva-intel-utils_2.21.0.bb
new file mode 100644
index 00000000..0407aa18
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel-utils_2.21.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "libva-utils is a collection of utilities from libva project"
2
3DESCRIPTION = "libva-utils is a collection of utilities \
4and examples to exercise VA-API in accordance with the libva \
5project.VA-API is an open-source library and API specification, \
6which provides access to graphics hardware acceleration capabilities \
7for video processing. It consists of a main library and driver-specific \
8acceleration backends for each supported hardware vendor"
9
10HOMEPAGE = "https://01.org/linuxmedia/vaapi"
11BUGTRACKER = "https://github.com/intel/libva-utils/issues"
12
13SECTION = "x11"
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16
17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.21-branch;protocol=https"
18SRCREV = "5a59217d5d288f7671ca18d3764139289d83a93e"
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
22
23DEPENDS = "libva"
24
25inherit meson pkgconfig features_check
26
27# depends on libva which requires opengl
28REQUIRED_DISTRO_FEATURES = "opengl"
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
31PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland"
33
34PROVIDES = "libva-utils"
35RPROVIDES:${PN} += "libva-utils"
diff --git a/recipes-graphics/libva/libva-intel_2.21.0.bb b/recipes-graphics/libva/libva-intel_2.21.0.bb
new file mode 100644
index 00000000..83fb3646
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel_2.21.0.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "git://github.com/intel/libva.git;protocol=https;branch=v2.21-branch \
21 "
22
23SRCREV = "0b01aed44ef1a6ad660261284ff266fa812829ef"
24
25S = "${WORKDIR}/git"
26
27UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
28
29DEPENDS = "libdrm"
30
31inherit meson pkgconfig
32
33PACKAGECONFIG ??= " \
34 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
35 ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
36"
37
38PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
39PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
40
41PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
42
43PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
44
45RDEPENDS:${PN}-x11 =+ "${PN}"
46RDEPENDS:${PN}-glx =+ "${PN}-x11"
47
48FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
49FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
50FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
51
52PROVIDES += "libva"
53RPROVIDES:${PN} += "libva"
54RPROVIDES:${PN}-x11 += "libva-x11"
55RPROVIDES:${PN}-glx += "libva-glx"
56RPROVIDES:${PN}-wayland += "libva-wayland"