summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/gmmlib
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/gmmlib')
-rw-r--r--recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch34
-rw-r--r--recipes-graphics/gmmlib/gmmlib_22.3.18.bb (renamed from recipes-graphics/gmmlib/gmmlib_18.4.1.bb)11
2 files changed, 42 insertions, 3 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
new file mode 100644
index 00000000..195b3c58
--- /dev/null
+++ b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
@@ -0,0 +1,34 @@
1From 683f3552e7d5089601bb37952641b1c7691cf475 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Mon, 25 Mar 2024 11:13:27 +0530
4Subject: [PATCH] Add new DG2 device IDs (#194)
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/dcc4b85ea3728c848b62fbb164c00f43b519b6fb]
7
8Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com>
9---
10 Source/inc/common/igfxfmid.h | 4 ++++
11 1 file changed, 4 insertions(+)
12
13diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
14index 1264087..e944e1e 100644
15--- a/Source/inc/common/igfxfmid.h
16+++ b/Source/inc/common/igfxfmid.h
17@@ -1934,6 +1934,8 @@ typedef enum __NATIVEGTTYPE
18 #define DEV_ID_56BB 0x56BB
19 #define DEV_ID_56BC 0x56BC
20 #define DEV_ID_56BD 0x56BD
21+#define DEV_ID_56BE 0x56BE
22+#define DEV_ID_56BF 0x56BF
23 #define DEV_ID_56C0 0x56C0
24 #define DEV_ID_56C1 0x56C1
25 #define DEV_ID_56C2 0x56C2
26@@ -2001,6 +2003,8 @@ typedef enum __NATIVEGTTYPE
27 ( d == DEV_ID_5690 ) || \
28 ( d == DEV_ID_5691 ) || \
29 ( d == DEV_ID_5692 ) || \
30+ ( d == DEV_ID_56BE ) || \
31+ ( d == DEV_ID_56BF ) || \
32 ( d == DEV_ID_56C0 ) || \
33 ( d == DEV_ID_56C2 ) || \
34 ( d == DEV_ID_4F80 ) || \
diff --git a/recipes-graphics/gmmlib/gmmlib_18.4.1.bb b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb
index ad2d11af..134a6461 100644
--- a/recipes-graphics/gmmlib/gmmlib_18.4.1.bb
+++ b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb
@@ -4,18 +4,23 @@ device specific and buffer management for the Intel(R) Graphics \
4Compute Runtime for OpenCL(TM) and the Intel(R) Media Driver for VAAPI." 4Compute Runtime for OpenCL(TM) and the Intel(R) Media Driver for VAAPI."
5 5
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=d9a6e772cd4c362ee4c8ef87c5aad843" 7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://github.com/intel/gmmlib.git;protocol=https \ 10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \
11 file://0001-Add-new-DG2-device-IDs-194.patch \
11 " 12 "
12 13
13SRCREV = "413896ed8e7ead3dd1c0fea9a4fe7f8326b7b9ff" 14SRCREV = "ac964bdffdda7730e8234511f61016071e63783b"
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
16 17
18COMPATIBLE_HOST:x86-x32 = "null"
19
17UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$" 20UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$"
18 21
19inherit pkgconfig cmake 22inherit pkgconfig cmake
20 23
21EXTRA_OECMAKE += "-DRUN_TEST_SUITE=OFF" 24EXTRA_OECMAKE += "-DRUN_TEST_SUITE=OFF"
25
26BBCLASSEXTEND = "native nativesdk"