summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch34
-rw-r--r--recipes-graphics/gmmlib/gmmlib_22.3.18.bb (renamed from recipes-graphics/gmmlib/gmmlib_18.4.1.bb)11
-rw-r--r--recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch42
-rw-r--r--recipes-graphics/hdcp/hdcp_21.2.0.bb26
-rw-r--r--recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb42
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.21.0.bb35
-rw-r--r--recipes-graphics/libva/libva-intel_2.21.0.bb56
-rw-r--r--recipes-graphics/metrics-discovery/metrics-discovery_1.12.171.bb (renamed from recipes-graphics/metrics-discovery/metrics-discovery_1.5.100.bb)7
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-ast_1.1.6.bb (renamed from recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb)4
9 files changed, 207 insertions, 50 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
new file mode 100644
index 00000000..195b3c58
--- /dev/null
+++ b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
@@ -0,0 +1,34 @@
1From 683f3552e7d5089601bb37952641b1c7691cf475 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Mon, 25 Mar 2024 11:13:27 +0530
4Subject: [PATCH] Add new DG2 device IDs (#194)
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/dcc4b85ea3728c848b62fbb164c00f43b519b6fb]
7
8Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com>
9---
10 Source/inc/common/igfxfmid.h | 4 ++++
11 1 file changed, 4 insertions(+)
12
13diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
14index 1264087..e944e1e 100644
15--- a/Source/inc/common/igfxfmid.h
16+++ b/Source/inc/common/igfxfmid.h
17@@ -1934,6 +1934,8 @@ typedef enum __NATIVEGTTYPE
18 #define DEV_ID_56BB 0x56BB
19 #define DEV_ID_56BC 0x56BC
20 #define DEV_ID_56BD 0x56BD
21+#define DEV_ID_56BE 0x56BE
22+#define DEV_ID_56BF 0x56BF
23 #define DEV_ID_56C0 0x56C0
24 #define DEV_ID_56C1 0x56C1
25 #define DEV_ID_56C2 0x56C2
26@@ -2001,6 +2003,8 @@ typedef enum __NATIVEGTTYPE
27 ( d == DEV_ID_5690 ) || \
28 ( d == DEV_ID_5691 ) || \
29 ( d == DEV_ID_5692 ) || \
30+ ( d == DEV_ID_56BE ) || \
31+ ( d == DEV_ID_56BF ) || \
32 ( d == DEV_ID_56C0 ) || \
33 ( d == DEV_ID_56C2 ) || \
34 ( d == DEV_ID_4F80 ) || \
diff --git a/recipes-graphics/gmmlib/gmmlib_18.4.1.bb b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb
index ad2d11af..134a6461 100644
--- a/recipes-graphics/gmmlib/gmmlib_18.4.1.bb
+++ b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb
@@ -4,18 +4,23 @@ device specific and buffer management for the Intel(R) Graphics \
4Compute Runtime for OpenCL(TM) and the Intel(R) Media Driver for VAAPI." 4Compute Runtime for OpenCL(TM) and the Intel(R) Media Driver for VAAPI."
5 5
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=d9a6e772cd4c362ee4c8ef87c5aad843" 7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://github.com/intel/gmmlib.git;protocol=https \ 10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \
11 file://0001-Add-new-DG2-device-IDs-194.patch \
11 " 12 "
12 13
13SRCREV = "413896ed8e7ead3dd1c0fea9a4fe7f8326b7b9ff" 14SRCREV = "ac964bdffdda7730e8234511f61016071e63783b"
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
16 17
18COMPATIBLE_HOST:x86-x32 = "null"
19
17UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$" 20UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$"
18 21
19inherit pkgconfig cmake 22inherit pkgconfig cmake
20 23
21EXTRA_OECMAKE += "-DRUN_TEST_SUITE=OFF" 24EXTRA_OECMAKE += "-DRUN_TEST_SUITE=OFF"
25
26BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch b/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch
new file mode 100644
index 00000000..6d32da43
--- /dev/null
+++ b/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch
@@ -0,0 +1,42 @@
1From 5cbcecff0bb7fa1c617d3082e7ad94c22e5f4eb1 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 3 Jul 2019 17:13:15 +0800
4Subject: [PATCH] main: fix hdcpd service failure
5
6Child process not able to finish before parent process
7exits, which causing hdcpd service failure.
8
9Added wait function to block parent process
10until child process exits.
11
12Upstream-Status: Submitted [https://github.com/intel/hdcp/pull/17]
13
14Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
15---
16 daemon/main.cpp | 3 +++
17 1 file changed, 3 insertions(+)
18
19diff --git a/daemon/main.cpp b/daemon/main.cpp
20index 9a028d7..ef1e047 100644
21--- a/daemon/main.cpp
22+++ b/daemon/main.cpp
23@@ -36,6 +36,7 @@
24 #include <sys/ioctl.h>
25 #include <fcntl.h>
26 #include <iostream>
27+#include <sys/wait.h>
28
29 #include "hdcpdef.h"
30 #include "srm.h"
31@@ -93,6 +94,8 @@ int32_t daemon_init(void)
32 }
33 else if (pid != 0)
34 {
35+ int status;
36+ wait(&status);
37 exit(SUCCESS); // parent exit
38 }
39
40--
412.17.1
42
diff --git a/recipes-graphics/hdcp/hdcp_21.2.0.bb b/recipes-graphics/hdcp/hdcp_21.2.0.bb
new file mode 100644
index 00000000..8529b5ab
--- /dev/null
+++ b/recipes-graphics/hdcp/hdcp_21.2.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Intel(R) unified HDCP SDK"
2DESCRIPTION = "This is a user space implementation to prevent copying of \
3digital audio & video content across digital display interfaces. It provides \
4Linux user space implementation to enable the HDCP1.4 and HDCP2.2 protection \
5for external digital display interface"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c50969be4feb8b99c6baa3795ede4dce"
8SECTION = "lib"
9
10inherit pkgconfig cmake useradd systemd features_check
11
12SRC_URI = "git://github.com/intel/hdcp.git;branch=master;protocol=https \
13 file://0001-main-fix-hdcpd-service-failure.patch \
14"
15SRCREV = "cacc352159c5bdaf1c21846cecdd1eb7b031e1d3"
16S = "${WORKDIR}/git"
17
18REQUIRED_DISTRO_FEATURES = "systemd"
19
20DEPENDS = "libdrm virtual/mesa systemd"
21
22USERADD_PACKAGES = "${PN}"
23USERADD_PARAM:${PN} = "--system --no-create-home --shell /bin/false --gid nogroup media"
24
25SYSTEMD_SERVICE:${PN} = "hdcpd.service"
26SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb b/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb
deleted file mode 100644
index 9fe2950a..00000000
--- a/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1require ${COREBASE}/meta/recipes-graphics/xorg-app/xorg-app-common.inc
2
3SUMMARY = "Intel GPU tools"
4DESCRIPTION = "Variety of small tools for testing intel graphics."
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4b3dd344780e0400593b21b115a6947"
7
8LICENSE_append = " & ISC"
9
10inherit autotools gtk-doc
11
12SRC_URI = "${XORG_MIRROR}/individual/app/${BP}.tar.xz"
13
14DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr procps libunwind kmod openssl"
15RDEPENDS_${PN} += "bash"
16RDEPENDS_${PN}-tests += "bash"
17
18PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests"
19
20SRC_URI[md5sum] = "04c1f10d6fd85e079271540b0ea786e9"
21SRC_URI[sha256sum] = "4d4b086c513bace5c23d0889de3f42ac3ebd3d968c64dedae6e28e006a499ad0"
22
23EXTRA_OECONF = "--disable-nouveau --disable-shader-debugger"
24COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
25COMPATIBLE_HOST_libc-musl_class-target = "null"
26
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[audio] = "--enable-audio,--disable-audio,alsa-lib gsl"
29
30gputools_sysroot_preprocess() {
31 rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc
32}
33SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess"
34
35FILES_${PN} += "${libdir}/intel_aubdump.so"
36FILES_${PN}-benchmarks += "${libexecdir}/${BPN}/benchmarks"
37FILES_${PN}-tests += "\
38 ${libexecdir}/${BPN}/*\
39 ${datadir}/${BPN}/1080p-right.png\
40 ${datadir}/${BPN}/1080p-left.png\
41 ${datadir}/${BPN}/pass.png\
42 ${datadir}/${BPN}/test-list.txt"
diff --git a/recipes-graphics/libva/libva-intel-utils_2.21.0.bb b/recipes-graphics/libva/libva-intel-utils_2.21.0.bb
new file mode 100644
index 00000000..0407aa18
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel-utils_2.21.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "libva-utils is a collection of utilities from libva project"
2
3DESCRIPTION = "libva-utils is a collection of utilities \
4and examples to exercise VA-API in accordance with the libva \
5project.VA-API is an open-source library and API specification, \
6which provides access to graphics hardware acceleration capabilities \
7for video processing. It consists of a main library and driver-specific \
8acceleration backends for each supported hardware vendor"
9
10HOMEPAGE = "https://01.org/linuxmedia/vaapi"
11BUGTRACKER = "https://github.com/intel/libva-utils/issues"
12
13SECTION = "x11"
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16
17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.21-branch;protocol=https"
18SRCREV = "5a59217d5d288f7671ca18d3764139289d83a93e"
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
22
23DEPENDS = "libva"
24
25inherit meson pkgconfig features_check
26
27# depends on libva which requires opengl
28REQUIRED_DISTRO_FEATURES = "opengl"
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
31PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland"
33
34PROVIDES = "libva-utils"
35RPROVIDES:${PN} += "libva-utils"
diff --git a/recipes-graphics/libva/libva-intel_2.21.0.bb b/recipes-graphics/libva/libva-intel_2.21.0.bb
new file mode 100644
index 00000000..83fb3646
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel_2.21.0.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "git://github.com/intel/libva.git;protocol=https;branch=v2.21-branch \
21 "
22
23SRCREV = "0b01aed44ef1a6ad660261284ff266fa812829ef"
24
25S = "${WORKDIR}/git"
26
27UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
28
29DEPENDS = "libdrm"
30
31inherit meson pkgconfig
32
33PACKAGECONFIG ??= " \
34 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
35 ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
36"
37
38PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
39PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
40
41PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
42
43PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
44
45RDEPENDS:${PN}-x11 =+ "${PN}"
46RDEPENDS:${PN}-glx =+ "${PN}-x11"
47
48FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
49FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
50FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
51
52PROVIDES += "libva"
53RPROVIDES:${PN} += "libva"
54RPROVIDES:${PN}-x11 += "libva-x11"
55RPROVIDES:${PN}-glx += "libva-glx"
56RPROVIDES:${PN}-wayland += "libva-wayland"
diff --git a/recipes-graphics/metrics-discovery/metrics-discovery_1.5.100.bb b/recipes-graphics/metrics-discovery/metrics-discovery_1.12.171.bb
index 5320129f..d3f32c25 100644
--- a/recipes-graphics/metrics-discovery/metrics-discovery_1.5.100.bb
+++ b/recipes-graphics/metrics-discovery/metrics-discovery_1.12.171.bb
@@ -2,14 +2,15 @@ SUMMARY = "Intel Metrics Discovery Application Programming Interface"
2DESCRIPTION = "This software is a user mode library that provides access to \ 2DESCRIPTION = "This software is a user mode library that provides access to \
3GPU performance data." 3GPU performance data."
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5ac9e51fb25f5d5b10a1bea412a4b74c" 5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8c5c9ac8ffd04a5614befdf63fba6ba8"
6SECTION = "lib" 6SECTION = "lib"
7 7
8inherit pkgconfig cmake 8inherit pkgconfig cmake
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11SRCREV = "a6accaf9844d453177047866caaa9eda34582de9" 11SRCREV = "24c4dfd45df1600ca83dfb03217675edc4633ffd"
12SRC_URI = "git://github.com/intel/metrics-discovery.git" 12SRC_URI = "git://github.com/intel/metrics-discovery.git;branch=master;protocol=https \
13 "
13 14
14EXTRA_OECMAKE += "-DMD_PLATFORM=linux" 15EXTRA_OECMAKE += "-DMD_PLATFORM=linux"
15EXTRA_OECMAKE += "-DMD_LIBDRM_SRC=${STAGING_INCDIR}" 16EXTRA_OECMAKE += "-DMD_LIBDRM_SRC=${STAGING_INCDIR}"
diff --git a/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb b/recipes-graphics/xorg-driver/xf86-video-ast_1.1.6.bb
index 090efd62..d7e4eab4 100644
--- a/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-ast_1.1.6.bb
@@ -7,6 +7,6 @@ DESCRIPTION = "ast is an Xorg driver for ASpeed Technologies video cards"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0b8c242f0218eea5caa949b7910a774b" 7LIC_FILES_CHKSUM = "file://COPYING;md5=0b8c242f0218eea5caa949b7910a774b"
8 8
9DEPENDS += "libpciaccess" 9DEPENDS += "libpciaccess"
10XORG_DRIVER_COMPRESSOR = ".tar.gz"
10 11
11SRC_URI[md5sum] = "4f85febe48d51e53624550a96fc9e9ee" 12SRC_URI[sha256sum] = "eeff52178ce2916a0e07b531bb23c8b105826b6e6e6c5f7c90e33f757827a7c7"
12SRC_URI[sha256sum] = "1edbbc55d47d3fd71dec99b15c2483e22738c642623a0fb86ef4a81a9067a2de"