summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb
new file mode 100644
index 00000000..aeedcb29
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb
@@ -0,0 +1,61 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Open Model Zoo repository"
2HOMEPAGE = "https://github.com/opencv/open_model_zoo"
3DESCRIPTION = "This repository includes optimized deep learning \
4models and a set of demos to expedite development of high-performance \
5deep learning inference applications."
6
7SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=git;branch=master \
8 file://0001-use-oe-gflags.patch \
9 "
10
11SRCREV = "912eeaddc034e31dedd34617d82bcc2ddf83e542"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
15"
16
17inherit cmake
18
19S = "${WORKDIR}/git/demos"
20
21DEPENDS += "openvino-inference-engine opencv gflags"
22
23RDEPENDS_${PN} += " \
24 python3-decorator \
25 python3-defusedxml \
26 python3-networkx \
27 python3-protobuf \
28 python3-test-generator \
29 python3-requests \
30 python3-pyyaml \
31"
32
33COMPATIBLE_HOST = '(x86_64).*-linux'
34
35EXTRA_OECMAKE += " \
36 -DIE_MAIN_SOURCE_DIR=${B} \
37 -DENABLE_SAMPLES=ON \
38 -DIE_INCLUDE_DIR=${STAGING_EXECPREFIXDIR} \
39 -DIE_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine.so \
40 -DIE_C_API_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_c_api.so \
41 -DIE_LEGACY_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_legacy.so \
42 -DIE_NN_BUILDER_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_nn_builder.so \
43 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \
44"
45
46do_configure_prepend(){
47 mkdir -p ${WORKDIR}/InferenceEngine/share
48 cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/
49}
50
51do_install(){
52 install -d ${D}${libdir}
53 install -d ${D}${bindir}
54 install -d ${D}${datadir}/openvino/open-model-zoo/tools
55 cp -rf ${WORKDIR}/build/intel64/Release/lib/*.a ${D}${libdir}
56 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir}
57 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo
58 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools
59}
60
61FILES_${PN} += "${datadir}/openvino"