summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch78
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020r1.bb)5
2 files changed, 42 insertions, 41 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
index 8fc7e32e..a938b942 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
@@ -1,4 +1,4 @@
1From 6fef79d47c2b92b3e194c412849d44ef632f9905 Mon Sep 17 00:00:00 2001 1From d63d1a1291a2715b7d70ed88c4d764b22e6f2f4d Mon Sep 17 00:00:00 2001
2From: Liwei Song <liwei.song@windriver.com> 2From: Liwei Song <liwei.song@windriver.com>
3Date: Fri, 22 May 2020 15:47:44 +0800 3Date: Fri, 22 May 2020 15:47:44 +0800
4Subject: [PATCH] use meta-oe gflags 4Subject: [PATCH] use meta-oe gflags
@@ -10,15 +10,15 @@ Upstream-Status: Inappropriate [meta-intel specific]
10 10
11Signed-off-by: Liwei Song <liwei.song@windriver.com> 11Signed-off-by: Liwei Song <liwei.song@windriver.com>
12--- 12---
13 CMakeLists.txt | 8 ++++---- 13 CMakeLists.txt | 8 ++++----
14 multi_channel/common/CMakeLists.txt | 2 +- 14 multi_channel/common/CMakeLists.txt | 2 +-
15 multi_channel/face_detection_demo/CMakeLists.txt | 2 +- 15 multi_channel/face_detection_demo/CMakeLists.txt | 2 +-
16 human_pose_estimation_demo/CMakeLists.txt | 2 +- 16 multi_channel/human_pose_estimation_demo/CMakeLists.txt | 2 +-
17 object_detection_demo_yolov3/CMakeLists.txt | 2 +- 17 multi_channel/object_detection_demo_yolov3/CMakeLists.txt | 2 +-
18 5 files changed, 8 insertions(+), 8 deletions(-) 18 5 files changed, 8 insertions(+), 8 deletions(-)
19 19
20diff --git a/CMakeLists.txt b/CMakeLists.txt 20diff --git a/CMakeLists.txt b/CMakeLists.txt
21index b22b2734656f..ed89411f1dfa 100644 21index 40b549f..dfdbf93 100644
22--- a/CMakeLists.txt 22--- a/CMakeLists.txt
23+++ b/CMakeLists.txt 23+++ b/CMakeLists.txt
24@@ -89,12 +89,10 @@ if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU) 24@@ -89,12 +89,10 @@ if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
@@ -35,8 +35,8 @@ index b22b2734656f..ed89411f1dfa 100644
35 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU) 35 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
36 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall") 36 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
37 endif() 37 endif()
38@@ -185,7 +183,7 @@ macro(ie_add_sample) 38@@ -177,7 +175,7 @@ macro(ie_add_sample)
39 endif() 39 target_include_directories(${IE_SAMPLE_NAME} PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/../common")
40 40
41 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${OpenCV_LIBRARIES} ${InferenceEngine_LIBRARIES} 41 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${OpenCV_LIBRARIES} ${InferenceEngine_LIBRARIES}
42- ${IE_SAMPLE_DEPENDENCIES} gflags) 42- ${IE_SAMPLE_DEPENDENCIES} gflags)
@@ -44,7 +44,7 @@ index b22b2734656f..ed89411f1dfa 100644
44 44
45 if(UNIX) 45 if(UNIX)
46 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE pthread) 46 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE pthread)
47@@ -206,11 +204,13 @@ endmacro() 47@@ -198,11 +196,13 @@ endmacro()
48 # use this flag if you need to throw custom message in case if the IE package is not found. 48 # use this flag if you need to throw custom message in case if the IE package is not found.
49 if (IE_NOT_FOUND_MESSAGE) 49 if (IE_NOT_FOUND_MESSAGE)
50 find_package(InferenceEngine 2.0 QUIET) 50 find_package(InferenceEngine 2.0 QUIET)
@@ -57,59 +57,59 @@ index b22b2734656f..ed89411f1dfa 100644
57+ find_package(gflags 2.2 REQUIRED) 57+ find_package(gflags 2.2 REQUIRED)
58 endif() 58 endif()
59 59
60 # collect all samples subdirectories 60 find_package(ngraph REQUIRED)
61diff --git a/multi_channel/common/CMakeLists.txt b/multi_channel/common/CMakeLists.txt 61diff --git a/multi_channel/common/CMakeLists.txt b/multi_channel/common/CMakeLists.txt
62index 740f3e1ec46e..573d12606d33 100644 62index d5e5d93..c33afbb 100644
63--- a/multi_channel/common/CMakeLists.txt 63--- a/multi_channel/common/CMakeLists.txt
64+++ b/multi_channel/common/CMakeLists.txt 64+++ b/multi_channel/common/CMakeLists.txt
65@@ -113,7 +113,7 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}") 65@@ -110,7 +110,7 @@ endif()
66 if(TARGET IE::ie_cpu_extension) 66
67 add_definitions(-DWITH_EXTENSIONS) 67 target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
68 endif() 68
69-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES}) 69-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES})
70+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES}) 70+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES})
71 if(TARGET IE::ie_cpu_extension) 71
72 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension) 72 if(UNIX)
73 endif() 73 target_link_libraries( ${TARGET_NAME} pthread)
74diff --git a/multi_channel/face_detection_demo/CMakeLists.txt b/multi_channel/face_detection_demo/CMakeLists.txt 74diff --git a/multi_channel/face_detection_demo/CMakeLists.txt b/multi_channel/face_detection_demo/CMakeLists.txt
75index 41730f1d73d4..3b2eb100ccf8 100644 75index 5b497fc..78c518e 100644
76--- a/multi_channel/face_detection_demo/CMakeLists.txt 76--- a/multi_channel/face_detection_demo/CMakeLists.txt
77+++ b/multi_channel/face_detection_demo/CMakeLists.txt 77+++ b/multi_channel/face_detection_demo/CMakeLists.txt
78@@ -64,7 +64,7 @@ if(TARGET IE::ie_cpu_extension) 78@@ -60,7 +60,7 @@ if(MULTICHANNEL_DEMO_USE_TBB)
79 add_definitions(-DWITH_EXTENSIONS) 79 endif()
80 endif() 80 endif()
81 81
82-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common) 82-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common)
83+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common) 83+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
84 84
85 if(TARGET IE::ie_cpu_extension) 85 if(UNIX)
86 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension) 86 target_link_libraries( ${TARGET_NAME} pthread)
87diff --git a/multi_channel/human_pose_estimation_demo/CMakeLists.txt b/multi_channel/human_pose_estimation_demo/CMakeLists.txt 87diff --git a/multi_channel/human_pose_estimation_demo/CMakeLists.txt b/multi_channel/human_pose_estimation_demo/CMakeLists.txt
88index f4c05cf5b0e8..2602f59c314f 100644 88index 7fe4823..7e76796 100644
89--- a/multi_channel/human_pose_estimation_demo/CMakeLists.txt 89--- a/multi_channel/human_pose_estimation_demo/CMakeLists.txt
90+++ b/multi_channel/human_pose_estimation_demo/CMakeLists.txt 90+++ b/multi_channel/human_pose_estimation_demo/CMakeLists.txt
91@@ -63,7 +63,7 @@ endif() 91@@ -60,7 +60,7 @@ if(MULTICHANNEL_DEMO_USE_TBB)
92 if(TARGET IE::ie_cpu_extension) 92 endif()
93 add_definitions(-DWITH_EXTENSIONS)
94 endif() 93 endif()
94
95-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common) 95-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common)
96+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common) 96+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common)
97 if(TARGET IE::ie_cpu_extension) 97
98 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension) 98 if(UNIX)
99 endif() 99 target_link_libraries( ${TARGET_NAME} pthread)
100diff --git a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt 100diff --git a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
101index 2f2b3bc540f8..ac10776e2b4e 100644 101index e959349..cf1de4a 100644
102--- a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt 102--- a/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
103+++ b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt 103+++ b/multi_channel/object_detection_demo_yolov3/CMakeLists.txt
104@@ -64,7 +64,7 @@ if(TARGET IE::ie_cpu_extension) 104@@ -60,7 +60,7 @@ if(MULTICHANNEL_DEMO_USE_TBB)
105 add_definitions(-DWITH_EXTENSIONS) 105 endif()
106 endif() 106 endif()
107 107
108-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} common) 108-target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} gflags ${OpenCV_LIBRARIES} ngraph::ngraph common)
109+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} common) 109+target_link_libraries(${TARGET_NAME} ${InferenceEngine_LIBRARIES} ${GFLAGS_LIBRARIES} ${OpenCV_LIBRARIES} ngraph::ngraph common)
110 110
111 if(TARGET IE::ie_cpu_extension) 111 if(UNIX)
112 target_link_libraries(${TARGET_NAME} IE::ie_cpu_extension) 112 target_link_libraries( ${TARGET_NAME} pthread)
113-- 113--
1142.17.1 1142.25.4
115 115
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020r1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb
index 102fcd47..aeedcb29 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020r1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2020.3.bb
@@ -8,7 +8,7 @@ SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=git;branch=master
8 file://0001-use-oe-gflags.patch \ 8 file://0001-use-oe-gflags.patch \
9 " 9 "
10 10
11SRCREV = "efd238d02035f8a5417b7b1e25cd4c997d44351f" 11SRCREV = "912eeaddc034e31dedd34617d82bcc2ddf83e542"
12 12
13LICENSE = "Apache-2.0" 13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ 14LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
@@ -18,7 +18,7 @@ inherit cmake
18 18
19S = "${WORKDIR}/git/demos" 19S = "${WORKDIR}/git/demos"
20 20
21DEPENDS += "dldt-inference-engine opencv gflags" 21DEPENDS += "openvino-inference-engine opencv gflags"
22 22
23RDEPENDS_${PN} += " \ 23RDEPENDS_${PN} += " \
24 python3-decorator \ 24 python3-decorator \
@@ -38,6 +38,7 @@ EXTRA_OECMAKE += " \
38 -DIE_INCLUDE_DIR=${STAGING_EXECPREFIXDIR} \ 38 -DIE_INCLUDE_DIR=${STAGING_EXECPREFIXDIR} \
39 -DIE_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine.so \ 39 -DIE_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine.so \
40 -DIE_C_API_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_c_api.so \ 40 -DIE_C_API_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_c_api.so \
41 -DIE_LEGACY_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_legacy.so \
41 -DIE_NN_BUILDER_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_nn_builder.so \ 42 -DIE_NN_BUILDER_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_nn_builder.so \
42 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \ 43 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \
43" 44"