summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/dnn/files
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/dnn/files')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch34
-rw-r--r--dynamic-layers/clang-layer/recipes-core/dnn/files/0002-src-CMakeLists.txt-use-value-of-DESTDIR.patch33
-rwxr-xr-xdynamic-layers/clang-layer/recipes-core/dnn/files/run-ptest15
3 files changed, 82 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch b/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch
new file mode 100644
index 00000000..aee0934a
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch
@@ -0,0 +1,34 @@
1From 89ebbee73ff0af48eaaec63335b749a176a317bb Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 21 Apr 2020 09:18:09 +0800
4Subject: [PATCH 1/2] src/CMakeLists.txt: fix FindOpenCL.cmake source path
5
6The existing logic doesn't work when DESTDIR is being passed to cmake.
7The file is installed in DESTDIR/CMAKE_INSTALL_PREFIX/libdir while we're
8trying to copy it from CMAKE_INSTALL_PREFIX/libdir.
9
10Use the file from source tree instead.
11
12Upstream-Status: Submitted
13
14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
15---
16 src/CMakeLists.txt | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
20index 88e318923..0c99fefae 100644
21--- a/src/CMakeLists.txt
22+++ b/src/CMakeLists.txt
23@@ -203,7 +203,7 @@ if(DNNL_GPU_RUNTIME STREQUAL "OCL")
24 install(FILES
25 "../cmake/FindOpenCL.cmake"
26 DESTINATION ${LIB_CONFIG_INSTALL_DIR})
27- install(FILES "${CMAKE_INSTALL_PREFIX}/${LIB_CONFIG_INSTALL_DIR}/FindOpenCL.cmake"
28+ install(FILES "../cmake/FindOpenCL.cmake"
29 DESTINATION ${LIB_CONFIG_INSTALL_DIR_COMPAT})
30 endif()
31
32--
332.25.3
34
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/files/0002-src-CMakeLists.txt-use-value-of-DESTDIR.patch b/dynamic-layers/clang-layer/recipes-core/dnn/files/0002-src-CMakeLists.txt-use-value-of-DESTDIR.patch
new file mode 100644
index 00000000..02c0f81e
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/files/0002-src-CMakeLists.txt-use-value-of-DESTDIR.patch
@@ -0,0 +1,33 @@
1From 3693305c9497f940b011e3e8b9d707d4f8075234 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 21 Apr 2020 09:19:38 +0800
4Subject: [PATCH 2/2] src/CMakeLists.txt: use value of DESTDIR
5
6Make sure that we're using the value of DESTDIR for the paths that are
7being created to look into paths of installed files. Ensure that
8cmake_install.cmake actually has $ENV{DESTDIR} which gets expanded if
9it's being passed to cmake.
10
11Upstream-Status: Submitted
12
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14---
15 src/CMakeLists.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
19index 0c99fefae..2f1499d0d 100644
20--- a/src/CMakeLists.txt
21+++ b/src/CMakeLists.txt
22@@ -137,7 +137,7 @@ install(EXPORT ${LIB_EXPORT_NAME}
23
24 # Intel MKL-DNN compat cmake files
25 install(CODE "execute_process(COMMAND ${CMAKE_COMMAND}
26- -DDIR=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/cmake
27+ -DDIR=\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/cmake
28 -P ${PROJECT_SOURCE_DIR}/cmake/gen_mkldnn_compat_cmakes.cmake)")
29
30 # Intel MKL-DNN compat libraries
31--
322.25.3
33
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/files/run-ptest b/dynamic-layers/clang-layer/recipes-core/dnn/files/run-ptest
new file mode 100755
index 00000000..82d4df58
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/files/run-ptest
@@ -0,0 +1,15 @@
1#!/bin/sh
2
3cd tests
4./api-c
5if [ $? -eq 0 ]; then
6 echo 'PASS: api-c'
7else
8 echo 'FAIL: api-c'
9fi
10./test_c_symbols-c
11if [ $? -eq 0 ]; then
12 echo 'PASS: test_c_symbols-c'
13else
14 echo 'FAIL: test_c_symbols-c'
15fi