summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch b/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch
new file mode 100644
index 00000000..aee0934a
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/dnn/files/0001-src-CMakeLists.txt-fix-FindOpenCL.cmake-source-path.patch
@@ -0,0 +1,34 @@
1From 89ebbee73ff0af48eaaec63335b749a176a317bb Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 21 Apr 2020 09:18:09 +0800
4Subject: [PATCH 1/2] src/CMakeLists.txt: fix FindOpenCL.cmake source path
5
6The existing logic doesn't work when DESTDIR is being passed to cmake.
7The file is installed in DESTDIR/CMAKE_INSTALL_PREFIX/libdir while we're
8trying to copy it from CMAKE_INSTALL_PREFIX/libdir.
9
10Use the file from source tree instead.
11
12Upstream-Status: Submitted
13
14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
15---
16 src/CMakeLists.txt | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
20index 88e318923..0c99fefae 100644
21--- a/src/CMakeLists.txt
22+++ b/src/CMakeLists.txt
23@@ -203,7 +203,7 @@ if(DNNL_GPU_RUNTIME STREQUAL "OCL")
24 install(FILES
25 "../cmake/FindOpenCL.cmake"
26 DESTINATION ${LIB_CONFIG_INSTALL_DIR})
27- install(FILES "${CMAKE_INSTALL_PREFIX}/${LIB_CONFIG_INSTALL_DIR}/FindOpenCL.cmake"
28+ install(FILES "../cmake/FindOpenCL.cmake"
29 DESTINATION ${LIB_CONFIG_INSTALL_DIR_COMPAT})
30 endif()
31
32--
332.25.3
34